(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Previously, ownership and permissions of AF_UNIX sockets created by
make-inetd-constructor and make-systemd-constructor were not set,
leaving the socket with root:root and 755 permissions.
modules/shepherd/service.scm (endpoint->listening-socket): fix chown and
chmod calls
---
modules/shepherd/service.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (15 lines)
diff --git a/modules/shepherd/service.scm b/modules/shepherd/service.scm
index 41c6248..f22aaaf 100644
--- a/modules/shepherd/service.scm
+++ b/modules/shepherd/service.scm
@@ -1867,8 +1867,8 @@ retrying to bind it in one second.")
(listen sock backlog)
(when (= AF_UNIX (sockaddr:fam address))
- (chown sock owner group)
- (chmod sock #o666))
+ (chown (sockaddr:path address) owner group)
+ (chmod (sockaddr:path address) #o666))
sock))))
--
2.43.0