[PATCH] gnu: skalibs: Correct symlink permissions on the hurd.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 1 years ago
(address . guix-patches@gnu.org)
52c1fda3674c848f5569fa35427921938aa140a2.1702472497.git.mail@cbaines.net
* gnu/packages/skarnet.scm (skalibs)[arguments]: Patch tools/install.sh umask.

Change-Id: Ia431a06d6150b33562dcf0f57eb3ba0fd84ba864
---
gnu/packages/skarnet.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index 6781e2eb58..eef4e6b6f9 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -42,8 +42,12 @@ (define-public skalibs
(arguments
'(#:tests? #f ; no tests exist
#:phases (modify-phases %standard-phases
- (add-after 'unpack 'reproducible
+ (add-after 'unpack 'patch
(lambda _
+ ;; This umask makes the symlinks in lib readable on
+ ;; i586-gnu
+ (substitute* "tools/install.sh"
+ (("umask 077") "umask 033"))
;; Sort source files deterministically so that the *.a
;; and *.so files are reproducible.
(substitute* "Makefile"

base-commit: 5f812344d293e5faaca44eeaab3b889fa6cb7e33
--
2.41.0
Christopher Baines wrote 1 years ago
(address . 67812-done@debbugs.gnu.org)
87sf3uw32a.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (28 lines)
> * gnu/packages/skarnet.scm (skalibs)[arguments]: Patch tools/install.sh umask.
>
> Change-Id: Ia431a06d6150b33562dcf0f57eb3ba0fd84ba864
> ---
> gnu/packages/skarnet.scm | 6 +++++-
> 1 file changed, 5 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
> index 6781e2eb58..eef4e6b6f9 100644
> --- a/gnu/packages/skarnet.scm
> +++ b/gnu/packages/skarnet.scm
> @@ -42,8 +42,12 @@ (define-public skalibs
> (arguments
> '(#:tests? #f ; no tests exist
> #:phases (modify-phases %standard-phases
> - (add-after 'unpack 'reproducible
> + (add-after 'unpack 'patch
> (lambda _
> + ;; This umask makes the symlinks in lib readable on
> + ;; i586-gnu
> + (substitute* "tools/install.sh"
> + (("umask 077") "umask 033"))
> ;; Sort source files deterministically so that the *.a
> ;; and *.so files are reproducible.
> (substitute* "Makefile"
>
> base-commit: 5f812344d293e5faaca44eeaab3b889fa6cb7e33

Pushed to master as f18f59fa4b249bbde6290ac5b91f6cd524b60848.

I also restored i586-gnu in the supported-systems.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmWFyX1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcDQg/9E6KV6SR7ZGTa1GqjmCC+3ezlpi6QKubJ
ypuFtjqVJnbVS1lxMofbVV0xSVLlPZLvF+lHrX0z0xDhWt8q7g1rLzVDPKMp6Bbf
Hkwuu6tAEKDJoJt0Yv9AvTMhtzlPwBXiof7WAJWzGn5MhRffYWeQweKoQJBr6UVP
BtT31RkXiWG0gXkTRawqPJwKaBtEOc1JyiKWl8l4ql0ijiFtqz5lxJ/6MLtb+vi/
gYBLnP3EINd6eyBETuzF/35nSQpReMiWcr4Xq8ykDuB6/uiZTbBiVtjxehYoAxyz
GICq3S7G3HqfrIYtA22du5iJL62+ytQX4oL/rdn4uztmj7vuBtopKmedUd9E9DUI
IgGF2F288cFj12FlcAknEq9Ix5aw22HWVhF3OZT0X15xBwDDd2p/cQYKe+ZScIIo
GIVcqAE5HVphPpRLHnqxSxCdhuR5YC7wYvqY/6dhWv7511yzhTWDpNJrG9M7Lxkt
wSMeo//GhKw+PCnmDfuMAQMZa4iPO2aNagpnOgex8qgKL0FlGJbqDLHFGwMwvLuL
08juJ75GhUd9g1vU3k6d3bbHVnbbrPoAgzQQ04Aige5eCvYy6hlc9zPzrBYLlRhD
ZIIHBwqYpA2TCKaDfb2vAiEIUkmewn02Vq3Td7IUNuw9tsrtQnGVsNzEb0pIDYwu
K0Usnpb1GRg=
=C9cR
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67812@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67812
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help