Christopher Baines wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/skarnet.scm (skalibs)[arguments]: Patch tools/install.sh umask.
Change-Id: Ia431a06d6150b33562dcf0f57eb3ba0fd84ba864
---
gnu/packages/skarnet.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
Toggle diff (22 lines)
diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index 6781e2eb58..eef4e6b6f9 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -42,8 +42,12 @@ (define-public skalibs
(arguments
'(#:tests? #f ; no tests exist
#:phases (modify-phases %standard-phases
- (add-after 'unpack 'reproducible
+ (add-after 'unpack 'patch
(lambda _
+ ;; This umask makes the symlinks in lib readable on
+ ;; i586-gnu
+ (substitute* "tools/install.sh"
+ (("umask 077") "umask 033"))
;; Sort source files deterministically so that the *.a
;; and *.so files are reproducible.
(substitute* "Makefile"
base-commit: 5f812344d293e5faaca44eeaab3b889fa6cb7e33
--
2.41.0