(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
Change-Id: I4d83a15ea4c24b2efb1300c29d56cb222993e7f3
---
gnu/packages/maths.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0f4d29b40f..d3774003f2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -10020,3 +10020,28 @@ (define-public bliss
+and canonical forms of graphs. It has both a command line user interface as
+well as C++ and C programming language APIs.")
(license license:lgpl3)))
+
+(define-public exprtk
+ (package
+ (name "exprtk")
+ (home-page "https://www.partow.net/programming/exprtk/index.html")
+ (synopsis "C++ Mathematical Expression Parsing And Evaluation Library")
+ (description
+ "The C++ Mathematical Expression Toolkit Library (ExprTk) is
+a versatile, simple to use, easy to integrate and extremely efficient runtime
+mathematical expression parser and evaluation engine. ExprTk supports
+numerous forms of functional, logical and vector processing semantics and is
+very easily extendible.")
+ (license license:expat)
+ (version "0.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ArashPartow/exprtk")
+ (commit version)))
+ (sha256
+ (base32 "1w92qlfjpcan38d88fak3avq81lkcpai5mqpbvrsfv04mi5nfpk5"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("exprtk.hpp" "include/"))))))
base-commit: baeff7f546d700ae4f0c873bd0fce0ca84bebd21
--
2.34.1