[PATCH] gnu: maths: Add exprtk package.

  • Open
  • quality assurance status badge
Details
2 participants
  • Lars Bilke
  • Steve George
Owner
unassigned
Submitted by
Lars Bilke
Severity
normal
L
L
Lars Bilke wrote on 12 Dec 2023 10:59
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
1efe619bbe4237820fd2d8e70039e7371d352839.1702375156.git.lars.bilke@ufz.de
Change-Id: I4d83a15ea4c24b2efb1300c29d56cb222993e7f3
---
gnu/packages/maths.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0f4d29b40f..d3774003f2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -10020,3 +10020,28 @@ (define-public bliss
+and canonical forms of graphs. It has both a command line user interface as
+well as C++ and C programming language APIs.")
(license license:lgpl3)))
+
+(define-public exprtk
+ (package
+ (name "exprtk")
+ (home-page "https://www.partow.net/programming/exprtk/index.html")
+ (synopsis "C++ Mathematical Expression Parsing And Evaluation Library")
+ (description
+ "The C++ Mathematical Expression Toolkit Library (ExprTk) is
+a versatile, simple to use, easy to integrate and extremely efficient runtime
+mathematical expression parser and evaluation engine. ExprTk supports
+numerous forms of functional, logical and vector processing semantics and is
+very easily extendible.")
+ (license license:expat)
+ (version "0.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ArashPartow/exprtk")
+ (commit version)))
+ (sha256
+ (base32 "1w92qlfjpcan38d88fak3avq81lkcpai5mqpbvrsfv04mi5nfpk5"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("exprtk.hpp" "include/"))))))

base-commit: baeff7f546d700ae4f0c873bd0fce0ca84bebd21
--
2.34.1
S
S
Steve George wrote on 1 Nov 2024 17:22
RE: Add exprtk package to Guix
(address . 67793@debbugs.gnu.org)
ZyUAOPUlCzHwOJd0@dragon2
Hi Lars,

I came across your patch and took a quick look. You seem to only install
the exprtk.hpp file, but the Github repository has lots of other things.
Is this what you intended?

Futurile
L
L
Lars Bilke wrote on 2 Jan 14:17 +0100
[PATCH v2] gnu: Add exprtk.
(address . 67793@debbugs.gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
456396e53d74e1e5df7cf2c7f381196d156e0289.1735823832.git.lars.bilke@ufz.de
* gnu/packages/maths.scm (exprtk): New variable.

Change-Id: I25e5a37cfd72b4b47dedc36916781b6ac355501e
---
gnu/packages/maths.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 22e2822c8c..de06e332eb 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -10826,3 +10826,23 @@ (define-public lie
(home-page "http://www-math.univ-poitiers.fr/~maavl/LiE/")
;; <http://www-math.univ-poitiers.fr/~maavl/LiE/> says LGPL.
(license license:lgpl3+)))
+
+(define-public exprtk
+ (package
+ (name "exprtk")
+ (home-page "https://www.partow.net/programming/exprtk/index.html")
+ (synopsis "C++ Mathematical Expression Parsing And Evaluation Library")
+ (description "A C++ library for mathematical expression parsing and evaluation")
+ (license license:expat)
+ (version "0.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ArashPartow/exprtk")
+ (commit version)))
+ (sha256
+ (base32 "0pszh11w29nc256qhil51g3635n06ncf0ihg7g4h86jrhqsk7183"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("exprtk.hpp" "include/"))))))

base-commit: ab43d883a0a88adbcfd3c3ab8d4c097cd9054b90
--
2.46.1
L
L
Lars Bilke wrote on 2 Jan 14:25 +0100
(address . 67793@debbugs.gnu.org)(address . slgeorge@futurile.net)
5E0AA0DA-2454-4F07-975B-55AAC05C7C88@ufz.de
Dear Futurile,

yes, copying exprtk.hpp only is intended. It contains the full (header-only) library. The license file is also copied into the store package.

Sincerely,
Lars
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67793@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67793
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch