[PATCH 10/10] gnu: rust-anstyle-wincon: Add version 3.0.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • Efraim Flashner
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
89875bd9310b68fd35a3a32c72b57df3@lyrion.ch
---
gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 60297370a2..b327c551c6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3565,6 +3565,29 @@ (define-public rust-anstyle-query-1
(description "Look up colored console capabilities")
(license (list license:expat license:asl2.0))))
+(define-public rust-anstyle-wincon-3
+ (package
+ (name "rust-anstyle-wincon")
+ (version "3.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "anstyle-wincon" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19v0fv400bmp4niqpzxnhg83vz12mmqv7l2l8vi80qcdxj0lpm8w"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-anstyle" ,rust-anstyle-1)
+ ("rust-windows-sys" ,rust-windows-sys-0.52))
+ #:cargo-development-inputs
+ (("rust-lexopt" ,rust-lexopt-0.3))))
+ (home-page "https://github.com/rust-cli/anstyle")
+ (synopsis "Styling legacy Windows terminals")
+ (description "Styling legacy Windows terminals")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-anstyle-wincon-1
(package
(name "rust-anstyle-wincon")
--
2.43.0
Efraim Flashner wrote 1 years ago
(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 67784-done@debbugs.gnu.org)
ZYq8xUj4AXkZde0W@3900XT
Thanks. rust-anstyle-wincon-3 was already in guix so I changed this
patch to update it to 3.0.2.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmWKvMUACgkQQarn3Mo9
g1FvOhAAwGfiml5BRDxv6MClJtAEklFB/7IvnB/3odKP6xJCQE9xp8bBYtB3a2At
4qFpP5yCTcN+Y0PQIIvEauQPKE66kkfrABoorsR3frN3xA0bHx734TwYuSjZmWpR
4PwewrmXV3bA4o/uS86lmDFrYThPUrc9OBro5Fs4Z/kzxPa7mIBCu3P9FSFN6D/N
5uJF7JYlFmmAYbM9bYUFIjMzNtmwLAqydh5HL4oz/raUNw4VvSmUj+B6cubrAxEj
RzG/Rv8CoodTTGNePetxo4yp9UH3w/OjF0lkEBeCRgHtIS2dIgfPor+XHdX95xlW
NMkbHq/SZZRocXHhne7+A9ZjvmeZuDNKBuJdK9OBNA4EoxS7UWjD8CGlqzPxIcM9
tVHrn22LzIBms3X6iwPWMLnX8pZw1vBwZ4DXTbHKdo8lx0KwPzvF8klRarcq0Z82
KdUnWieo2eBkT76877oQGSEWqVXdbvRsURnAbsYd9sWvlFtobVOvd82q/EfBFuwv
0sOD3Y2B2Dudv2tiVmFjVjUbTzbnMT5Dvo+eLZCvRCqwfeKEVj/hg4fzs5n3JiLx
Va5Z7nMUuDRa5XJaXiM9yZTO7dvevxNLPm0x19qPd/T5wMdSQ/1KmmI/pe5opk5D
i00hqh/Vva9f9Ga3RmPj87EP69FeYgyT4H5aamZarTPYcbbEEHc=
=KX2s
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67784@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67784
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help