[PATCH 06/10] gnu: rust-windows-x86-64-gnu: Add 0.52.

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • Efraim Flashner
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
7366d124a108ec2757313e0b58c4ba4f@lyrion.ch
---
gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ca275e73f8..53687ec258 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -83717,6 +83717,28 @@ (define-public rust-windows-tokens-0.32
windows crate.")
(license (list license:expat license:asl2.0))))
+(define-public rust-windows-x86-64-gnu-0.52
+ (package
+ (name "rust-windows-x86-64-gnu")
+ (version "0.52.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_x86_64_gnu" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zdy4qn178sil5sdm63lm7f0kkcjg6gvdwmcprd2yjmwn8ns6vrx"))
+ (snippet
+ '(delete-file "lib/libwindows.0.52.0.a"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description
+ "This package provides code gen support for the windows crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-x86-64-gnu-0.48
(package
(name "rust-windows-x86-64-gnu")
--
2.43.0
Efraim Flashner wrote 1 years ago
(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 67783-done@debbugs.gnu.org)
ZYq8qVrh_m8JjUT_@3900XT
Thanks. Patch added to the rust-team branch.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmWKvKkACgkQQarn3Mo9
g1Fj1g/+MmV9qIHZkeqzIKNrc93Du+7FYOciRMwnbUByI5jJ1Z92mS6wcoMmi2qg
muiLlJPZ4oIAcinx8f5ddtq12mR7O7O6E+2i5luw7kd+v5G5bTJF1lmhSnVJX1sN
mP3CsRlCfVbkyVA7EDP1cauGUfmOmPesSrMXaivYUHJLW7t4RKzfk/kJaSKx6TB1
YxuOOq3X1cuDDXpSID/Vr7FYm4gp4mfDTC9usd48MSF4NnPDYzhzrXXw8snAoWe1
811gURSPDOZlO2THXlOlrKLRDaZUFqYGAZrQyhrAdWWRO0KXGTYQgb0Yht4VJiO0
R5UOtNDt0bSK4RjsEAa3bL84y4McCksara0bUGxAxHvcpbIe0WKZvIrzBBoy+cgg
aVSXOECfERpJK5SOHU/Cegfj4Q0g5/HrvqWYlJ4AAbrLEFpKxNlZlHDKTIixxhc0
5md4iPc2pkqcJ3rvXpoZ6MU+VwUH4OvEvH8dBcISZZsglyCvBJ2kz57/5zv9DzN1
gPjYWICFOnIGrqd8iSYm+5wCuzkWzR6DPUpu5wFwRfX/WcTms2QLGpEBj7K7X5WS
BleupYjupal02KlprgRwjd1dgqsXReAyxE1Ls2iGzRAGuTf2hSXM6lPqnirzXKTA
iuGrwjZWxJxUwY35/Gln6uev67dKMs7evlUyPdPN9bNV0EuP7OQ=
=+TJ3
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67783@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67783
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help