[PATCH 09/10] gnu: rust-windows-targets: Add 0.52.

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • Efraim Flashner
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
af291dccd62fa6778af19d23597556f8@lyrion.ch
---
gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 73f314a5df..60297370a2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -83648,6 +83648,33 @@ (define-public rust-windows-macros-0.9
(description "Macros for the windows crate")
(license (list license:expat license:asl2.0))))
+(define-public rust-windows-targets-0.52
+ (package
+ (name "rust-windows-targets")
+ (version "0.52.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows-targets" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1kg7a27ynzw8zz3krdgy6w5gbqcji27j1sz4p7xk2j5j8082064a"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-windows-aarch64-gnullvm" ,rust-windows-aarch64-gnullvm-0.52)
+ ("rust-windows-aarch64-msvc" ,rust-windows-aarch64-msvc-0.52)
+ ("rust-windows-i686-gnu" ,rust-windows-i686-gnu-0.52)
+ ("rust-windows-i686-msvc" ,rust-windows-i686-msvc-0.52)
+ ("rust-windows-x86-64-gnu" ,rust-windows-x86-64-gnu-0.52)
+ ("rust-windows-x86-64-gnullvm" ,rust-windows-x86-64-gnullvm-0.52)
+ ("rust-windows-x86-64-msvc" ,rust-windows-x86-64-msvc-0.52))))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description
+ "This package provides code gen support for the windows crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-targets-0.48
(package
(name "rust-windows-targets")
--
2.43.0
Efraim Flashner wrote 1 years ago
(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 67782-done@debbugs.gnu.org)
ZYq8vXJNQhOWIZLS@3900XT
Thanks. Patch added to the rust-team branch.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmWKvL0ACgkQQarn3Mo9
g1Hg9RAAu4WChvYuWfaMZeqo7cjYwhKVPfEnuWqukB+qSD2yf6vayrjdUacynyU0
6xgOPl/U5dr0YB4PHMozLLCFr0N0/+0jXVKSxtqQajtTNobelFFmUQlkMDKmAW5T
LPKUWoZiNbTY5tjpRTVABGeK23dt6E/WJyXj/mAFFfdlQII9jhjgbQkjlpO/RXwD
rTwCEazdreX4JBoOcK7/5L7eMkuQHLr7sQ3B10WU85RI0jOxY0QDyveiBlhTaw1y
gKVfZetlXLi0MD/E9DLOvt3Yk3CuIJihZSLheIRzRnb5TIv7mFaOtFizkD5f55of
9ZwM9Wm6fjlmZq6c3tAP2EBMH2acoc/42fc1juqZnf3eYWBAo83y+kUQ2TVXJj0W
D2c1XmK2c9lmtgYGyMJk8hL6Oibh5vH3uidiQB4pUpoGmucJza0+9+rhGETZk07N
49cfFXcxnf3byeQmfX/guaEjQSPJI8L0ScagTz8paXwfHoGlX6/K8ZCvWG4pRPVf
bCUYqJzeXDFczdHg11Cugc7emv4QcGnkW1NHp0eCixALglo3H7kC3cJsPhFt2LdM
nHUX4jeoBdjTnbu/KVkHhDn1sVPFLLZo/0Z1MJDpHl+Nh2+a4n1RvK/bbR+kymws
f3LesyGhNx5mJ8AwMqH32H2IEXLwdrgeWw9GHbP5TbA9sR4Firs=
=Ygkj
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67782@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67782
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help