[PATCH 08/10] gnu: rust-windows-x86-64-msvc: Add 0.52.

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • Efraim Flashner
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
1821fe7efeaba5a7db53b3d8fd787764@lyrion.ch
---
gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 93ea78000e..73f314a5df 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -83878,6 +83878,27 @@ (define-public rust-windows-x86-64-gnullvm-0.42
'(delete-file "lib/libwindows.a"))))
(arguments (list #:skip-build? #t))))
+(define-public rust-windows-x86-64-msvc-0.52
+ (package
+ (name "rust-windows-x86-64-msvc")
+ (version "0.52.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_x86_64_msvc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "012wfq37f18c09ij5m6rniw7xxn5fcvrxbqd0wd8vgnl3hfn9yfz"))
+ (snippet
+ '(delete-file "lib/windows.0.52.0.lib"))))
+ (build-system cargo-build-system)
+ (arguments (list #:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description
+ "This package provides code gen support for the windows crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-x86-64-msvc-0.48
(package
(name "rust-windows-x86-64-msvc")
--
2.43.0
Efraim Flashner wrote 1 years ago
(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 67781-done@debbugs.gnu.org)
ZYq8tRFK4H7Q9V7l@3900XT
Thanks. Patch added to the rust-team branch.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmWKvLUACgkQQarn3Mo9
g1H70w/+MwkUqXMHuQtBaYY5+h7777RZEDqVl14lkjO+kIFLq7+5YnTe2IcOLvAD
qjrPOgEf4Pvh2/FA0HqFhZCXS7JFvxi/F8vNsZG5Pxv4ehL3YG3gBryfv7r8vODv
B12Nmr1RKzQfRlFIHniq4IB4RUxMvYkQZkDeHbZj02uzDq7FIZf9iWoBPdJNcu/Z
zvGfBiwueMvG5/Ug0Xd23fcWwsEZ5PtUrfDoN1ie1sleXUOjTouZLk79LKOL4ArM
pry6bV8NYkakIDjIBH8FLM2RTT3XinUpphvQ0nZ0O/P20hmoNijr1L8lRgqIULay
AOMV4P6O0Aa+4cdPqbMEGD5pY/umu8n97gf0mqKwJ6LlHIxfXBnkzh2ID+abBdW3
c6m/Rje0qyvOKZFB6siM8l8r+3Oct66NEyMP2N3nd16p27o6BaIXT3ChmAuGMlu2
1gLrEag4Hy3zmFMz9N+lTW4hGtnvalFGdaMtwiatEsJCq/FcES6o6vOGXqbyaw0a
Rdjhot3S0ZK0+u4uojSYKwHYRHGjKlpwv2fxIcGCT9rWQyy+3YPGy/bmsHqAP+wH
3oNMq0oHr2YPkYwHcXY3vKrg/VJ47+03D8btlgooYbj0+t7cliGL0zIec7HQ++ZS
xSfBF5oAz04LKa28YrdqhN5AzRHRviRTHYeSpnTmxX5Q8dTGHuw=
=0C41
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67781@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67781
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help