[PATCH 03/10] gnu: rust-windows-aarch64-msvc: Add 0.52.

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • Efraim Flashner
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
677f23f650b87d804f742f1791762f47@lyrion.ch
---
gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d79f9cb5ed..f4629b3ebe 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -83102,6 +83102,28 @@ (define-public rust-windows-aarch64-gnullvm-0.42
(arguments
(list #:skip-build? #t))))
+(define-public rust-windows-aarch64-msvc-0.52
+ (package
+ (name "rust-windows-aarch64-msvc")
+ (version "0.52.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_aarch64_msvc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vvmy1ypvzdvxn9yf0b8ygfl85gl2gpcyvsvqppsmlpisil07amv"))
+ (snippet
+ '(delete-file "lib/windows.0.52.0.lib"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description "This package provides code gen support for the windows
+crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-aarch64-msvc-0.48
(package
(name "rust-windows-aarch64-msvc")
--
2.43.0
Efraim Flashner wrote 1 years ago
(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 67779-done@debbugs.gnu.org)
ZYq8mJadcJJtI6nY@3900XT
Thanks. Patch added to the rust-team branch.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmWKvJgACgkQQarn3Mo9
g1E9LhAAlJjmw7M9scj2xrw9c783/sDk65N6GLZ34ArlY5PGJ3r20aLOtuwXhPN9
RjQ7/GkTtZx0c0O+7isUmYnNnx7O83OcFH9+r/RrGLddqup4I6jiJFbnAr5NRGxM
SFYbx9Ad/UbfgAnS1cmpexy1uYqu5wZ8jnqWB4UuR7crhqESGao3bv3jyAZcW22S
JAJPNe9vwmaXMFYLLJgkzRU9zEWrvwRnZ/lOp+60kFGkKC6wCNHQTNssG9zaIaGn
UIPl4qyrrNObb6AmKA99vna1y5QWIXIP3Z6xIDT5yRL39IiaVfpwedaOi0OfYsam
gy3gaVziDtvUGvrzc2YA0zGlz+vgeFgYNyobDxYJ6NQdQtHzOt5dfI2ru6ntnDl/
MJ4GQeMdzTX4F7OAf2AT2o161XyZkO/xY+W/FKUJg8XAvR01w3wZgJomzfn3P7Tn
LBTohkZTmuPfy0k5oUm1SksFKnD3hJcSfNSDDlHe1oQRgCezCs9padSWvDhlAnRd
E8ei1vXQ9F5SSLfPC7J9q4M5oFne7oiYCEpQip9CTDX7qBoTLNa4dw1gH1jmfs79
FYU3w1uzV0hkvCrg0s6feSi94Hzq4BALXfOuNtmRNNtnK8amL88qCHBGY9hRkvx6
oAXM/+tCOTkHyhAgpXT9LRRnGsXEkz+tIF5Ef9xWqLvbqWWtxb0=
=/NV1
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67779@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67779
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help