[PATCH 04/10] gnu: rust-windows-i686-gnu: Add 0.52.

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • Efraim Flashner
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
ea00be2dfd9ac29a2f0d6874407e158d@lyrion.ch
---
gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f4629b3ebe..2a6274309a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -83205,6 +83205,28 @@ (define-public rust-windows-aarch64-msvc-0.28
(base32
"1hpk0n2z0jzzvwlvs98b75sa4q920953nqfc119rv19nwm0mlsaj"))))))
+(define-public rust-windows-i686-gnu-0.52
+ (package
+ (name "rust-windows-i686-gnu")
+ (version "0.52.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_i686_gnu" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04zkglz4p3pjsns5gbz85v4s5aw102raz4spj4b0lmm33z5kg1m2"))
+ (snippet
+ '(delete-file "lib/libwindows.0.52.0.a"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description
+ "This package provides code gen support for the windows crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-i686-gnu-0.48
(package
(name "rust-windows-i686-gnu")
--
2.43.0
Efraim Flashner wrote 1 years ago
(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 67778-done@debbugs.gnu.org)
ZYq8nswb1SX2pQDl@3900XT
Thanks. Patch added to the rust-team branch.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmWKvJ4ACgkQQarn3Mo9
g1EiXQ//Q5Pg2FTQBKIkaP+6zxcxnjaGDuiwaV4WHYuGUBrbbTpJOA4JvrldNTV5
GXq+w0glvTM71/2ck90cpgJPFpHKTTegkRtn+8jbl+u06NRKEUTpy9rgeRtI959X
k5dzwME8uVZBriQ/EK4Ld92zUMAk2jBwLffu4V1PA8NQMBIZxUPbbVRH8b5VNyNx
Z9XvpgkBnioFrwCvuyjHSNNj9o5PmpvnuX0WBQv18tG38rN7OFtTiIIvWB8I9PB9
2nTddYksJLC/62rjlUYFV5Ol1Qw3jJNW0bbUH6UsGhN3v7rtjHfCk+Cf33LCJt0F
PgPSRSmhU8gLcFQQPOfGe7kR26E404Ot4g9muPiNVx8TZ55SNmZUb7zFYoIwK4Ur
Oxgbdtw4HMpw705bqzBsrOQXbrPTwbCTF2VP3bAihq1W6V8+gXTuAjuY02eFVuqg
3sj1UZI6juqcNzlnarKabVqY6KqLrCJma1A9mJ4hIkYgbjpm1B5yL9lw20ZJxhU+
MDT3DS2vsO7ANsuTVx76pwAqUpEuXGvwXUkoooOHB3Smh33zcFyI6gzrpMxNp/ij
zyzc5xEyuWCRRSsk/LtdIh83+0oRJfwBmAcVJNfmTC6kQFqMVnlKIc+MOYcri7sN
1YZ2RWnNRLADdDV1YjjritfeB4dFufYHDjdoGT9DdK43mLkifF4=
=7yM7
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67778@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67778
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help