[PATCH 05/10] gnu: rust-windows-i686-msvc: Add 0.52.

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • Efraim Flashner
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal

Debbugs page

Daniel Ziltener wrote 1 years ago
(address . guix-patches@gnu.org)(address . dziltener@lyrion.ch)
0296513b6e058418bd7ce6764f48d9de@lyrion.ch
---
gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2a6274309a..ca275e73f8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -83308,6 +83308,28 @@ (define-public rust-windows-i686-gnu-0.28
(base32
"12hx7qpsjg9p7jggfcplqa3mf1mzr7k7s5ybzqwg1zmg4fn2aizm"))))))
+(define-public rust-windows-i686-msvc-0.52
+ (package
+ (name "rust-windows-i686-msvc")
+ (version "0.52.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_i686_msvc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16kvmbvx0vr0zbgnaz6nsks9ycvfh5xp05bjrhq65kj623iyirgz"))
+ (snippet
+ '(delete-file "lib/windows.0.52.0.lib"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:skip-build? #t))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Code gen support for the windows crate")
+ (description
+ "This package provides code gen support for the windows crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-i686-msvc-0.48
(package
(name "rust-windows-i686-msvc")
--
2.43.0
Efraim Flashner wrote 1 years ago
(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 67777-done@debbugs.gnu.org)
ZYq8o2d18SYQojxV@3900XT
Thanks. Patch added to the rust-team branch.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmWKvKMACgkQQarn3Mo9
g1FuWRAAm2Ep3STpQb4gcDYDMKqZAf/tVffBlzcGadajglTCqyDSarcAmyEXKeX8
Ma9MXII0N/yuSMWB3589jSULk5OPa4jrYAioNvIaHxq69wQOSGN/Jx4aGieylVyL
2RdS77NCgEvqP2j22aQ3Qf+jNFsRzSx2ofmQBQg/iFhlIYVBW61bv7OxSKPWC6md
APfq3IyzRZLg/niIl3q9OH1VFdurmmRrGPRZpQ74lPTUMjhMUuUpBU6Mrc+/paFd
k4WVC19RY6m+eA0ct2VaIP2zGaKalBrLtZ5/KbCccPBFSmo0/WvtkTclc4ma3IQT
yjybReMfFbFSuPrpCFGTuyFnafTC6INH60XsV5NSGZDHNbBsit7UoiKzSU5vbqhz
b9N2WbdXQMg7M5R7T9ZFWuNtoIIy9XpP+984eaPbKXE4y7DPscytY6IHaE0z8RIq
b0RSOVuWIvhN0j9ci1o0cxy0t8IAE1rV8lDFkexMsaGI/0no8epreYUyrddh35Ls
jV7jom93gl5wdgpPVyGPTlEB2gob7BUDaJbJOlXv9zp9R92mTSJYzhvA4huFNyMh
qu5dvDtnTWiTS6ptQEO/C4Txfwj55Viwlz9aw5986IUtN8oi2auMW6AkB8q6Oib/
MA5t8EyoRgkR3z0XfobFwRqxiT38l3vyU/PaeTEXbT8Kdz6L2G0=
=+S0h
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67777@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67777
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help