[PATCH 1/2] gnu: qbe: Update to d023bdaa6.

  • Open
  • quality assurance status badge
Details
2 participants
  • Timmy Douglas
  • Steve George
Owner
unassigned
Submitted by
Timmy Douglas
Severity
normal
T
T
Timmy Douglas wrote on 10 Dec 2023 08:11
(address . guix-patches@gnu.org)(name . Timmy Douglas)(address . mail@timmydouglas.com)
25394f16bfd70d3a7f21a26672407a89ce98dde2.1702192273.git.mail@timmydouglas.com
* gnu/packages/c.scm (qbe): Update to d023bdaa6.

Change-Id: I71c03bd49d7acb91a34837e48e5dd088763d1353
---
gnu/packages/c.scm | 67 +++++++++++++++++++++++++---------------------
1 file changed, 36 insertions(+), 31 deletions(-)

Toggle diff (90 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index ac83336ba5..a7e63a16e0 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © 2023 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2023 Timmy Douglas <mail@timmydouglas.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -324,38 +325,42 @@ (define-public pcc
(license (list license:bsd-2 license:bsd-3))))
(define-public qbe
- (package
- (name "qbe")
- (version "1.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://c9x.me/qbe")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "07nl1kdgpz7hwfkng0yy4xihk0fmv1a2hq9bxzgvhy3vk9r7fmn8"))))
- (build-system gnu-build-system)
- (arguments
- (list #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target))
- (string-append "PREFIX=" #$output))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'allow-cross-compilation
- (lambda _
- (substitute* "Makefile"
- (("`uname -m`") #$(or (%current-target-system)
- (%current-system))))))
- (delete 'configure))))
- (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
- (synopsis "Simple compiler backend")
- (description
- "QBE is a small compiler backend using an SSA-based intermediate
+ (let ((revision "1")
+ (commit "d023bdaa6b493686f7e9be7ac200ee4ac37d351f"))
+ (package
+ (name "qbe")
+ (version (git-version "1.1.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://c9x.me/qbe")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11flr6mmxglidp4fr7whfzhwr1bjkiz0rcvpy541xmwm2isj5znm"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target))
+ (string-append "PREFIX="
+ #$output))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'allow-cross-compilation
+ (lambda _
+ (substitute* "Makefile"
+ (("`uname -m`")
+ #$(or (%current-target-system)
+ (%current-system))))))
+ (delete 'configure))))
+ (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
+ (synopsis "Simple compiler backend")
+ (description
+ "QBE is a small compiler backend using an SSA-based intermediate
language as input.")
- (home-page "https://c9x.me/compile/")
- (license license:expat)))
+ (home-page "https://c9x.me/compile/")
+ (license license:expat))))
(define-public python-pcpp
(package

base-commit: 2e11caff39d502775d7c652972a441f5da3d9eec
--
2.41.0
S
S
Steve George wrote on 31 Oct 14:49 +0100
RE: update qbe in Guix
(address . 67739@debbugs.gnu.org)
ZyOK6awM6_WDCKTX@dragon2
Hi Timothy,

I found your patch to update qbe, there's a new release to 1.2. Are you
able to update your patch?


Futurile
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67739@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67739
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch