My first package: libsurvive

  • Open
  • quality assurance status badge
Details
2 participants
  • Tobias Alexandra Platen
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Tobias Alexandra Platen
Severity
normal

Debbugs page

Tobias Alexandra Platen wrote 1 years ago
(address . guix-patches@gnu.org)
33287c7e32d41871bc7071748a0cc9ecb5592812.camel@platen-software.de
I've tried to follow the rules documented in[1] and run guix lint and
currenty dont know how to fix the warnings. I made the release and
pushed it to codeberg.

gnu/packages/hardware.scm:1051:6: warning: no valid tags found for
libsurvive
gnu/packages/hardware.scm:1051:6: libsurvive@2023.12: updater 'generic-
git' failed to find upstream releases
gnu/packages/hardware.scm:1051:6: libsurvive@2023.12: scheduled
Software Heritage archival

From 0e6cda8957e4b4f37187dcda5cace66602eb8401 Mon Sep 17 00:00:00 2001
From: Tobias Platen <tplaten@posteo.de>
Date: Sat, 9 Dec 2023 12:53:00 +0100
Subject: [PATCH 1/1] gnu: Add libsurvive

---
gnu/packages/hardware.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 59b95ab7c8..fdbd21a018 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -38,6 +38,7 @@ (define-module (gnu packages hardware)
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
@@ -1049,6 +1050,33 @@ (define-public openhmd
technology, such as head mounted displays with built in head tracking.")
(license license:boost1.0)))
+(define-public libsurvive
+ (package
+ (name "libsurvive")
+ (version "2023.12")
+ (source
+ (origin ;;TODO: make release
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/LibreVR/libsurvive")
+ (recursive? #t)
+ (commit "v2023.12.rc0"))) ;; make a final release this year
+ (file-name (git-file-name name version))
+ (sha256 (base32 "0fkdgvpm987yl5q6yq0979cfj99ffi6k0dpmddlpxfm2rngn85r5"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ;; no tests in this version
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list hidapi eigen eudev))
+ (home-page "https://codeberg.org/LibreVR/libsurvive")
+ (synopsis "Lighthouse Tracking for LibreVR")
+ (description "Libsurvive is a set of tools and libraries that enable Lighthouse
+Tracking on various devices, including HTC Vive and the well known Valve Index.
+It currently supports both SteamVR 1.0 and SteamVR 2.0 generation of devices,
+future versions will support more hardware and the survive_link protocol.")
+ (license license:expat)))
+
(define-public openrgb
(package
(name "openrgb")
--
2.39.2
From 0e6cda8957e4b4f37187dcda5cace66602eb8401 Mon Sep 17 00:00:00 2001
From: Tobias Platen <tplaten@posteo.de>
Date: Sat, 9 Dec 2023 13:01:04 +0100
Subject: [PATCH 0/1] *** SUBJECT HERE ***

*** BLURB HERE ***

Tobias Platen (1):
gnu: Add libsurvive

gnu/packages/hardware.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)


base-commit: 61f2d84e75c340c2ba528d392f522c51b8843f34
--
2.39.2
Nicolas Goaziou wrote 4 days ago
(address . 67727@debbugs.gnu.org)(name . Tobias Alexandra Platen)(address . alex@platen-software.de)
87h6429uwn.fsf@nicolasgoaziou.fr
Hello,

Toggle quote (2 lines)
> +(define-public libsurvive

Thank you!

Toggle quote (10 lines)
> + (package
> + (name "libsurvive")
> + (version "2023.12")
> + (source
> + (origin ;;TODO: make release
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://codeberg.org/LibreVR/libsurvive")
> + (recursive? #t)

Can you unbundle whatever is pulled in submodules and avoid using
#:recursive?

Toggle quote (2 lines)
> + (commit "v2023.12.rc0"))) ;; make a final release this year

Nitpick: end of line comments use a single semicolon.

It is also not a good idea to introduce a mismatch between version and
commit. It this situation, you can either use "2023.12.rc0" for version
and (string-append "v" version) for commit, or use a raw commit hash,
bound to `commit' and bind "1" to `revision'. Then, version becomes
(git-version "2023.12" revision commit) and commit is set to… commit.

Toggle quote (5 lines)
> + (file-name (git-file-name name version))
> + (sha256 (base32 "0fkdgvpm987yl5q6yq0979cfj99ffi6k0dpmddlpxfm2rngn85r5"))))
> + (build-system cmake-build-system)
> + (arguments (list #:tests? #f)) ;; no tests in this version

Same remark as above about semicolon.

Toggle quote (5 lines)
> + (native-inputs
> + (list pkg-config))
> + (inputs
> + (list hidapi eigen eudev))

Please order inputs alphabetically.

Toggle quote (8 lines)
> + (synopsis "Lighthouse Tracking for LibreVR")
> + (description "Libsurvive is a set of tools and libraries that enable Lighthouse
> +Tracking on various devices, including HTC Vive and the well known Valve Index.
> +It currently supports both SteamVR 1.0 and SteamVR 2.0 generation of devices,
> +future versions will support more hardware and the survive_link
> protocol.")

Nitpick: @code{survive_link} protocol.

Would you want to send an updated patch?

Regards,
--
Nicolas Goaziou
Tobias Alexandra Platen wrote 4 days ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 67727@debbugs.gnu.org)
2739466711c968953c9faa8558ed1ee9ecd69bdf.camel@platen-software.de
On Sun, 2025-03-09 at 14:48 +0100, Nicolas Goaziou wrote:
Toggle quote (61 lines)
> Hello,
>
> > +(define-public libsurvive
>
> Thank you!
>
> > +  (package
> > +    (name "libsurvive")
> > +    (version "2023.12")
> > +    (source
> > +      (origin ;;TODO: make release
> > +        (method git-fetch)
> > +        (uri (git-reference
> > +              (url "https://codeberg.org/LibreVR/libsurvive")
> > +              (recursive? #t)
>
> Can you unbundle whatever is pulled in submodules and avoid using
> #:recursive?
>
> > +              (commit "v2023.12.rc0"))) ;; make a final release
> > this year
>
> Nitpick: end of line comments use a single semicolon.
>
> It is also not a good idea to introduce a mismatch between version
> and
> commit. It this situation, you can either use "2023.12.rc0" for
> version
> and (string-append "v" version) for commit, or use a raw commit hash,
> bound to `commit' and bind "1" to `revision'. Then, version becomes
> (git-version "2023.12" revision commit) and commit is set to… commit.
>
> > +        (file-name (git-file-name name version))
> > +        (sha256 (base32
> > "0fkdgvpm987yl5q6yq0979cfj99ffi6k0dpmddlpxfm2rngn85r5"))))
> > +    (build-system cmake-build-system)
> > +    (arguments (list #:tests? #f)) ;; no tests in this version
>
> Same remark as above about semicolon.
>
> > +    (native-inputs
> > +     (list pkg-config))
> > +    (inputs
> > +     (list hidapi eigen eudev))
>
> Please order inputs alphabetically.
>
> > +    (home-page "https://codeberg.org/LibreVR/libsurvive")
> > +    (synopsis "Lighthouse Tracking for LibreVR")
> > +    (description "Libsurvive is a set of tools and libraries that
> > enable Lighthouse
> > +Tracking on various devices, including HTC Vive and the well known
> > Valve Index.
> > +It currently supports both SteamVR 1.0 and SteamVR 2.0 generation
> > of devices,
> > +future versions will support more hardware and the survive_link
> > protocol.")
>
> Nitpick: @code{survive_link} protocol.
>
> Would you want to send an updated patch?
yes, but not today. Maybe in one month.
Toggle quote (2 lines)
>
> Regards,
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67727@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67727
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help