My first package: libsurvive

  • Open
  • quality assurance status badge
Details
One participant
  • Tobias Alexandra Platen
Owner
unassigned
Submitted by
Tobias Alexandra Platen
Severity
normal
T
T
Tobias Alexandra Platen wrote on 9 Dec 2023 13:14
(address . guix-patches@gnu.org)
33287c7e32d41871bc7071748a0cc9ecb5592812.camel@platen-software.de
I've tried to follow the rules documented in[1] and run guix lint and
currenty dont know how to fix the warnings. I made the release and
pushed it to codeberg.

gnu/packages/hardware.scm:1051:6: warning: no valid tags found for
libsurvive
gnu/packages/hardware.scm:1051:6: libsurvive@2023.12: updater 'generic-
git' failed to find upstream releases
gnu/packages/hardware.scm:1051:6: libsurvive@2023.12: scheduled
Software Heritage archival

From 0e6cda8957e4b4f37187dcda5cace66602eb8401 Mon Sep 17 00:00:00 2001
From: Tobias Platen <tplaten@posteo.de>
Date: Sat, 9 Dec 2023 12:53:00 +0100
Subject: [PATCH 1/1] gnu: Add libsurvive

---
gnu/packages/hardware.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 59b95ab7c8..fdbd21a018 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -38,6 +38,7 @@ (define-module (gnu packages hardware)
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
@@ -1049,6 +1050,33 @@ (define-public openhmd
technology, such as head mounted displays with built in head tracking.")
(license license:boost1.0)))
+(define-public libsurvive
+ (package
+ (name "libsurvive")
+ (version "2023.12")
+ (source
+ (origin ;;TODO: make release
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/LibreVR/libsurvive")
+ (recursive? #t)
+ (commit "v2023.12.rc0"))) ;; make a final release this year
+ (file-name (git-file-name name version))
+ (sha256 (base32 "0fkdgvpm987yl5q6yq0979cfj99ffi6k0dpmddlpxfm2rngn85r5"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ;; no tests in this version
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list hidapi eigen eudev))
+ (home-page "https://codeberg.org/LibreVR/libsurvive")
+ (synopsis "Lighthouse Tracking for LibreVR")
+ (description "Libsurvive is a set of tools and libraries that enable Lighthouse
+Tracking on various devices, including HTC Vive and the well known Valve Index.
+It currently supports both SteamVR 1.0 and SteamVR 2.0 generation of devices,
+future versions will support more hardware and the survive_link protocol.")
+ (license license:expat)))
+
(define-public openrgb
(package
(name "openrgb")
--
2.39.2
From 0e6cda8957e4b4f37187dcda5cace66602eb8401 Mon Sep 17 00:00:00 2001
From: Tobias Platen <tplaten@posteo.de>
Date: Sat, 9 Dec 2023 13:01:04 +0100
Subject: [PATCH 0/1] *** SUBJECT HERE ***

*** BLURB HERE ***

Tobias Platen (1):
gnu: Add libsurvive

gnu/packages/hardware.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)


base-commit: 61f2d84e75c340c2ba528d392f522c51b8843f34
--
2.39.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67727@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67727
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch