[PATCH] build: test-driver.scm: Set mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
0cb300dcdd10457c69f7b1f7e0e153c671906e33.1702048189.git.~@wolfsden.cz
Emacs auto-detects the build-aux/test-driver.scm as sh-mode, due to the
shebang. So override the auto-detection using a local variable forcing
scheme-mode.

* build-aux/test-driver.scm: Set mode to scheme.

Change-Id: I07f12656dba5fb7b52447b94569307a2a605ffc1
---
build-aux/test-driver.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (25 lines)
diff --git a/build-aux/test-driver.scm b/build-aux/test-driver.scm
index 1cdd4ff8f7..901f6ab9ec 100755
--- a/build-aux/test-driver.scm
+++ b/build-aux/test-driver.scm
@@ -3,7 +3,7 @@
!#
;;;; test-driver.scm - Guile test driver for Automake testsuite harness
-(define script-version "2021-02-02.05") ;UTC
+(define script-version "2023-12-08.14") ;UTC
;;; Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -274,6 +274,7 @@ (define (main . args)
(exit 0)))
;;; Local Variables:
+;;; mode: scheme
;;; eval: (add-hook 'write-file-functions 'time-stamp)
;;; time-stamp-start: "(define script-version \""
;;; time-stamp-format: "%:y-%02m-%02d.%02H"

base-commit: 99bf4840cec2e74d1824684dd8bd29511e904ba0
--
2.41.0
Maxim Cournoyer wrote 1 years ago
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 67712-done@debbugs.gnu.org)
87frzd4w2c.fsf@gmail.com
Hi,

Tomas Volf <~@wolfsden.cz> writes:

Toggle quote (8 lines)
> Emacs auto-detects the build-aux/test-driver.scm as sh-mode, due to the
> shebang. So override the auto-detection using a local variable forcing
> scheme-mode.
>
> * build-aux/test-driver.scm: Set mode to scheme.
>
> Change-Id: I07f12656dba5fb7b52447b94569307a2a605ffc1

Applied, thank you.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67712@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67712
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help