Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
Emacs auto-detects the build-aux/test-driver.scm as sh-mode, due to the
shebang. So override the auto-detection using a local variable forcing
scheme-mode.
* build-aux/test-driver.scm: Set mode to scheme.
Change-Id: I07f12656dba5fb7b52447b94569307a2a605ffc1
---
build-aux/test-driver.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (25 lines)
diff --git a/build-aux/test-driver.scm b/build-aux/test-driver.scm
index 1cdd4ff8f7..901f6ab9ec 100755
--- a/build-aux/test-driver.scm
+++ b/build-aux/test-driver.scm
@@ -3,7 +3,7 @@
!#
;;;; test-driver.scm - Guile test driver for Automake testsuite harness
-(define script-version "2021-02-02.05") ;UTC
+(define script-version "2023-12-08.14") ;UTC
;;; Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -274,6 +274,7 @@ (define (main . args)
(exit 0)))
;;; Local Variables:
+;;; mode: scheme
;;; eval: (add-hook 'write-file-functions 'time-stamp)
;;; time-stamp-start: "(define script-version \""
;;; time-stamp-format: "%:y-%02m-%02d.%02H"
base-commit: 99bf4840cec2e74d1824684dd8bd29511e904ba0
--
2.41.0