Build python-dm-tree.x86_64-linux on master is broken.

  • Open
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 4 Dec 2023 23:53
(name . bug-guix)(address . bug-guix@gnu.org)
87a5qpr33s.fsf@gmail.com
Hello,

cuirass@gnu.org (Cuirass) writes:

Toggle quote (6 lines)
> <p>The build <b>python-dm-tree.x86_64-linux</b> for specification <b>master</b> is
> broken. You can find the detailed information about this build <a
> href="https://ci.guix.gnu.org/build/2802866/details">here</a>.</p>
>
> https://ci.guix.gnu.org/build/2802866/details

Toggle snippet (25 lines)
starting phase `sanity-check'
validating 'dm-tree' /gnu/store/9xzpw6casxsg7pfw8hmky3b21hwyxas4-python-dm-tree-0.1.8/lib/python3.10/site-packages
...checking requirements: OK
...trying to load module tree: ERROR:
Traceback (most recent call last):
File "/gnu/store/iqsjkp55pcx5bfcp2jm9yj5rlx9a0whd-sanity-check.py", line 73, in <module>
importlib.import_module(name)
File "/gnu/store/0a75sq4c9sf8wrqw9gd2kg11cr013j68-python-3.10.7/lib/python3.10/importlib/__init__.py", line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 1050, in _gcd_import
File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
File "<frozen importlib._bootstrap>", line 1006, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 688, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 883, in exec_module
File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
File "/gnu/store/9xzpw6casxsg7pfw8hmky3b21hwyxas4-python-dm-tree-0.1.8/lib/python3.10/site-packages/tree/__init__.py", line 23, in <module>
from .sequence import _is_attrs
File "/gnu/store/9xzpw6casxsg7pfw8hmky3b21hwyxas4-python-dm-tree-0.1.8/lib/python3.10/site-packages/tree/sequence.py", line 19, in <module>
from tree import _tree
ImportError: /gnu/store/9xzpw6casxsg7pfw8hmky3b21hwyxas4-python-dm-tree-0.1.8/lib/python3.10/site-packages/tree/_tree.so: undefined symbol: _ZN4absl12lts_2023080213hash_internal15MixingHashState5kSeedE
error: in phase 'sanity-check': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("/gnu/store/iqsjkp55pcx5bfcp2jm9yj5rlx9a0whd-sanity-check.py" "/gnu/store/9xzpw6casxsg7pfw8hmky3b21hwyxas4-python-dm-tree-0.1.8/lib/python3.10/site-packages") exit-status: 1 term-signal: #f stop-signal: #f>
phase `sanity-check' failed after 0.2 seconds

I guess that may be related to the abseil-cpp upgrade in commit
af2735e874232d0ba46e2e943f0ba4697c42f70f.

--
Thanks,
Maxim
G
G
Greg Hogan wrote on 5 Dec 2023 20:48
[PATCH 2/2] gnu: python-dm-tree: Pin abseil-cpp version.
(address . 67632@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20231205194803.9919-2-code@greghogan.com
* gnu/packages/python-xyz.scm (python-dm-tree)[inputs]: Replace
static-abseil-cpp with static-abseil-cpp-20220623.1.

Change-Id: Ia83175c266eeea5bab9dac4282e39d9f71b06052
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9f458196fa..9b3c917e7a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5890,7 +5890,7 @@ (define-public python-dm-tree
;; We link the static abseil libraries here to avoid problems in
;; downstream libraries using potentially different variants of
;; abseil-cpp. This is also what's done in the upstream CMake build.
- (inputs (list pybind11 static-abseil-cpp python))
+ (inputs (list pybind11 static-abseil-cpp-20220623.1 python))
(propagated-inputs (list python-wheel
python-absl-py
python-attrs
--
2.40.1
G
G
Greg Hogan wrote on 5 Dec 2023 20:48
[PATCH 1/2] gnu: Add static-abseil-cpp-20220623.1.
(address . 67632@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20231205194803.9919-1-code@greghogan.com
* gnu/packages/cpp.scm (static-abseil-cpp-20220623.1): New variable.
(make-static-abseil-cpp): Parameterize base.

Change-Id: I9667914de031f431524bf195818e8d2f316e8553
---
gnu/packages/cpp.scm | 20 +++++++++++---------
1 file changed, 11 insertions(+), 9 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index f7549cb22a..c451033287 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1320,15 +1320,14 @@ (define (abseil-cpp-for-c++-standard base version)
(number->string version))
#$flags)))))))
-(define (make-static-abseil-cpp version)
- (let ((base abseil-cpp))
- (hidden-package
- (package/inherit base
- (arguments
- (substitute-keyword-arguments (package-arguments base)
- ((#:configure-flags flags)
- #~(cons* "-DCMAKE_POSITION_INDEPENDENT_CODE=ON"
- (delete "-DBUILD_SHARED_LIBS=ON" #$flags)))))))))
+(define (make-static-abseil-cpp base)
+ (hidden-package
+ (package/inherit base
+ (arguments
+ (substitute-keyword-arguments (package-arguments base)
+ ((#:configure-flags flags)
+ #~(cons* "-DCMAKE_POSITION_INDEPENDENT_CODE=ON"
+ (delete "-DBUILD_SHARED_LIBS=ON" #$flags))))))))
(define-public abseil-cpp-cxxstd17
(abseil-cpp-for-c++-standard abseil-cpp 17)) ;XXX: the default with GCC 11?
@@ -1339,6 +1338,9 @@ (define-public abseil-cpp-cxxstd11
(define-public static-abseil-cpp
(make-static-abseil-cpp abseil-cpp))
+(define-public static-abseil-cpp-20220623.1
+ (make-static-abseil-cpp abseil-cpp-20220623.1))
+
(define-public pegtl
(package
(name "pegtl")

--
2.40.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67632@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67632
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch