Build python-phenograph.x86_64-linux on master is broken.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 4 Dec 2023 23:05
(name . bug-guix)(address . bug-guix@gnu.org)
87zfypr5c8.fsf@gmail.com
Hi,

cuirass@gnu.org (Cuirass) writes:

Toggle quote (6 lines)
> <p>The build <b>python-phenograph.x86_64-linux</b> for specification <b>master</b> is
> broken. You can find the detailed information about this build <a
> href="https://ci.guix.gnu.org/build/2736972/details">here</a>.</p>
>
> https://ci.guix.gnu.org/build/2736972/details

The failure reads:

Toggle snippet (40 lines)
=================================== FAILURES ===================================
___________________________ test_classify_generated ____________________________

cluster_dataset_generated = <tests.conftest.GeneratedClusterDataset object at 0x7ffdcfdb90f0>

def test_classify_generated(cluster_dataset_generated):
output, _ = classify(
cluster_dataset_generated.train_set, cluster_dataset_generated.test_set
)
actual = cluster_dataset_generated.test_labels
> assert all([p == a for p, a in zip(output, actual)])
E assert False
E + where False = all([True, True, False])

tests/test_classify.py:9: AssertionError
----------------------------- Captured stdout call -----------------------------
Finding 30 nearest neighbors using minkowski metric and 'auto' algorithm
=============================== warnings summary ===============================
phenograph/cluster.py:13
/tmp/guix-build-python-phenograph-1.5.7.drv-0/PhenoGraph-1.5.7/phenograph/cluster.py:13: DeprecationWarning: Please use `spmatrix` from the `scipy.sparse` namespace, the `scipy.sparse.base` namespace is deprecated.
from scipy.sparse.base import spmatrix

tests/test_classify.py::test_classify_generated
tests/test_classify.py::test_classify_generated
tests/test_classify.py::test_classify_generated
tests/test_classify.py::test_classify_fixed
tests/test_classify.py::test_classify_fixed
tests/test_classify.py::test_classify_fixed
tests/test_classify.py::test_random_walk_probabilities_fixed
tests/test_classify.py::test_random_walk_probabilities_fixed
tests/test_classify.py::test_random_walk_probabilities_fixed
/tmp/guix-build-python-phenograph-1.5.7.drv-0/PhenoGraph-1.5.7/phenograph/classify.py:43: DeprecationWarning: Please use `bicgstab` from the `scipy.sparse.linalg` namespace, the `scipy.sparse.linalg.isolve` namespace is deprecated.
sp.linalg.isolve.bicgstab(Lu, b.T.todense(), atol="legacy") for b in B.T

-- Docs: https://docs.pytest.org/en/stable/how-to/capture-warnings.html
=========================== short test summary info ============================
FAILED tests/test_classify.py::test_classify_generated - assert False
=================== 1 failed, 5 passed, 10 warnings in 3.48s ===================

The test is probably flaky and should be reported upstream and disabled
in our package meanwhile.

--
Thanks,
Maxim
E
E
Efraim Flashner wrote on 16 Jul 20:55 +0200
Re: bug#67630: Build python-phenograph.x86_64-linux on master is broken.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 67630-done@debbugs.gnu.org)
ZpbCE9mQSGZrE6gR@pbp
This package appears to be building correctly now.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmaWwgkACgkQQarn3Mo9
g1HthA//dhzfCEI7NQsZkFWy6jEe+0IR3iagffMUWQI0X9rp7Ddc2fweExVgiz49
jgleeLchMN+zW8gUCAEbTfCH22tFaVYuxWeaCdvlh2OiMV7rU8vMYhKauJLEpP0K
GYDgqQklUeGPIHo4Dv0BOZgXQaSYtVo/Bk1ieAPijY6WcOybBM92E8QadjAp80aZ
lETsHeQsP7hND2e0aY0cIifWfwp7ZMC3ltlWvgwxfBx0iARNZ5bo4dnZ/92a/Yb8
I56qf7Frol1vrdqt8IOsrSSFBOO9SSk+PlttDRo+o52Vri7KEW7VPcSWU9PWd5Pn
wLE2eT/+vSpDRDFxc0aB49/FSPXn9rVqHz+SJlwhxUmqkV6uWGIVosaaSMSZ91a7
3NTSq5fisRhElj9iAwd9CveHTy/ziIYRpcpAHWvydq15Pym1boOfjVDawlAPgDgV
aPjhGC1fNdYHFiTapDqVZj3RXNjjCe5GNNCZJ4hfwljjzbS142nrRIfvBJavRu96
GMt1nPXN4I3OQoJaKaST8dEZb0KmrDWQPmmK9Cd3XCa4nRT8QjOo+hTN5AIG3Yb7
dhLsI5eS9VgxV4a7DqBkHaJC6iqiFbzWF+sS/EG+d9cyiB3mczR0tN7/d+lPX6DO
JN805zODU6R4w1E+5cIa0DAL7WXQjHiLjgnQJtMWqPe3tyATvtI=
=vXs0
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67630@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67630
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch