Build python-phenograph.x86_64-linux on master is broken.

  • Open
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 4 Dec 2023 23:05
(name . bug-guix)(address . bug-guix@gnu.org)
87zfypr5c8.fsf@gmail.com
Hi,

cuirass@gnu.org (Cuirass) writes:

Toggle quote (6 lines)
> <p>The build <b>python-phenograph.x86_64-linux</b> for specification <b>master</b> is
> broken. You can find the detailed information about this build <a
> href="https://ci.guix.gnu.org/build/2736972/details">here</a>.</p>
>
> https://ci.guix.gnu.org/build/2736972/details

The failure reads:

Toggle snippet (40 lines)
=================================== FAILURES ===================================
___________________________ test_classify_generated ____________________________

cluster_dataset_generated = <tests.conftest.GeneratedClusterDataset object at 0x7ffdcfdb90f0>

def test_classify_generated(cluster_dataset_generated):
output, _ = classify(
cluster_dataset_generated.train_set, cluster_dataset_generated.test_set
)
actual = cluster_dataset_generated.test_labels
> assert all([p == a for p, a in zip(output, actual)])
E assert False
E + where False = all([True, True, False])

tests/test_classify.py:9: AssertionError
----------------------------- Captured stdout call -----------------------------
Finding 30 nearest neighbors using minkowski metric and 'auto' algorithm
=============================== warnings summary ===============================
phenograph/cluster.py:13
/tmp/guix-build-python-phenograph-1.5.7.drv-0/PhenoGraph-1.5.7/phenograph/cluster.py:13: DeprecationWarning: Please use `spmatrix` from the `scipy.sparse` namespace, the `scipy.sparse.base` namespace is deprecated.
from scipy.sparse.base import spmatrix

tests/test_classify.py::test_classify_generated
tests/test_classify.py::test_classify_generated
tests/test_classify.py::test_classify_generated
tests/test_classify.py::test_classify_fixed
tests/test_classify.py::test_classify_fixed
tests/test_classify.py::test_classify_fixed
tests/test_classify.py::test_random_walk_probabilities_fixed
tests/test_classify.py::test_random_walk_probabilities_fixed
tests/test_classify.py::test_random_walk_probabilities_fixed
/tmp/guix-build-python-phenograph-1.5.7.drv-0/PhenoGraph-1.5.7/phenograph/classify.py:43: DeprecationWarning: Please use `bicgstab` from the `scipy.sparse.linalg` namespace, the `scipy.sparse.linalg.isolve` namespace is deprecated.
sp.linalg.isolve.bicgstab(Lu, b.T.todense(), atol="legacy") for b in B.T

-- Docs: https://docs.pytest.org/en/stable/how-to/capture-warnings.html
=========================== short test summary info ============================
FAILED tests/test_classify.py::test_classify_generated - assert False
=================== 1 failed, 5 passed, 10 warnings in 3.48s ===================

The test is probably flaky and should be reported upstream and disabled
in our package meanwhile.

--
Thanks,
Maxim
?