[PATCH] gnu: ncdu: Use zig-build-system.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ekaitz Zarraga
  • Hilton Chain
Owner
unassigned
Submitted by
Ekaitz Zarraga
Severity
normal

Debbugs page

Ekaitz Zarraga wrote 1 years ago
(address . guix-patches@gnu.org)(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
26548efff715c63df08ca3a92cde262da4a6a989.1701704919.git.ekaitz@elenq.tech
* gnu/packages/ncdu.scm(ncdu): Move to zig-build-system.
[build-system]: Use zig-build-system.
[phases]: Delegate phase manipulation to the build-system. Remove
'validate-runpath as it fails (we should remove it in the build-system
directly).
[make-flags]: Remove them.
[native-inputs]: Remove zig-0.10.

Change-Id: I9027a1cbd925cfb0c135740e81a33b62cb9d91ca
---
gnu/packages/ncdu.scm | 24 ++++++------------------
1 file changed, 6 insertions(+), 18 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/ncdu.scm b/gnu/packages/ncdu.scm
index 30460b404d..1e7598a7fd 100644
--- a/gnu/packages/ncdu.scm
+++ b/gnu/packages/ncdu.scm
@@ -27,8 +27,8 @@ (define-module (gnu packages ncdu)
#:use-module (guix utils)
#:use-module (guix gexp)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages zig))
+ #:use-module (guix build-system zig)
+ #:use-module (gnu packages perl))
(define-public ncdu-1
;; This old version is ‘LTS’. Version 2 works fine and has more features,
@@ -73,28 +73,16 @@ (define-public ncdu
#~(begin
;; Delete a pregenerated man page. We'll build it ourselves.
(delete-file "ncdu.1")))))
+ (build-system zig-build-system)
(arguments
(list
- #:make-flags
- #~(list (string-append "PREFIX=" #$output)
- (string-append "CC=" #$(cc-for-target))
- (string-append "ZIG_FLAGS=-Drelease-fast"))
#:phases
#~(modify-phases %standard-phases
- (delete 'configure) ; No configure script.
- (add-before 'build 'pre-build
- (lambda _
- (setenv "ZIG_GLOBAL_CACHE_DIR"
- (mkdtemp "/tmp/zig-cache-XXXXXX"))))
+ (delete 'validate-runpath)
(add-after 'build 'build-manpage
(lambda _
- (invoke "make" "doc")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "zig" "test" "build.zig")))))))
- (native-inputs
- (list perl zig-0.10))
+ (invoke "make" "doc"))))))
+ (native-inputs (list perl))
(properties `((tunable? . #t)))))
(define-public ncdu-2

base-commit: 61cc93e49cdc35d3cc1b7f6018a2645628c5e892
--
2.41.0
Hilton Chain wrote 1 years ago
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)(address . 67624-done@debbugs.gnu.org)
87plzek8d3.wl-hako@ultrarare.space
Hi Ekaitz,

On Mon, 04 Dec 2023 23:48:39 +0800,
Ekaitz Zarraga wrote:
Toggle quote (14 lines)
>
> * gnu/packages/ncdu.scm(ncdu): Move to zig-build-system.
> [build-system]: Use zig-build-system.
> [phases]: Delegate phase manipulation to the build-system. Remove
> 'validate-runpath as it fails (we should remove it in the build-system
> directly).
> [make-flags]: Remove them.
> [native-inputs]: Remove zig-0.10.
>
> Change-Id: I9027a1cbd925cfb0c135740e81a33b62cb9d91ca
> ---
> gnu/packages/ncdu.scm | 24 ++++++------------------
> 1 file changed, 6 insertions(+), 18 deletions(-)

I have adjusted commit message and applied the patch as
20223da2f21cb1a0879aaed4b915305d1f197522, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67624@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67624
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help