[PATCH] gnu: Add python-icegrams.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Spencer King
Owner
unassigned
Submitted by
Spencer King
Severity
normal

Debbugs page

Spencer King wrote 1 years ago
(address . guix-patches@gnu.org)(name . Spencer King)(address . spencer@nursiapress.com)
283ec0dc3ea786a66c3e4eac20da222b79dc0902.1701658991.git.spencer@nursiapress.com
* gnu/packages/python-xyz.scm (python-icegrams): New variable.

Change-Id: Ia0044304f8b2002a5362813448a6172c2f3eef5b
---
gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f87e6fc3f7..c2f3475362 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34242,6 +34242,29 @@ (define-public python-islenska
forms, and about 300,000 distinct lemmas.")
(license license:expat)))
+(define-public python-icegrams
+ (package
+ (name "python-icegrams")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "icegrams" version))
+ (sha256
+ (base32 "1ajcjngvr4rlgb0q6p6vjz2sncwhvq3msjy6qaiz5g37vgvw2ij8"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-cffi))
+ (home-page "https://github.com/mideind/Icegrams")
+ (synopsis "Trigram statistics for Icelandic")
+ (description
+ "Icegrams is a Python package that encapsulates a large trigram
+library for Icelandic. You can use Icegrams to obtain probabilities (relative
+frequencies) of over a million different unigrams (single words or tokens), or of
+bigrams (pairs of two words or tokens), or of trigrams. Icegrams is useful for
+instance in spelling correction, predictive typing, to help disabled people
+write text fast, and for various text generation, statistics, and modeling tasks.")
+ (license license:expat)))
+
(define-public python-zeroc-ice-3.6
(package
(inherit python-zeroc-ice)

base-commit: 6e2dd51df5f3f51e9056dd4f2e1b036195ab3caa
--
2.41.0
Ludovic Courtès wrote 1 years ago
(name . Spencer King)(address . spencer@nursiapress.com)(name . Munyoki Kilyungi)(address . me@bonfacemunyoki.com)(name . jgart)(address . jgart@dismail.de)(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 67617-done@debbugs.gnu.org)(name . Marius Bakke)(address . marius@gnu.org)
87frzt6x5i.fsf@gnu.org
Spencer King <spencer@nursiapress.com> skribis:

Toggle quote (4 lines)
> * gnu/packages/python-xyz.scm (python-icegrams): New variable.
>
> Change-Id: Ia0044304f8b2002a5362813448a6172c2f3eef5b

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67617@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67617
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help