[PATCH gnome-team] gnu: Add xdg-desktop-portal-gnome.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Maxim Cournoyer
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
73242591093b4b3ff7a75254cdb7b13e7b84d40b.1701611807.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (xdg-desktop-portal-gnome): New variable.
(gnome) [propagated-inputs]: Add xdg-desktop-portal-gnome.

Change-Id: I2925cf950b731c71e4ad4a01f28bce22c0cb54fb
---
Dear Guix,

I’m not sure what I’m doing here. xdg-desktop-portal-gnome is a core app, so I
guess I should add it to the gnome propagated inputs?

Best regards,

Vivien

gnu/packages/gnome.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d354327497..3a69aca3ba 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10114,6 +10114,7 @@ (define-public gnome
simple-scan
totem
tracker-miners
+ xdg-desktop-portal-gnome
yelp
;; Others.
gnome-online-accounts
@@ -12841,6 +12842,44 @@ (define-public piper
(simple-service 'ratbagd dbus-root-service-type (list libratbag))")
(license license:gpl2)))
+(define-public xdg-desktop-portal-gnome
+ (package
+ (name "xdg-desktop-portal-gnome")
+ (version "44.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "08gznmr718na5p2j8fm7nim5862r2v0sjh68ql5yl0q356n1mvah"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "subprojects")))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:configure-flags #~'("-Dsystemduserunitdir=no")))
+ (inputs
+ (list gnome-desktop
+ gsettings-desktop-schemas
+ libadwaita
+ libxml2
+ xdg-desktop-portal
+ xdg-desktop-portal-gtk))
+ (native-inputs
+ (list gettext-minimal
+ `(,glib "bin")
+ pkg-config))
+ (home-page "https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome")
+ (synopsis "GNOME backend for xdg-desktop-portal")
+ (description "xdg-desktop-portal-gnome implements a back-end for
+@command{xdg-desktop-portal} that uses gtk and some more GNOME APIs.")
+ (license license:lgpl2.1+)))
+
(define-public parlatype
(package
(name "parlatype")

base-commit: e21f0cb7b7a87992004193cd56638ad961fe5928
--
2.41.0
Maxim Cournoyer wrote 1 years ago
87cyvmvmft.fsf@gmail.com
Hi Vivien,

Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (3 lines)
> * gnu/packages/gnome.scm (xdg-desktop-portal-gnome): New variable.
> (gnome) [propagated-inputs]: Add xdg-desktop-portal-gnome.

These should be in two seperate commits (1. adding the new package and
2. adding it as an propagated-input to the gnome package)

Toggle quote (5 lines)
> Dear Guix,
>
> I’m not sure what I’m doing here. xdg-desktop-portal-gnome is a core app, so I
> guess I should add it to the gnome propagated inputs?

suggests it is a core application, so adding it to 'gnome' sounds
reasonable to me.

If you split the commits, LGTM.

--
Thanks,
Maxim
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2 1/2] gnu: Add xdg-desktop-portal-gnome.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
d8b7a2f754be471b418270dd50ee5ac373357618.1701713921.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (xdg-desktop-portal-gnome): New variable.

Change-Id: I2925cf950b731c71e4ad4a01f28bce22c0cb54fb
---
gnu/packages/gnome.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c6437ce450..1a515af4e7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12866,6 +12866,44 @@ (define-public piper
(simple-service 'ratbagd dbus-root-service-type (list libratbag))")
(license license:gpl2)))
+(define-public xdg-desktop-portal-gnome
+ (package
+ (name "xdg-desktop-portal-gnome")
+ (version "44.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "08gznmr718na5p2j8fm7nim5862r2v0sjh68ql5yl0q356n1mvah"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "subprojects")))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:configure-flags #~'("-Dsystemduserunitdir=no")))
+ (inputs
+ (list gnome-desktop
+ gsettings-desktop-schemas
+ libadwaita
+ libxml2
+ xdg-desktop-portal
+ xdg-desktop-portal-gtk))
+ (native-inputs
+ (list gettext-minimal
+ `(,glib "bin")
+ pkg-config))
+ (home-page "https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome")
+ (synopsis "GNOME backend for xdg-desktop-portal")
+ (description "xdg-desktop-portal-gnome implements a back-end for
+@command{xdg-desktop-portal} that uses gtk and some more GNOME APIs.")
+ (license license:lgpl2.1+)))
+
(define-public parlatype
(package
(name "parlatype")

base-commit: 4c323c2f8308bba0e3295f3109d159c7b8f72838
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2 2/2] gnu: gnome: Propagate xdg-desktop-portal-gnome.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
c93761c893521994b7097766856f1666eb8c2802.1701713921.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (gnome) [propagated-inputs]: Add
xdg-desktop-portal-gnome.

Change-Id: I2a911ec58a1c9992213e60d92a3dd955dd1a545e
---
gnu/packages/gnome.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1a515af4e7..71a8a4b7ec 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10137,6 +10137,7 @@ (define-public gnome
simple-scan
totem
tracker-miners
+ xdg-desktop-portal-gnome
yelp
;; Others.
gnome-online-accounts
--
2.41.0
Maxim Cournoyer wrote 1 years ago
Re: [PATCH gnome-team v2 1/2] gnu: Add xdg-desktop-portal-gnome.
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
878r69pk2v.fsf@gmail.com
Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (4 lines)
> * gnu/packages/gnome.scm (xdg-desktop-portal-gnome): New variable.
>
> Change-Id: I2925cf950b731c71e4ad4a01f28bce22c0cb54fb

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
Maxim Cournoyer wrote 1 years ago
Re: [PATCH gnome-team v2 2/2] gnu: gnome: Propagate xdg-desktop-portal-gnome.
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
874jgxpk2o.fsf@gmail.com
Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (5 lines)
> * gnu/packages/gnome.scm (gnome) [propagated-inputs]: Add
> xdg-desktop-portal-gnome.
>
> Change-Id: I2a911ec58a1c9992213e60d92a3dd955dd1a545e

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
Liliana Marie Prikler wrote 1 years ago
Re: [PATCH gnome-team v2 1/2] gnu: Add xdg-desktop-portal-gnome.
36dd60eb64eca35cf7ab779f87a6ce3464de8f5c.camel@gmail.com
Am Montag, dem 04.12.2023 um 19:30 -0500 schrieb Maxim Cournoyer:
Toggle quote (7 lines)
> Vivien Kraus <vivien@planete-kraus.eu> writes:
>
> > * gnu/packages/gnome.scm (xdg-desktop-portal-gnome): New variable.
> >
> > Change-Id: I2925cf950b731c71e4ad4a01f28bce22c0cb54fb
>
> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
Pushed at last.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67601@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67601
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help