Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/gnome.scm (xdg-desktop-portal-gnome): New variable.
(gnome) [propagated-inputs]: Add xdg-desktop-portal-gnome.
Change-Id: I2925cf950b731c71e4ad4a01f28bce22c0cb54fb
---
Dear Guix,
I’m not sure what I’m doing here. xdg-desktop-portal-gnome is a core app, so I
guess I should add it to the gnome propagated inputs?
Best regards,
Vivien
gnu/packages/gnome.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
Toggle diff (61 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d354327497..3a69aca3ba 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10114,6 +10114,7 @@ (define-public gnome
simple-scan
totem
tracker-miners
+ xdg-desktop-portal-gnome
yelp
;; Others.
gnome-online-accounts
@@ -12841,6 +12842,44 @@ (define-public piper
(simple-service 'ratbagd dbus-root-service-type (list libratbag))")
(license license:gpl2)))
+(define-public xdg-desktop-portal-gnome
+ (package
+ (name "xdg-desktop-portal-gnome")
+ (version "44.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "08gznmr718na5p2j8fm7nim5862r2v0sjh68ql5yl0q356n1mvah"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "subprojects")))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:configure-flags #~'("-Dsystemduserunitdir=no")))
+ (inputs
+ (list gnome-desktop
+ gsettings-desktop-schemas
+ libadwaita
+ libxml2
+ xdg-desktop-portal
+ xdg-desktop-portal-gtk))
+ (native-inputs
+ (list gettext-minimal
+ `(,glib "bin")
+ pkg-config))
+ (home-page "https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome")
+ (synopsis "GNOME backend for xdg-desktop-portal")
+ (description "xdg-desktop-portal-gnome implements a back-end for
+@command{xdg-desktop-portal} that uses gtk and some more GNOME APIs.")
+ (license license:lgpl2.1+)))
+
(define-public parlatype
(package
(name "parlatype")
base-commit: e21f0cb7b7a87992004193cd56638ad961fe5928
--
2.41.0