[PATCH gnome-team 0/4] Update python-dbusmock

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Maxim Cournoyer
  • Vivien Kraus
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 2 Dec 2023 11:35
(address . guix-patches@gnu.org)
cover.1701513359.git.liliana.prikler@gmail.com
Hi Guix,

this series updates dbusmock, which is required to test mutter and
gnome-shell among others. With this, we should soon™ be able to ship
GNOME 44.

Cheers

Liliana Marie Prikler (4):
gnu: Add python-meson-python.
gnu: Add python-dbus-python.
gnu: python-dbusmock: Update to 0.30.0.
Revert "gnu: sysprof: Do not propagate libadwaita."

gnu/packages/gnome.scm | 5 ++-
gnu/packages/gtk.scm | 5 ++-
gnu/packages/polkit.scm | 2 +-
gnu/packages/python-xyz.scm | 75 +++++++++++++++++++++++++++++++++++--
4 files changed, 78 insertions(+), 9 deletions(-)


base-commit: e21f0cb7b7a87992004193cd56638ad961fe5928
prerequisite-patch-id: 8d1a45af0d4d7f62972fb8e55b250c820314d8a2
prerequisite-patch-id: c86837319c9b4a863bb76c1cda3ad400f11f9c7f
prerequisite-patch-id: fdcf33da7b5aa853025b83b56cae2cad32c40d20
prerequisite-patch-id: 6b34aba7833316d5b68c66c3523fa9e36fcd21ea
prerequisite-patch-id: ea4f5585810504e1d9048d18be0279cdf915f7f7
prerequisite-patch-id: 2423d15d8a338cb27b2a09d1343c97efe157273e
prerequisite-patch-id: 9ae0e5fe0509966acb8535d24445e2778ce3bf51
prerequisite-patch-id: 6c994d78a267679e41c64aca5e2a8eed9903c36a
prerequisite-patch-id: f687a06414371dc1a5c13f62121085935f6420c4
prerequisite-patch-id: 37e6c6b7f27c55f93e63c25ae0c93aba6349974a
prerequisite-patch-id: 7d6f1a77e5cb31bdf1f9c4e491413c95c52cff3f
prerequisite-patch-id: dccc6c9860b8e2a024ab2ec2833f8385b7c8e75c
prerequisite-patch-id: e5cb122207ec3784a270158758d0f5597b87e162
prerequisite-patch-id: 60b3204e84dc6d0f39ce2d994053c83e6333c80b
prerequisite-patch-id: be468df07dd87b750ebd01ea72c8294dd93dce32
prerequisite-patch-id: 14d90fb9fb9a284cf216ec7b25f163c2323f5b10
prerequisite-patch-id: 3beb347bc9ee5c0d42a3fef154dc242b6ae8de52
prerequisite-patch-id: fc6d9920ccd676a132d8bc39a0343c40fcf5b4b4
prerequisite-patch-id: f772aa06c02d662e27dde01064c2aeb91f30de75
prerequisite-patch-id: cf70a422a2843416b013992cd3f10a079b0be77c
prerequisite-patch-id: 95a220c8e07d6264306a63a615739710968585c0
prerequisite-patch-id: 3de44279e1880b71bce0685d72d28d43334a2884
--
2.41.0
L
L
Liliana Marie Prikler wrote on 2 Dec 2023 00:38
[PATCH gnome-team 1/4] gnu: Add python-meson-python.
(address . 67582@debbugs.gnu.org)
375986f75944e81a821fdf26672d3e09e06c7ed0.1701513359.git.liliana.prikler@gmail.com
* gnu/packages/python-xyz.scm (python-meson-python): New variable.

Change-Id: I43548f7d23b7a2f1c8caedacd72498c868c85ac3
---
gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8e89f61373..3e406cc677 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -274,6 +274,7 @@ (define-module (gnu packages python-xyz)
#:use-module (guix build-system cargo)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix download)
@@ -12589,6 +12590,24 @@ (define-public python-pyproject-metadata
(define-public python-pep621
(deprecated-package "python-pep621" python-pyproject-metadata))
+(define-public python-meson-python
+ (package
+ (name "python-meson-python")
+ (version "0.15.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "meson_python" version))
+ (sha256
+ (base32 "0vyjhjabvm41hqijifk33idbdl62i76kfyf884f9rs29rpp77nzx"))))
+ (build-system meson-build-system)
+ (propagated-inputs (list python-pyproject-metadata python-tomli))
+ (home-page "https://github.com/mesonbuild/meson-python")
+ (synopsis "Meson Python build backend (PEP 517)")
+ (description "This package provides a PEP 517 build backend that makes
+use of the Meson build system.")
+ (license license:expat)))
+
(define-public python-pyflakes
(package
(name "python-pyflakes")
--
2.41.0
L
L
Liliana Marie Prikler wrote on 2 Dec 2023 00:09
[PATCH gnome-team 3/4] gnu: python-dbusmock: Update to 0.30.0.
(address . 67582@debbugs.gnu.org)
75681c8791607557c6fdeaa2c6ce0d66181caf49.1701513359.git.liliana.prikler@gmail.com
* gnu/packages/python-xyz.scm (python-dbusmock): Update to 0.30.0.
[#:phases]<patch-paths>: Adjust accordingly.
[native-inputs]: Add upower.
(python-dbus-minimal): New variable.
* gnu/packages/gnome.scm (upower)[native-inputs]: Replace python-dbusmock
with python-dbusmock-minimal.
* gnu/packages/gtk.scm (at-spi2-core)[native-inputs]: Likewise.
(at-spi2-core-with-documentation)[native-inputs]: Adjust accordingly.
* gnu/packages/polkit.scm (polkit)[native-inputs]: Replace python-dbusmock
with python-dbusmock-minimal.

Change-Id: If0cd76da0495d052f94ee5d654436c4d1dd1e2c3
---
gnu/packages/gnome.scm | 2 +-
gnu/packages/gtk.scm | 5 +++--
gnu/packages/polkit.scm | 2 +-
gnu/packages/python-xyz.scm | 21 +++++++++++++++++----
4 files changed, 22 insertions(+), 8 deletions(-)

Toggle diff (113 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 900869a80c..07944b7a3e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5810,7 +5810,7 @@ (define-public upower
python
;; For tests.
python-dbus
- python-dbusmock
+ python-dbusmock-minimal
python-packaging
python-pygobject
umockdev
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b5246c8b3b..761b65fd1f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -849,7 +849,7 @@ (define-public at-spi2-core
gobject-introspection
gsettings-desktop-schemas
pkg-config
- python-dbusmock
+ python-dbusmock-minimal
python-pytest
python-wrapper))
(synopsis "Assistive Technology Service Provider Interface, core components")
@@ -880,7 +880,8 @@ (define-public at-spi2-core-with-documentation
"/share/doc'\n")))))))))
(native-inputs
(modify-inputs (package-native-inputs at-spi2-core)
- (append gi-docgen python python-sphinx)))
+ (append gi-docgen python python-sphinx)
+ (replace "python-dbusmock" python-dbusmock)))
(properties (alist-delete 'hidden?
(package-properties at-spi2-core)))))
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index 2f733dd703..337d9b9a73 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -158,7 +158,7 @@ (define-public polkit
perl
pkg-config
python
- python-dbusmock))
+ python-dbusmock-minimal))
(home-page "https://www.freedesktop.org/wiki/Software/polkit/")
(synopsis "Authorization API for privilege management")
(description "Polkit is an application-level toolkit for defining and
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3e23311b80..c079efe7ca 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27338,14 +27338,14 @@ (define-public python-dbus-python
(define-public python-dbusmock
(package
(name "python-dbusmock")
- (version "0.25.0")
+ (version "0.30.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-dbusmock" version))
(sha256
(base32
- "1nwl0gzzds2g1w1gfxfzlgrkb5hr1rrdyn619ml25c6b1rjyfk3g"))))
+ "1hanz6x76jq66ypdirga5h15zjs67kwysl6rmsf0i22dbdqrxdfv"))))
(build-system python-build-system)
(arguments
(list #:modules `((guix build python-build-system)
@@ -27356,6 +27356,9 @@ (define-public python-dbusmock
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "tests/test_api.py"
+ (("/usr/bin/python3")
+ (which "python3")))
(substitute* "tests/test_code.py"
(("/bin/bash")
(which "bash")))
@@ -27382,11 +27385,11 @@ (define-public python-dbusmock
status))
(loop)))))))))))))
(native-inputs
- (list dbus python-pytest which))
+ (list dbus python-pytest upower which))
(inputs
(list dbus))
(propagated-inputs
- (list python-dbus python-pygobject))
+ (list python-dbus-python python-pygobject))
(home-page "https://github.com/martinpitt/python-dbusmock")
(synopsis "Python library for mock D-Bus objects")
(description "python-dbusmock allows for the easy creation of mock objects on
@@ -27396,6 +27399,16 @@ (define-public python-dbusmock
services to what you expect in your tests.")
(license license:lgpl3+)))
+(define-public python-dbusmock-minimal
+ (package
+ (inherit python-dbusmock)
+ (name "python-dbusmock-minimal")
+ (arguments
+ (substitute-keyword-arguments (package-arguments python-dbusmock)
+ ((#:tests? _ #t) #f)))
+ (native-inputs (list which))
+ (properties '((hidden? . #t)))))
+
(define-public python-jsonplus
(package
(name "python-jsonplus")
--
2.41.0
L
L
Liliana Marie Prikler wrote on 2 Dec 2023 00:09
[PATCH gnome-team 2/4] gnu: Add python-dbus-python.
(address . 67582@debbugs.gnu.org)
a42fa1fc21dcb1548d41816ac3190b029e252702.1701513359.git.liliana.prikler@gmail.com
* gnu/packages/python-xyz.scm (python-dbus-python): New variable.

Change-Id: I7d9ba58466e8a07119073209e47814fc9fc573cb
---
gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3e406cc677..3e23311b80 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -173,6 +173,7 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bdw-gc)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
@@ -186,6 +187,7 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages djvu)
#:use-module (gnu packages docker)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages elf)
#:use-module (gnu packages enchant)
#:use-module (gnu packages file)
#:use-module (gnu packages fonts)
@@ -27300,6 +27302,39 @@ (define-public python-pykwalify
for YAML and JSON.")
(license license:expat)))
+(define-public python-dbus-python
+ (package
+ (name "python-dbus-python")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dbus-python" version))
+ (sha256
+ (base32 "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-requirements
+ (lambda _
+ (substitute* (list "pyproject.toml" "setup.py")
+ (("'(ninja|patchelf)',?") ""))
+ (substitute* "setup.cfg"
+ (("(ninja|patchelf)") "")))))))
+ (inputs (list dbus glib))
+ (propagated-inputs (list python-pygobject))
+ (native-inputs (list pkg-config
+ python-meson-python
+ meson ninja patchelf
+ python-sphinx python-sphinx-rtd-theme
+ python-tappy
+ python-wheel))
+ (home-page "https://dbus.freedesktop.org/doc/dbus-python/")
+ (synopsis "Python bindings for libdbus")
+ (description "This package provides Python bindings to libdbus, the
+reference implementation of the D-Bus protocol.")
+ (license license:expat)))
+
(define-public python-dbusmock
(package
(name "python-dbusmock")
--
2.41.0
L
L
Liliana Marie Prikler wrote on 1 Dec 2023 21:48
[PATCH gnome-team 4/4] Revert "gnu: sysprof: Do not propagate libadwaita."
(address . 67582@debbugs.gnu.org)
aca9d4153ca6608a1e0a885f61238d3dcbb6a077.1701513359.git.liliana.prikler@gmail.com
This reverts commit e21f0cb7b7a87992004193cd56638ad961fe5928. It was
introduced to fix a build failure in mutter, that no longer occurs with
the updated python-dbusmock.

Change-Id: I781fa2314afb0c1819e30ef404cf2e8da6652e3e
---
gnu/packages/gnome.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 07944b7a3e..43d9997efb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13042,7 +13042,8 @@ (define-public sysprof
(("update_desktop_database: true")
"update_desktop_database: false")))))))
(propagated-inputs
- (list glib json-glib polkit))
+ ;; Listed in sysprof-4.pc or sysprof-ui-5.pc
+ (list glib json-glib libadwaita polkit))
(inputs
(list glib
gtk
--
2.41.0
V
V
Vivien Kraus wrote on 2 Dec 2023 15:18
[PATCH gnome-team 0/4] Update python-dbusmock
(address . 67582@debbugs.gnu.org)
efeaaecea0d0e95d14d10c91760db171fab13565.camel@planete-kraus.eu
Hello!

Thank you for this much needed update!

I can however anticipate a QA failure, as accountsservice is too old. I
don’t want to confuse QA, so the patch is an attachment.

Best regards,

Vivien
From bc04d8ddae4cdc7caf2e30df5811b4c94432239a Mon Sep 17 00:00:00 2001
Message-ID: <bc04d8ddae4cdc7caf2e30df5811b4c94432239a.1701526104.git.vivien@planete-kraus.eu>
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Sat, 2 Dec 2023 15:04:51 +0100
Subject: [PATCH gnome-team] gnu: accountsservice: Update to 23.13.9.
To: 67582@debbugs.gnu.org
Cc: liliana.prikler@gmail.com, maxim.cournoyer@gmail.com, rg@raghavgururajan.name

The style of the C code has changed, so the patch does not apply anymore.

* gnu/packages/freedesktop.scm (accountsservice): Update to 23.13.9.
[native-inuputs]: Add glibc-locales.
* gnu/packages/patches/accountsservice-extensions.patch: Update.

Change-Id: I19678b5ce36549a832099109b13cdaf91539b20a
---

Thank you for this much needed update!

accountsservice fails to build now though, but we can fix it by upgrading it.

Best regards,

Vivien

gnu/packages/freedesktop.scm | 5 +++--
gnu/packages/patches/accountsservice-extensions.patch | 5 ++---
2 files changed, 5 insertions(+), 5 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 25b7998d05..a934b3ac17 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1746,7 +1746,7 @@ (define-public udisks
(define-public accountsservice
(package
(name "accountsservice")
- (version "22.08.8")
+ (version "23.13.9")
(source
(origin
(method url-fetch)
@@ -1754,7 +1754,7 @@ (define-public accountsservice
"accountsservice/accountsservice-"
version ".tar.xz"))
(sha256
- (base32 "14d3lwik048h62qrzg1djdd2sqmxf3m1r859730pvzhrd6krg6ch"))
+ (base32 "0kwjkff5m7gnzpns6cy27az90w7sxzwzygyzwy90kyi4mvg4rnmd"))
(patches (search-patches "accountsservice-extensions.patch"))))
(build-system meson-build-system)
(arguments
@@ -1795,6 +1795,7 @@ (define-public accountsservice
docbook-xsl
gettext-minimal
`(,glib "bin") ; for gdbus-codegen, etc.
+ glibc-locales ;for tests
gobject-introspection
gtk-doc
libxml2 ;for XML_CATALOG_FILES
diff --git a/gnu/packages/patches/accountsservice-extensions.patch b/gnu/packages/patches/accountsservice-extensions.patch
index 2cfab580e3..8027a28a44 100644
--- a/gnu/packages/patches/accountsservice-extensions.patch
+++ b/gnu/packages/patches/accountsservice-extensions.patch
@@ -5,7 +5,7 @@ diff --git a/src/extensions.c b/src/extensions.c
index 038dcb2..830465d 100644
--- a/src/extensions.c
+++ b/src/extensions.c
-@@ -121,16 +121,7 @@ daemon_read_extension_directory (GHashTable *ifaces,
+@@ -122,15 +122,7 @@ daemon_read_extension_directory (GHashTable *ifaces,
continue;
}
@@ -13,8 +13,7 @@ index 038dcb2..830465d 100644
- const gchar * const prefix = "../../dbus-1/interfaces/";
- if (g_str_has_prefix (symlink, prefix) && g_str_equal (symlink + strlen (prefix), name)) {
- daemon_read_extension_file (ifaces, filename);
-- }
-- else {
+- } else {
- g_warning ("Found accounts service vendor extension symlink %s, but it must be exactly "
- "equal to '../../dbus-1/interfaces/%s' for forwards-compatibility reasons.",
- filename, name);

base-commit: e21f0cb7b7a87992004193cd56638ad961fe5928
--
2.41.0
M
M
Maxim Cournoyer wrote on 3 Dec 2023 18:16
Re: [bug#67582] [PATCH gnome-team 1/4] gnu: Add python-meson-python.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87il5f2olx.fsf@gmail.com
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-meson-python): New variable.

This should go to gnu/packages/python-build.scm.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 3 Dec 2023 18:19
Re: [bug#67582] [PATCH gnome-team 2/4] gnu: Add python-dbus-python.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87bkb72ogk.fsf@gmail.com
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-dbus-python): New variable.

[...]

Toggle quote (28 lines)
> +(define-public python-dbus-python
> + (package
> + (name "python-dbus-python")
> + (version "1.3.2")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "dbus-python" version))
> + (sha256
> + (base32 "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
> + (build-system pyproject-build-system)
> + (arguments
> + (list #:phases #~(modify-phases %standard-phases
> + (add-after 'unpack 'patch-requirements
> + (lambda _
> + (substitute* (list "pyproject.toml" "setup.py")
> + (("'(ninja|patchelf)',?") ""))
> + (substitute* "setup.cfg"
> + (("(ninja|patchelf)") "")))))))
> + (inputs (list dbus glib))
> + (propagated-inputs (list python-pygobject))
> + (native-inputs (list pkg-config
> + python-meson-python
> + meson ninja patchelf
> + python-sphinx python-sphinx-rtd-theme
> + python-tappy
> + python-wheel))

Is this 'guix style' produced? The convention is to use:

(native-inputs
(list one
two
...))

When there are more than 5 inputs (or if they don't fit on a single
line).

Otherwise,

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>

--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 3 Dec 2023 19:41
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
063de2574249ecc7aaeefdba3ac14b1d0b011eb7.camel@gmail.com
Am Sonntag, dem 03.12.2023 um 12:19 -0500 schrieb Maxim Cournoyer:
Toggle quote (47 lines)
> Hello,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > * gnu/packages/python-xyz.scm (python-dbus-python): New variable.
>
> [...]
>
> > +(define-public python-dbus-python
> > +  (package
> > +  (name "python-dbus-python")
> > +  (version "1.3.2")
> > +  (source
> > +   (origin
> > +     (method url-fetch)
> > +     (uri (pypi-uri "dbus-python" version))
> > +     (sha256
> > +      (base32
> > "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
> > +  (build-system pyproject-build-system)
> > +  (arguments
> > +   (list #:phases #~(modify-phases %standard-phases
> > +                      (add-after 'unpack 'patch-requirements
> > +                        (lambda _
> > +                          (substitute* (list "pyproject.toml"
> > "setup.py")
> > +                            (("'(ninja|patchelf)',?") ""))
> > +                          (substitute* "setup.cfg"
> > +                            (("(ninja|patchelf)") "")))))))
> > +  (inputs (list dbus glib))
> > +  (propagated-inputs (list python-pygobject))
> > +  (native-inputs (list pkg-config
> > +                       python-meson-python
> > +                       meson ninja patchelf
> > +                       python-sphinx python-sphinx-rtd-theme
> > +                       python-tappy
> > +                       python-wheel))
>
> Is this 'guix style' produced?  The convention is to use:
>
> (native-inputs
>  (list one
>        two
>        ...))
>
> When there are more than 5 inputs (or if they don't fit on a single
> line).
I manually grouped them by theme.

Cheers
L
L
Liliana Marie Prikler wrote on 3 Dec 2023 19:41
Re: [bug#67582] [PATCH gnome-team 1/4] gnu: Add python-meson-python.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
052a685fe0caba9c77c1a03135a28dc03ab42304.camel@gmail.com
Am Sonntag, dem 03.12.2023 um 12:16 -0500 schrieb Maxim Cournoyer:
Toggle quote (7 lines)
> Hi,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > * gnu/packages/python-xyz.scm (python-meson-python): New variable.
>
> This should go to gnu/packages/python-build.scm.
It should, but it can't, because there are requirements from python-xyz
and I'm not going to move them around on-the-go.

Cheers
M
M
Maxim Cournoyer wrote on 3 Dec 2023 20:04
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87a5qryuo4.fsf@gmail.com
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (11 lines)
> Am Sonntag, dem 03.12.2023 um 12:16 -0500 schrieb Maxim Cournoyer:
>> Hi,
>>
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>>
>> > * gnu/packages/python-xyz.scm (python-meson-python): New variable.
>>
>> This should go to gnu/packages/python-build.scm.
> It should, but it can't, because there are requirements from python-xyz
> and I'm not going to move them around on-the-go.

It doesn't look out of reach if we add a bootstrap (untested) variant of
python-pyproject-metada in (gnu packages python-build), but okay.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 3 Dec 2023 20:06
Re: [bug#67582] [PATCH gnome-team 2/4] gnu: Add python-dbus-python.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
875y1fyula.fsf@gmail.com
Hi,
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
Toggle quote (49 lines)
> Am Sonntag, dem 03.12.2023 um 12:19 -0500 schrieb Maxim Cournoyer:
>> Hello,
>>
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>>
>> > * gnu/packages/python-xyz.scm (python-dbus-python): New variable.
>>
>> [...]
>>
>> > +(define-public python-dbus-python
>> > +  (package
>> > +  (name "python-dbus-python")
>> > +  (version "1.3.2")
>> > +  (source
>> > +   (origin
>> > +     (method url-fetch)
>> > +     (uri (pypi-uri "dbus-python" version))
>> > +     (sha256
>> > +      (base32
>> > "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
>> > +  (build-system pyproject-build-system)
>> > +  (arguments
>> > +   (list #:phases #~(modify-phases %standard-phases
>> > +                      (add-after 'unpack 'patch-requirements
>> > +                        (lambda _
>> > +                          (substitute* (list "pyproject.toml"
>> > "setup.py")
>> > +                            (("'(ninja|patchelf)',?") ""))
>> > +                          (substitute* "setup.cfg"
>> > +                            (("(ninja|patchelf)") "")))))))
>> > +  (inputs (list dbus glib))
>> > +  (propagated-inputs (list python-pygobject))
>> > +  (native-inputs (list pkg-config
>> > +                       python-meson-python
>> > +                       meson ninja patchelf
>> > +                       python-sphinx python-sphinx-rtd-theme
>> > +                       python-tappy
>> > +                       python-wheel))
>>
>> Is this 'guix style' produced?  The convention is to use:
>>
>> (native-inputs
>>  (list one
>>        two
>>        ...))
>>
>> When there are more than 5 inputs (or if they don't fit on a single
>> line).
> I manually grouped them by theme.
I see. I'd still prefer the conventional sorted flat list, because the
next person touching it probably won't notice and break that logic.
--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 19 Dec 2023 23:54
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
b1628e4035167bbe31baacec71aa3dad9a4c9de8.camel@gmail.com
Am Sonntag, dem 03.12.2023 um 14:06 -0500 schrieb Maxim Cournoyer:
Toggle quote (58 lines)
> Hi,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > Am Sonntag, dem 03.12.2023 um 12:19 -0500 schrieb Maxim Cournoyer:
> > > Hello,
> > >
> > > Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> > >
> > > > * gnu/packages/python-xyz.scm (python-dbus-python): New
> > > > variable.
> > >
> > > [...]
> > >
> > > > +(define-public python-dbus-python
> > > > +  (package
> > > > +  (name "python-dbus-python")
> > > > +  (version "1.3.2")
> > > > +  (source
> > > > +   (origin
> > > > +     (method url-fetch)
> > > > +     (uri (pypi-uri "dbus-python" version))
> > > > +     (sha256
> > > > +      (base32
> > > > "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
> > > > +  (build-system pyproject-build-system)
> > > > +  (arguments
> > > > +   (list #:phases #~(modify-phases %standard-phases
> > > > +                      (add-after 'unpack 'patch-requirements
> > > > +                        (lambda _
> > > > +                          (substitute* (list "pyproject.toml"
> > > > "setup.py")
> > > > +                            (("'(ninja|patchelf)',?") ""))
> > > > +                          (substitute* "setup.cfg"
> > > > +                            (("(ninja|patchelf)") "")))))))
> > > > +  (inputs (list dbus glib))
> > > > +  (propagated-inputs (list python-pygobject))
> > > > +  (native-inputs (list pkg-config
> > > > +                       python-meson-python
> > > > +                       meson ninja patchelf
> > > > +                       python-sphinx python-sphinx-rtd-theme
> > > > +                       python-tappy
> > > > +                       python-wheel))
> > >
> > > Is this 'guix style' produced?  The convention is to use:
> > >
> > > (native-inputs
> > >  (list one
> > >        two
> > >        ...))
> > >
> > > When there are more than 5 inputs (or if they don't fit on a
> > > single line).
> > I manually grouped them by theme.
>
> I see.  I'd still prefer the conventional sorted flat list, because
> the next person touching it probably won't notice and break that
> logic.
We can still break it when the next person touches it, so that's fine
by me :)

Pushed, along with the rest.
Closed
?