[PATCH] gtkwave: Update to 3.3.117 and use gtk3

  • Open
  • quality assurance status badge
Details
One participant
  • Nathan Merkley
Owner
unassigned
Submitted by
Nathan Merkley
Severity
normal
N
N
Nathan Merkley wrote on 29 Nov 2023 00:16
(address . guix-patches@gnu.org)(name . Nathan Merkley)(address . nathanmerkley@gmail.com)
3cef56ba1d81f8701c611a8e14e48cc3188886f2.1701212697.git.nathanmerkley@gmail.com
* gnu/packages/fpga.scm (gtkwave): Update to 3.3.117 and use gtk3

Change-Id: If2e660144b86b30fb6e90a7623fb0d9a439f6e65
---
gnu/packages/fpga.scm | 23 ++++++++++++++---------
1 file changed, 14 insertions(+), 9 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 13ac1a0b57..48df57125d 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -31,6 +31,7 @@ (define-module (gnu packages fpga)
#:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
#:use-module (gnu packages)
@@ -38,6 +39,7 @@ (define-module (gnu packages fpga)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages elf)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tcl)
#:use-module (gnu packages readline)
@@ -346,25 +348,28 @@ (define-public arachne-pnr
(define-public gtkwave
(package
(name "gtkwave")
- (version "3.3.113")
+ (version "3.3.117")
(source
(origin
(method url-fetch)
(uri (list (string-append "mirror://sourceforge/gtkwave/"
- "gtkwave-" version "/"
- "gtkwave-" version ".tar.gz")
+ "gtkwave-gtk3-" version "/"
+ "gtkwave-gtk3-" version ".tar.gz")
(string-append "https://gtkwave.sourceforge.net/"
- "gtkwave-" version ".tar.gz")))
+ "gtkwave-gtk3" version ".tar.gz")))
(sha256
- (base32 "1zqkfchmns5x90qxa8kg39bfhax3vxf1mrdz3lhyb9fz1gp4difn"))))
- (build-system gnu-build-system)
+ (base32 "1f8xazl1i4fbwffgcwaal740i9vdrwcgmy0sc2qcn4d9hrsm7w9w"))))
+ (build-system glib-or-gtk-build-system)
(native-inputs
- (list gperf pkg-config))
+ (list gperf pkg-config `(,glib "bin")))
(inputs
- (list tcl tk gtk+-2))
+ (list tcl tk gtk+))
(arguments
(list #:configure-flags
- #~(list (string-append "--with-tcl="
+ #~(list "--disable-dependency-tracking"
+ "--with-gsettings"
+ "--enable-gtk3"
+ (string-append "--with-tcl="
(assoc-ref %build-inputs "tcl")
"/lib")
(string-append "--with-tk="

base-commit: 62376e3eb67644454bc655bed56be4be965bd13e
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67519@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67519
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch