Spencer King wrote 1 years ago
(address . guix-patches@gnu.org)(name . Spencer King)(address . spencer@nursiapress.com)
* gnu/packages/python-xyz.scm (python-islenska): New variable.
Change-Id: Id9acd04d625bbbdef0438b1b98b73550e826088d
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 746ecccc5a..cf7b13c9e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34219,6 +34219,28 @@ (define-public python-zeroc-ice
interfaces.")
(license license:gpl2)))
+(define-public python-islenska
+ (package
+ (name "python-islenska")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "islenska" version))
+ (sha256
+ (base32 "0fdp90mzy0sd4kyw8kd8kybd1ni765fvqn8hz2wx5sqbjjkm4d5k"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-cffi python-typing-extensions))
+ (home-page "https://github.com/mideind/BinPackage")
+ (synopsis
+ "The vocabulary of the modern Icelandic language, in a Python package")
+ (description
+ "Islenska is a Python package, published by Mideind, that embeds the vocabulary
+ of the Database of Icelandic Morphology and offers various lookups and queries
+ of the data. The database contains over 6.5 million entries, over 3.1 million
+ unique word forms, and about 300,000 distinct lemmas.")
+ (license license:expat)))
+
(define-public python-zeroc-ice-3.6
(package
(inherit python-zeroc-ice)
base-commit: 3778f778c37110460dd78088200cbd05eb0c49e4
--
2.43.0