[PATCH] gnu: Add python-islenska.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Spencer King
Owner
unassigned
Submitted by
Spencer King
Severity
normal

Debbugs page

Spencer King wrote 1 years ago
(address . guix-patches@gnu.org)(name . Spencer King)(address . spencer@nursiapress.com)
28ae33f0a375264f77c7cbdbb502d916aa7b74cf.1701135879.git.spencer@nursiapress.com
* gnu/packages/python-xyz.scm (python-islenska): New variable.

Change-Id: Id9acd04d625bbbdef0438b1b98b73550e826088d
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 746ecccc5a..cf7b13c9e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34219,6 +34219,28 @@ (define-public python-zeroc-ice
interfaces.")
(license license:gpl2)))
+(define-public python-islenska
+ (package
+ (name "python-islenska")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "islenska" version))
+ (sha256
+ (base32 "0fdp90mzy0sd4kyw8kd8kybd1ni765fvqn8hz2wx5sqbjjkm4d5k"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-cffi python-typing-extensions))
+ (home-page "https://github.com/mideind/BinPackage")
+ (synopsis
+ "The vocabulary of the modern Icelandic language, in a Python package")
+ (description
+ "Islenska is a Python package, published by Mideind, that embeds the vocabulary
+ of the Database of Icelandic Morphology and offers various lookups and queries
+ of the data. The database contains over 6.5 million entries, over 3.1 million
+ unique word forms, and about 300,000 distinct lemmas.")
+ (license license:expat)))
+
(define-public python-zeroc-ice-3.6
(package
(inherit python-zeroc-ice)

base-commit: 3778f778c37110460dd78088200cbd05eb0c49e4
--
2.43.0
Ludovic Courtès wrote 1 years ago
(name . Spencer King)(address . spencer@nursiapress.com)(name . Munyoki Kilyungi)(address . me@bonfacemunyoki.com)(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 67501-done@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)(name . Marius Bakke)(address . marius@gnu.org)
87a5qqgbbc.fsf@gnu.org
Hi,

Spencer King <spencer@nursiapress.com> skribis:

Toggle quote (4 lines)
> * gnu/packages/python-xyz.scm (python-islenska): New variable.
>
> Change-Id: Id9acd04d625bbbdef0438b1b98b73550e826088d

Applied with the minor changes below. Thanks!

Ludo’.
Toggle diff (22 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3c6902762f..f87e6fc3f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34234,12 +34234,12 @@ (define-public python-islenska
(propagated-inputs (list python-cffi python-typing-extensions))
(home-page "https://github.com/mideind/BinPackage")
(synopsis
- "The vocabulary of the modern Icelandic language, in a Python package")
+ "Vocabulary of the modern Icelandic language, in a Python package")
(description
- "Islenska is a Python package, published by Mideind, that embeds the vocabulary
- of the Database of Icelandic Morphology and offers various lookups and queries
- of the data. The database contains over 6.5 million entries, over 3.1 million
- unique word forms, and about 300,000 distinct lemmas.")
+ "Islenska is a Python package that embeds the vocabulary of the Database
+of Icelandic Morphology and offers various lookups and queries of the data.
+The database contains over 6.5 million entries, over 3.1 million unique word
+forms, and about 300,000 distinct lemmas.")
(license license:expat)))
(define-public python-zeroc-ice-3.6
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67501@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67501
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help