[PATCH] gnu: tractor: Change URI of source.

  • Open
  • quality assurance status badge
Details
2 participants
  • Danial Behzadi
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Danial Behzadi
Severity
normal
D
D
Danial Behzadi wrote on 27 Nov 2023 11:01
(address . guix-patches@gnu.org)(name . Danial Behzadi)(address . dani.behzi@ubuntu.com)
20231127100109.93330-1-dani.behzi@ubuntu.com
---
gnu/packages/tor.scm | 61 ++++++++++++++++++++++----------------------
1 file changed, 30 insertions(+), 31 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index d4bf27a790..cb7fd571c5 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -441,41 +441,40 @@ (define-public tractor
(source
(origin
(method url-fetch)
- (uri (pypi-uri "traxtor" version))
+ (uri (string-append "https://framagit.org/tractor/tractor/-/archive/"
+ version "/tractor-" version ".tar.bz2"))
(sha256
- (base32
- "1542g6alycwlmvndxcijzn4d5lgycmxxb78gqd8qwgm9kw0fnr3q"))))
+ (base32 "0gnsgwgbipd1z3ra32mpglwy19jfay36y78nqg32zqka3lsha7rc"))))
(build-system pyproject-build-system)
- (native-inputs
- (list (list glib "bin"))) ; for glib-compile-schemas.
- (inputs
- (list python-fire
- python-psutil
- python-pygobject
- python-requests
- python-stem
- python-termcolor))
+ (native-inputs (list (list glib "bin"))) ;for glib-compile-schemas.
+ (inputs (list python-fire
+ python-psutil
+ python-pygobject
+ python-requests
+ python-stem
+ python-termcolor))
(arguments
(list
- #:tests? #f ; no test suite.
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'install-man-page
- (lambda _
- (let ((man1 (string-append #$output "/share/man/man1")))
- (install-file "tractor/man/tractor.1" man1))))
- (add-after 'install 'install-bash-completion
- (lambda _
- (mkdir "bash-completion")
- (rename-file "tractor/tractor-completion"
- "bash-completion/tractor")
- (let ((bash-completion
- (string-append #$output "/share/bash-completion/completions")))
- (install-file "bash-completion/tractor" bash-completion))))
- (add-after 'install 'install-gschema
- (lambda _
- (let ((schemas (string-append #$output "/share/glib-2.0/schemas")))
- (install-file "tractor/tractor.gschema.xml" schemas)))))))
+ #:tests? #f ;no test suite.
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-man-page
+ (lambda _
+ (let ((man1 (string-append #$output "/share/man/man1")))
+ (install-file "tractor/man/tractor.1" man1))))
+ (add-after 'install 'install-bash-completion
+ (lambda _
+ (mkdir "bash-completion")
+ (rename-file "tractor/tractor-completion"
+ "bash-completion/tractor")
+ (let ((bash-completion (string-append #$output
+ "/share/bash-completion/completions")))
+ (install-file "bash-completion/tractor"
+ bash-completion))))
+ (add-after 'install 'install-gschema
+ (lambda _
+ (let ((schemas (string-append #$output
+ "/share/glib-2.0/schemas")))
+ (install-file "tractor/tractor.gschema.xml" schemas)))))))
(home-page "https://framagit.org/tractor")
(synopsis "Setup an onion routing proxy")
(description
--
2.34.1
M
M
Mathieu Othacehe wrote on 25 Dec 2023 18:32
(name . Danial Behzadi)(address . dani.behzi@ubuntu.com)(address . 67481@debbugs.gnu.org)
87h6k6i3x4.fsf@gnu.org
Hello Danial,

Toggle quote (4 lines)
> - (uri (pypi-uri "traxtor" version))
> + (uri (string-append "https://framagit.org/tractor/tractor/-/archive/"
> + version "/tractor-" version ".tar.bz2"))

What's the rationale behind the URI change? It seems that pypi is still
providing traxtor.

Toggle quote (17 lines)
> - (native-inputs
> - (list (list glib "bin"))) ; for glib-compile-schemas.
> - (inputs
> - (list python-fire
> - python-psutil
> - python-pygobject
> - python-requests
> - python-stem
> - python-termcolor))
> + (native-inputs (list (list glib "bin"))) ;for glib-compile-schemas.
> + (inputs (list python-fire
> + python-psutil
> + python-pygobject
> + python-requests
> + python-stem
> + python-termcolor))

All the subsequent modifications should be made in another separate
commit. Could you please send an updated version?

Thanks,

Mathieu
D
D
Danial Behzadi wrote on 7 Jan 14:24 +0100
[PATCH] gnu: tractor: Change URI of source.
(address . 67481@debbugs.gnu.org)
EW7W6S.7GSJ9D5NH7ME3@ubuntu.com
Close in favor of #68303
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67481@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67481
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch