[PATCH gnome-team] gnu: sushi: Update to 44.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
2519e9b6dacac21d85b383252331bb1859cd91bf.1701043773.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (sushi): Update to 44.2.
[arguments]: Convert to list of G-Expressions.

Change-Id: Ifd87eb3eed82b3fb2921d23fa27e161fe8361069
---
gnu/packages/gnome.scm | 29 +++++++++++++++--------------
1 file changed, 15 insertions(+), 14 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d354327497..2bcd427012 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1621,7 +1621,7 @@ (define-public gnome-user-share
(define-public sushi
(package
(name "sushi")
- (version "42.0")
+ (version "44.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1629,21 +1629,22 @@ (define-public sushi
name "-" version ".tar.xz"))
(sha256
(base32
- "0848gidl0ab8i5pa70mv8jzchmd9kqa8sn1lg977hyasyixdpn25"))))
+ "1sa3x8w8fhjj641yx5praabkqxfdsnafqnlb8jx2g451mvh2y03c"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'glib-or-gtk-wrap 'wrap-typelib
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prog (string-append (assoc-ref outputs "out")
- "/bin/sushi")))
- ;; Put existing typelibs before sushi's deps, so as to
- ;; correctly infer gdk-pixbuf.
- (wrap-program prog
- `("GI_TYPELIB_PATH" suffix
- (,(getenv "GI_TYPELIB_PATH"))))))))))
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'glib-or-gtk-wrap 'wrap-typelib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/sushi")))
+ ;; Put existing typelibs before sushi's deps, so as to
+ ;; correctly infer gdk-pixbuf.
+ (wrap-program prog
+ `("GI_TYPELIB_PATH" suffix
+ (,(getenv "GI_TYPELIB_PATH"))))))))))
(native-inputs
(list `(,glib "bin")
gettext-minimal

base-commit: e21f0cb7b7a87992004193cd56638ad961fe5928
--
2.41.0
Maxim Cournoyer wrote 1 years ago
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
87v89eu5z1.fsf@gmail.com
Hello,

Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (5 lines)
> * gnu/packages/gnome.scm (sushi): Update to 44.2.
> [arguments]: Convert to list of G-Expressions.
>
> Change-Id: Ifd87eb3eed82b3fb2921d23fa27e161fe8361069

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>

--
Thanks,
Maxim
Vivien Kraus wrote 1 years ago
Applied, closing
(address . 67471-done@debbugs.gnu.org)
725ed80633f700c36c08fb1286bb202f0ec80473.camel@planete-kraus.eu
Applied, closing.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67471@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67471
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help