[PATCH gnome-team] gnu: python-pyatspi: Update to 2.46.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
2f11e6684d98992f858e2f4c5a6e225e0b12bfe5.1701039796.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (python-pyatspi): Update to 2.46.0.
[arguments]: Convert to list of G-Expressions.

Change-Id: I88c6b33154c21cd165e800b3a3e8a584eee50abd
---
gnu/packages/gnome.scm | 19 ++++++++++---------
1 file changed, 10 insertions(+), 9 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d354327497..8624c79de3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11053,7 +11053,7 @@ (define-public gnome-system-monitor
(define-public python-pyatspi
(package
(name "python-pyatspi")
- (version "2.45.90")
+ (version "2.46.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -11062,16 +11062,17 @@ (define-public python-pyatspi
"/pyatspi-" version ".tar.xz"))
(sha256
(base32
- "1fggihg4xmwia0xgjkcraiqk76jvyrj1pcsw99rjh4yn3kygisrh"))))
+ "0bn6f1cn5z3fdg98irbm4265y0ri7fdr9s1m385ibaj77p7qjm6l"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'fix-atk-load
- (lambda _
- (substitute* "pyatspi/__init__.py"
- (("from gi.repository import Atspi")
- "gi.require_version('Gtk', '3.0')
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'fix-atk-load
+ (lambda _
+ (substitute* "pyatspi/__init__.py"
+ (("from gi.repository import Atspi")
+ "gi.require_version('Gtk', '3.0')
from gi.repository import Gtk
from gi.repository import Atspi")))))))
(native-inputs

base-commit: e21f0cb7b7a87992004193cd56638ad961fe5928
--
2.41.0
Maxim Cournoyer wrote 1 years ago
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
87plzmx2mt.fsf@gmail.com
Hi,

Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (3 lines)
> * gnu/packages/gnome.scm (python-pyatspi): Update to 2.46.0.
> [arguments]: Convert to list of G-Expressions.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>

--
Thanks,
Maxim
Vivien Kraus wrote 1 years ago
Applied, closing
(address . 67465-done@debbugs.gnu.org)
2b9574ff914fbd4fd75e5c7af17dc1263cd85710.camel@planete-kraus.eu
Applied, closing.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67465@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67465
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help