[PATCH] home: services: unclutter: Convert to non-one-shot service

  • Open
  • quality assurance status badge
Details
One participant
  • Saku Laesvuori
Owner
unassigned
Submitted by
Saku Laesvuori
Severity
normal
S
S
Saku Laesvuori wrote on 26 Nov 2023 10:00
(address . guix-patches@gnu.org)(name . Saku Laesvuori)(address . saku@laesvuori.fi)
d61d25b0d5875d3350babd43fb4bef2d64a5233b.1700989215.git.saku@laesvuori.fi
* gnu/home/services/desktop.scm (home-unclutter-shepherd-service)
[one-shot?]: Remove field.
[stop]: Add kill action.

Change-Id: I33551607b05dbac30da94f81fd605ff9624ebe24
---
gnu/home/services/desktop.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/home/services/desktop.scm b/gnu/home/services/desktop.scm
index 91465bf168..6bb117ea8c 100644
--- a/gnu/home/services/desktop.scm
+++ b/gnu/home/services/desktop.scm
@@ -347,7 +347,6 @@ (define (home-unclutter-shepherd-service config)
(shepherd-service
(provision '(unclutter))
(requirement '())
- (one-shot? #t)
(start #~(make-forkexec-constructor
(list
#$(file-append
@@ -360,7 +359,8 @@ (define (home-unclutter-shepherd-service config)
(or (getenv "XDG_STATE_HOME")
(format #f "~a/.local/state"
(getenv "HOME")))
- "/log/unclutter.log"))))))
+ "/log/unclutter.log")))
+ (stop #~(make-kill-destructor)))))
(define home-unclutter-service-type
(service-type

base-commit: 9f67681db15d22f7ede5488315d52b78e357343e
--
2.41.0
S
S
Saku Laesvuori wrote on 15 Jan 16:50 +0100
(address . guix-patches@gnu.org)
nlpl3o6hzsuagsskn3xlfvjzxt5a5ivlyucueym7n6doy3p75m@7azrwrkk3bzn
On Sun, Nov 26, 2023 at 11:00:15AM +0200, Saku Laesvuori wrote:
Toggle quote (4 lines)
> * gnu/home/services/desktop.scm (home-unclutter-shepherd-service)
> [one-shot?]: Remove field.
> [stop]: Add kill action.

A reminder about this trivial change. The unclutter service spawns a
process that hides the cursor when it is inactive. The process runs for
the entire session and killing it causes the cursor to stay visible even
when inactive, so it seems to me that it should be provided by a normal
service that can be started/stopped.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoMkZR3NPB29fCOn/JX0oSiodOjIFAmWlVDQACgkQJX0oSiod
OjItFQ//SwUo4D4K8COWqcZCj4pvXOjSriJKDi+S99zPgNGAS1DCh9VMZIq2HPYi
IInrJqHWcfB6ioJQIL7SE8TYT1etGGezgvkCxgnKpfU4O/BvsG843hXhIiCtXXFH
SgGE3sZCWsAGX1Jp3uKleooL3/WgrV7BJTKHZ6/F8fugxj6V6y53rlgvOiV8tTow
fayijqV+5VV7UkCrxjz/qx+CBiOEuWvrUHAWTIqO87Hmv0Aq7vtWvlH5OX4W9zQw
wSR/Dg/V69BbBTyRFCMFWmrAYZKkfWw5vMpCCPXuXaZUmo0vpviaH0pRqbdT14Y1
U6Sll8Ojquecbyx+IPkJIN9NVTR4Xs+kZ+e9JrDUpizWtcwhX/lbI9XIaVwd3Yf4
sT9ZQYFOcBV/U/c376nCgFhY8dEhqgV43kY+7mASWjLVXdpBajmIGfmryf2WHjT+
TPhKgBl8qdokQ4sWpbDsQpKSIADd7Ky4lbhQoV12gOds3xpr04wFzQgbFszzBejN
DquDIYM5FusMh8j5mDyCGFsqrUqyXrAzhy4D6LDcbYfa2CQExWoX2rxaNY7Tm9e1
wb97Ebk56iUHZZMrqQ1aqkv7g5sw9Iuu42OfxSbTQWp+9K9sbGKPtwLAxipp/Z6H
GksLabCJt8Xp1OzRZ2dk5+z5vuWi3XKUPPmQOICE/tpZTOwjo9Q=
=zJ1o
-----END PGP SIGNATURE-----


S
S
Saku Laesvuori wrote on 22 Mar 10:15 +0100
Re: [bug#67453] [PATCH] home: services: unclutter: Convert to non-one-shot service
(address . 67453@debbugs.gnu.org)
drf6knf4naen44sm6a5qpp5vrvjohzep6mzhwvmttfmsrm575b@ranreqirjalf
On Mon, Jan 15, 2024 at 05:50:12PM +0200, Saku Laesvuori wrote:
Toggle quote (11 lines)
> On Sun, Nov 26, 2023 at 11:00:15AM +0200, Saku Laesvuori wrote:
> > * gnu/home/services/desktop.scm (home-unclutter-shepherd-service)
> > [one-shot?]: Remove field.
> > [stop]: Add kill action.
>
> A reminder about this trivial change. The unclutter service spawns a
> process that hides the cursor when it is inactive. The process runs for
> the entire session and killing it causes the cursor to stay visible even
> when inactive, so it seems to me that it should be provided by a normal
> service that can be started/stopped.

Ping
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoMkZR3NPB29fCOn/JX0oSiodOjIFAmX9TD0ACgkQJX0oSiod
OjLHkRAAsqIpY7C2VU0nFg3jQ/oGPLNCV/s3wCB88TKGK4uq72XQQhDmJ84kkzY4
6n/NkXD3Rj9MEn4QZSkhBL65hYJrZKO9aF87h+zY+yNxWhEmt1DBhTUtMNgKUwfl
0mIsGzpAMRMBaK2GukzoxjZITcz/UZ0ZkDL8XzFSAueF1KajiYAo50PXSaAd905W
5hhpkWuc/minGt/s259BMq1OpV7MBfKiZwyNHBPyG5sCp8/Xbx8PxCQorOM+CF2X
KzmUzb52qf7gwyUwM/nDMtnaux468IX4odhsquymYCeRHIuTegg/u423Tj5p/GQV
YTQoP55Kx09e8AHYCIqx6Hodg1HU0ZaN0vGOfwFFXH0VUhmlcKDMUsfpH+GsOeJk
D5v0N8tHf2bvPdkKeDo2wV2nYRqkzE6iFOGPbLqimKh5stM/7DhLsjiEibBg3tUf
P4hGRssqll8g8BmN3jmdJaMQehOCvFg+xFR0EmgJ3GyCZVJr8gMBl0zuZlKasUS2
6AnaqWhnRNgBVIwLQWhHQbh44snREZ8DzJ5P4xQhLeaA+qp59pJltfoWFPozdHnA
mQktSGNHqxBoO1k/pPDHxAjOO3Sv4AAsGBVxuBVhv4FQ/Lhi0DT86C2e4OaQVY0t
Lqa17rUh78/FOzfcRrjXD1B2lb/VyYmFYxbKc1T954cYlZnOV0o=
=qBe4
-----END PGP SIGNATURE-----


?