[PATCH] licenses: Add CC-PDDC license.

  • Done
  • quality assurance status badge
Details
3 participants
  • Aaron Covrig
  • Leo Famulari
  • Simon Tournier
Owner
unassigned
Submitted by
Aaron Covrig
Severity
normal
A
A
Aaron Covrig wrote on 26 Nov 2023 04:11
(address . guix-patches@gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
126d21100411182bcc88411b0080a288fac6aa0a.1700968299.git.aaron.covrig.us@ieee.org
* gnu/license.scm (CC-PDDC): New variable.

Change-Id: I272f08fde34aaba7acf4cca3327e56fe065dcf10
---
Adding a less common Creative Commons license from the Linux Foundation
SPDX license list for the inclusion of additional software.
guix/licenses.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (29 lines)
diff --git a/guix/licenses.scm b/guix/licenses.scm
index d200614d91..291bccdf56 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -48,6 +48,7 @@ (define-module (guix licenses)
bsd-0 bsd-1 bsd-2 bsd-3 bsd-4
non-copyleft
cc0
+ cc-pddc
cc-by2.0 cc-by3.0 cc-by4.0
cc-by-sa2.0 cc-by-sa3.0 cc-by-sa4.0
cddl1.0 cddl1.1
@@ -262,6 +263,11 @@ (define cc0
"http://directory.fsf.org/wiki/License:CC0"
"http://www.gnu.org/licenses/license-list.html#CC0"))
+(define cc-pddc
+ (license "CC-PDDC"
+ "https://spdx.org/licenses/CC-PDDC"
+ "Creative Commons Public Domain Dedication and Certification"))
+
(define cc-by-sa4.0
(license "CC-BY-SA 4.0"
"http://creativecommons.org/licenses/by-sa/4.0/"

base-commit: d987b75618a62c95c030e7ca53e0972e700c4f06
prerequisite-patch-id: b20d54ba34bb720fc0d3f0d0cf88b4f453c62e32
--
2.41.0
A
A
Aaron Covrig wrote on 26 Nov 2023 15:15
[PATCH v1] licenses: Add CC-PDDC license.
(address . 67451@debbugs.gnu.org)(name . Aaron Covrig)(address . aaron.covrig.us@ieee.org)
c93cb28d27b4237872156e4e0c67c5d4d0f06fb6.1701008131.git.aaron.covrig.us@ieee.org
* gnu/license.scm (CC-PDDC): New variable.
* guix/import/utils.scm : Add CC-PDDC.

Change-Id: I272f08fde34aaba7acf4cca3327e56fe065dcf10
---
Missed adding the identifier into import/utils.scm

guix/import/utils.scm | 1 +
guix/licenses.scm | 6 ++++++
2 files changed, 7 insertions(+)

Toggle diff (41 lines)
diff --git a/guix/import/utils.scm b/guix/import/utils.scm
index 0cf52cdbde..4b44ff0a0b 100644
--- a/guix/import/utils.scm
+++ b/guix/import/utils.scm
@@ -190,6 +190,7 @@ (define %spdx-license-identifiers
("BSD-3-Clause" . license:bsd-3)
("BSD-4-Clause" . license:bsd-4)
("CC0-1.0" . license:cc0)
+ ("CC-PDDC" . license:cc-pddc)
("CC-BY-2.0" . license:cc-by2.0)
("CC-BY-3.0" . license:cc-by3.0)
("CC-BY-4.0" . license:cc-by4.0)
diff --git a/guix/licenses.scm b/guix/licenses.scm
index d200614d91..291bccdf56 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -48,6 +48,7 @@ (define-module (guix licenses)
bsd-0 bsd-1 bsd-2 bsd-3 bsd-4
non-copyleft
cc0
+ cc-pddc
cc-by2.0 cc-by3.0 cc-by4.0
cc-by-sa2.0 cc-by-sa3.0 cc-by-sa4.0
cddl1.0 cddl1.1
@@ -262,6 +263,11 @@ (define cc0
"http://directory.fsf.org/wiki/License:CC0"
"http://www.gnu.org/licenses/license-list.html#CC0"))
+(define cc-pddc
+ (license "CC-PDDC"
+ "https://spdx.org/licenses/CC-PDDC"
+ "Creative Commons Public Domain Dedication and Certification"))
+
(define cc-by-sa4.0
(license "CC-BY-SA 4.0"
"http://creativecommons.org/licenses/by-sa/4.0/"

base-commit: d987b75618a62c95c030e7ca53e0972e700c4f06
prerequisite-patch-id: b20d54ba34bb720fc0d3f0d0cf88b4f453c62e32
--
2.41.0
S
S
Simon Tournier wrote on 28 Nov 2023 11:01
Re: [bug#67451] [PATCH] licenses: Add CC-PDDC license.
87plzuci2c.fsf@gmail.com
Hi,

Thanks for the patch.

On Sat, 25 Nov 2023 at 22:11, Aaron Covrig via Guix-patches via <guix-patches@gnu.org> wrote:

Toggle quote (2 lines)
> * gnu/license.scm (CC-PDDC): New variable.

Well, a naive question: what package(s) could potentially use this
license?

Moreover, this license is not listed in:


and the link https://spdx.org/licenses/CC-PDDC points to:



Cheers,
simon
A
A
Aaron Covrig wrote on 28 Nov 2023 19:12
(address . 67451@debbugs.gnu.org)
20231128131233.61cabfb8@mobile-dev
On Tue, 28 Nov 2023 11:01:47 +0100
Simon Tournier <zimon.toutoune@gmail.com> wrote:

Toggle quote (25 lines)
> Hi,
>
> Thanks for the patch.
>
> On Sat, 25 Nov 2023 at 22:11, Aaron Covrig via Guix-patches via
> <guix-patches@gnu.org> wrote:
>
> > * gnu/license.scm (CC-PDDC): New variable.
>
> Well, a naive question: what package(s) could potentially use this
> license?
>
> Moreover, this license is not listed in:
>
> https://www.gnu.org/licenses/license-list.html
>
> and the link <https://spdx.org/licenses/CC-PDDC> points to:
>
> https://creativecommons.org/licenses/publicdomain/ [no longer live]
>
>
> Cheers,
> simon
>

Good question, I'm slowly trying to run through some rust packages
(mostly in crates-io.scm) with the intent of upgrading nu-shell
(currently quite out of date to the extent that most online
documenation is now dubious with new features added and a lot of
commands removed or changed). While adding and upgrading packages, I
ran across the rust package `pwd` (https://crates.io/crates/pwd/1.4.0)
which uses this license.

There is a slim chance the author might be willing to update the
package to a dual license, but it seemed like adding this would still
be useful for completeness sake (and in the case that they aren't able
to be reached easily).

V/R,

Aaron
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQSPXVwROJGaYSBOwhhfTkc5aZTD/QUCZWYtkQAKCRBfTkc5aZTD
/Z3rAP98B8oW3hGHFgnRcFRFsBzGSBUC75X5uNl5kIR/diq1MwEAgyJdCTPEeWrK
Ijdm3ZQdgcFUIS2PGIep2P8kzO/zFAc=
=Vb7Y
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 29 Dec 2023 23:17
(name . Aaron Covrig via Guix-patches via)(address . guix-patches@gnu.org)(address . 67451-done@debbugs.gnu.org)
ZY9Fj6YtdoGPt89M@jasmine.lan
On Tue, Nov 28, 2023 at 01:12:33PM -0500, Aaron Covrig via Guix-patches via wrote:
Toggle quote (13 lines)
> Good question, I'm slowly trying to run through some rust packages
> (mostly in crates-io.scm) with the intent of upgrading nu-shell
> (currently quite out of date to the extent that most online
> documenation is now dubious with new features added and a lot of
> commands removed or changed). While adding and upgrading packages, I
> ran across the rust package `pwd` (https://crates.io/crates/pwd/1.4.0)
> which uses this license.
>
> There is a slim chance the author might be willing to update the
> package to a dual license, but it seemed like adding this would still
> be useful for completeness sake (and in the case that they aren't able
> to be reached easily).

Thanks for working on the Rust packages and looking ahead towards
needing this license.

I'm going to put this patch on the backburner for now, until we actually
have some patches that need this license. When the time comes, we can
reopen this ticket.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEaEByLu7k06ZO5T6saqwZY3V/R/8FAmWPRY4ACgkQaqwZY3V/
R/91wRAAiBXhUIcIUy9MOs8TzlExekfkBvJpJUQdRnMvgGxxAI/YyFLw8H658Ynk
moV+Ho9CibPPYiycC/G9/+gopdsvsr0OSGitPZmVleVJsXfzQRLKfaBm4699i3Ce
eTIvljKt0sVUPa1rD8WY9+3rm9KernoIVTbq3vcIfRNh3ZAjatvH5/k9oxjXmEg3
XDUDjSf+0AIsaOq2KQAuZGJ8xxORqZFsVxTkxkrrcELF/H8usjfVf+aRXld5AZID
NM6WtmKddnSH2vIA0bqKpXQT/dMxVuzf19ha4uM4ixjdlv3xrQOFb9P85TMlv2aN
oEXakm69RtfCByD4WFwEh5lxaNf4n2hb05slC7LG2w7Rooq1pj1CEOFI2WYVrLM0
gzZybvzQOJD5e7L9Fjwm0xbqgPY+IK4pTi2jd0PMT77OG4EXJGKCYdtsEzjbA2ZS
lgMT1SNLN6znV8XRr9B8ZmXIAWw4jTV2nE2kh2HQLEjmbSZxAlclDJ2OgsT0HRZ9
8kwhuIFMG1RxvAPgnt3tSYw6ni4bKWrQz/xvWnuamRyiITrnMv9C6sX0fIHM2mjo
ovz3xFhSFNXFUHd2tmmjsW9OeTJQdMXryUh1+3mKW/BYcivop+CBT95cCjOK9De8
bv3KqNLl4KJDQQPdayWAfMD/VrA6yUE6qdkg1gPOI+gfX6w8o6k=
=0Xz1
-----END PGP SIGNATURE-----


?