Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/gnome.scm (gupnp): Update to 1.6.6.
[arguments]: Convert to list of G-Expressions.
[#:configure-flags]: Add -Dgtk_doc=true.
[native-inputs]: Add gi-docgen.
Change-Id: Ia173720a9b888b4064417f1df79508a8c5b7fb14
---
gnu/packages/gnome.scm | 19 +++++++++++--------
1 file changed, 11 insertions(+), 8 deletions(-)
Toggle diff (45 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 194a443484..dff57f65c6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1379,7 +1379,7 @@ (define-public gssdp-1.4
(define-public gupnp
(package
(name "gupnp")
- (version "1.5.4")
+ (version "1.6.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1387,17 +1387,20 @@ (define-public gupnp
name "-" version ".tar.xz"))
(sha256
(base32
- "0y0v0m6afnx879hjvhj2lrawp9qhpyp8mbds0yp544imghajk0wq"))))
+ "0kx0ymsab4x927ir2a5f7mfk9sck5kswbig6n38r4dwbqzl51p69"))))
(build-system meson-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'pre-check
- (lambda _
- ;; Tests require a writable HOME.
- (setenv "HOME" (getcwd)))))))
+ (list
+ #:configure-flags #~'("-Dgtk_doc=true")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a writable HOME.
+ (setenv "HOME" (getcwd)))))))
(native-inputs
(list gettext-minimal
+ gi-docgen
`(,glib "bin")
gobject-introspection
gtk-doc/stable
base-commit: 60db3a6b3f6e4d1bd751d04b7d9ad1e894febf93
--
2.41.0