[PATCH] gnu: Add perl-mousex-params-validate.

  • Open
  • quality assurance status badge
Details
One participant
  • Rikard Nordgren
Owner
unassigned
Submitted by
Rikard Nordgren
Severity
normal
R
R
Rikard Nordgren wrote on 22 Nov 2023 21:05
(address . guix-patches@gnu.org)(address . hrn@posteo.net)
c7c494b6f5baf9cab497d82ad7061b276e7f2099.1700683508.git.hrn@posteo.net
* gnu/packages/perl.scm (perl-mousex-params-validate): New variable.

Change-Id: I1f31b2a76eee1c7bce3d0e07235a496a07c94671
---
gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8b82c272fc..a448d270a0 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8077,6 +8077,30 @@ (define-public perl-mousex-nativetraits
of data.")
(license (package-license perl))))
+(define-public perl-mousex-params-validate
+ (package
+ (name "perl-mousex-params-validate")
+ (version "0.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/manwar/MouseX-Params-Validate")
+ (commit "6b3c2c10537dd5c9cb7b068e3647b72ec5b39c49")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0yzwp0c2317mr99h5vadwh4fd6pwf26ypc3xnlb494p7hyb36a6l"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-devel-caller perl-mouse perl-params-validate
+ perl-sub-exporter))
+ (home-page "https://metacpan.org/pod/MouseX::Params::Validate")
+ (synopsis "Extension of @code{Params::Validate} using Mouse's types")
+ (description
+ "Method parameter validation extension to Mouse.
+Code borrowed entirely from @code{MooseX::Params::Validate} and stripped Moose
+footprints.")
+ (license license:artistic2.0)))
+
(define-public perl-mozilla-ca
(package
(name "perl-mozilla-ca")

base-commit: 23627b1706af25a0a30b96b9169a3495279aff1b
--
2.34.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67385@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67385
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch