[PATCH 05/10] gnu: Add rust-vt100 0.15.

  • Done
  • quality assurance status badge
Details
2 participants
  • gravitydiv10
  • Nicolas Goaziou
Owner
unassigned
Submitted by
gravitydiv10
Severity
normal

Debbugs page

gravitydiv10 wrote 1 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)(name . gravitydiv10@protonmail.com)(address . gravitydiv10@protonmail.com)
DzzPIo_ay9L64UigDKkE-bgjaZdpzgkcAANj0YXn9tlSA8hzCW0zdXpcq-xPzwIletcLFtxvYvAsjTHovmxWW4eHvoOVCVmLErNTH58Yl2Q=@protonmail.com
From 77be122c0001cbf75ae45c5745a772d688ac5b7d Mon Sep 17 00:00:00 2001
Message-ID: <77be122c0001cbf75ae45c5745a772d688ac5b7d.1700662237.git.gravitydiv10@protonmail.com>
In-Reply-To: <a61e0dec65d0b4c9f04dc5bc6bb4768d0ff170d9.1700662237.git.gravitydiv10@protonmail.com>
References: <a61e0dec65d0b4c9f04dc5bc6bb4768d0ff170d9.1700662237.git.gravitydiv10@protonmail.com>
From: Lu <gravitydiv10@protonmail.com>
Date: Wed, 22 Nov 2023 21:55:18 +0800
Subject: [PATCH 05/10] gnu: Add rust-vt100 0.15.

* gnu/packages/crates-io.scm (rust-vt100-0.15): New variable.

Change-Id: I3c40d2d7d51358ade4ebac06d290c25f28c2c4d8
---
gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7c512a1e89..5e02b1cda9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -81255,6 +81255,29 @@ (define-public rust-vswhom-sys-0.1
"This package provides a pure FFI to Jon Blow's VS discovery script.")
(license license:expat)))
+(define-public rust-vt100-0.15
+ (package
+ (name "rust-vt100")
+ (version "0.15.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "vt100" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1pklc8y984axmxr0cd363srr2d27wd5rj15xlcmkjznvy0xqdkc4"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-itoa" ,rust-itoa-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-unicode-width" ,rust-unicode-width-0.1)
+ ("rust-vte" ,rust-vte-0.11))))
+ (home-page "https://github.com/doy/vt100-rust")
+ (synopsis "Library for parsing terminal data")
+ (description "This package provides function for parsing terminal data in Rust.")
+ (license license:expat)))
+
(define-public rust-vte-0.10
(package
(name "rust-vte")
--
2.41.0
Nicolas Goaziou wrote 2 weeks ago
(address . 67376-done@debbugs.gnu.org)
874j0284v5.fsf@nicolasgoaziou.fr
Toggle quote (2 lines)
> Subject: [PATCH 05/10] gnu: Add rust-vt100 0.15.

Package already in Guix. Closing.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67376@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67376
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help