[PATCH 01/10] gnu: Add rust-simplelog 0.12.1.

  • Open
  • quality assurance status badge
Details
One participant
  • gravitydiv10
Owner
unassigned
Submitted by
gravitydiv10
Severity
normal
G
G
gravitydiv10 wrote on 22 Nov 2023 15:12
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)(name . gravitydiv10@protonmail.com)(address . gravitydiv10@protonmail.com)
BH73NczgBlsyzJzzshik5Te4LwGhZfZB04Vm0hDJ59OD4mN7mPUxatlVj1HzF6BhalFe7HHuqpUVHkSrH4xUq7wBxJehGuspocR_nV-yRpo=@protonmail.com
From a61e0dec65d0b4c9f04dc5bc6bb4768d0ff170d9 Mon Sep 17 00:00:00 2001
Message-ID: <a61e0dec65d0b4c9f04dc5bc6bb4768d0ff170d9.1700662237.git.gravitydiv10@protonmail.com>
From: Lu <gravitydiv10@protonmail.com>
Date: Wed, 22 Nov 2023 21:33:07 +0800
Subject: [PATCH 01/10] gnu: Add rust-simplelog 0.12.1.

* gnu/packages/crates-io.scm (rust-simple-0.12): New variable.

Change-Id: I66dcd57d15912040f0ff28645ef3ac5fe0ce02ae
---
gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d42ff60a20..a0c357d2f0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2022 Paul Alesius <paul@unnservice.com>
;;; Copyright © 2023 Arnav Andrew Jose <arnav.jose@gmail.com>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
+;;; Copyright © 2023 Lu <gravitydiv10@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -66429,6 +66430,26 @@ (define-public rust-simplelog-0.11
small to medium sized project")
(license (list license:expat license:asl2.0))))
+(define-public rust-simplelog-0.12
+ (package
+ (inherit rust-simplelog-0.11)
+ (name "rust-simplelog")
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "simplelog" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0sa3hjdifxhcb9lnlg549fr2cc7vz89nygwbih2dbqsx3h20ivmc"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-ansi-term" ,rust-ansi-term-0.12)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-paris" ,rust-paris-1)
+ ("rust-termcolor" ,rust-termcolor-1)
+ ("rust-time" ,rust-time-0.3))))))
+
(define-public rust-simple-logger-2
(package
(name "rust-simple-logger")

base-commit: fc6bdaad57bf91609849623c5f485403c030cb49
prerequisite-patch-id: 1b27e2939325bda399993d7b2b0afafc59c64342
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67372@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67372
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch