(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
From 607a7269252b9382c17aae7bc3899d9a6529c4d2 Mon Sep 17 00:00:00 2001Message-ID: <607a7269252b9382c17aae7bc3899d9a6529c4d2.1700658800.git.gravitydiv10@protonmail.com>
From: Lu <gravitydiv10@protonmail.com>
Date: Wed, 22 Nov 2023 21:12:53 +0800
Subject: [PATCH] gnu: Add empty.
* gnu/packages/terminals.scm (empty): New variable.
Change-Id: I5d96a8dfc5009dda1fc3d761b47b133a0021085a
---
gnu/packages/terminals.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
Toggle diff (46 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index adb5e223e7..336e33c2a5 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
+;;; Copyright © 2023 Lu <gravitydiv10@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1699,3 +1700,31 @@ (define-public bootterm
support for non-standard baud rates, the ability to wait for ports to appear,
and the ability to read and write via stdin and stdout.")
(license license:expat)))
+
+(define-public empty
+ (package
+ (name "empty")
+ (version "0.6.23c")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://sourceforge.net/projects/empty/files/empty/empty-"
+ version "/empty-" version ".tgz"))
+ (sha256
+ (base32 "1g8hw047y34hrrkcy84g5hfrky5iwc5zrsn779sddilx173shz4a"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags (list (string-append "CC="
+ ,(cc-for-target))
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://empty.sourceforge.net")
+ (synopsis "Simple tool for automating interactive application")
+ (description
+ "Run applications under pseudo-terminal (PTY) sessions and
+replace TCL/Expect with a simple tool under your favourite shell.")
+ (license license:expat)))
base-commit: fc6bdaad57bf91609849623c5f485403c030cb49
--
2.41.0