[PATCH] gnu: Add empty.

  • Open
  • quality assurance status badge
Details
One participant
  • gravitydiv10
Owner
unassigned
Submitted by
gravitydiv10
Severity
normal
G
G
gravitydiv10 wrote on 22 Nov 2023 14:20
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
zJJy36kFXfCV_ZDyCgjU9Yr3N5I4oh5KpGDCfWFWInGzT2ubO-eRuamjHTDRJ6lOwwX1vyUcyXuAy1YXXQu73Fw6L38LFj1FH6MAtnVYW3E=@protonmail.com
From 607a7269252b9382c17aae7bc3899d9a6529c4d2 Mon Sep 17 00:00:00 2001Message-ID: <607a7269252b9382c17aae7bc3899d9a6529c4d2.1700658800.git.gravitydiv10@protonmail.com>
From: Lu <gravitydiv10@protonmail.com>
Date: Wed, 22 Nov 2023 21:12:53 +0800
Subject: [PATCH] gnu: Add empty.

* gnu/packages/terminals.scm (empty): New variable.

Change-Id: I5d96a8dfc5009dda1fc3d761b47b133a0021085a
---
gnu/packages/terminals.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index adb5e223e7..336e33c2a5 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
+;;; Copyright © 2023 Lu <gravitydiv10@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1699,3 +1700,31 @@ (define-public bootterm
support for non-standard baud rates, the ability to wait for ports to appear,
and the ability to read and write via stdin and stdout.")
(license license:expat)))
+
+(define-public empty
+ (package
+ (name "empty")
+ (version "0.6.23c")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://sourceforge.net/projects/empty/files/empty/empty-"
+ version "/empty-" version ".tgz"))
+ (sha256
+ (base32 "1g8hw047y34hrrkcy84g5hfrky5iwc5zrsn779sddilx173shz4a"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags (list (string-append "CC="
+ ,(cc-for-target))
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://empty.sourceforge.net")
+ (synopsis "Simple tool for automating interactive application")
+ (description
+ "Run applications under pseudo-terminal (PTY) sessions and
+replace TCL/Expect with a simple tool under your favourite shell.")
+ (license license:expat)))

base-commit: fc6bdaad57bf91609849623c5f485403c030cb49
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67371@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67371
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch