[PATCH 0/2] Add solo2-cli to manage "solokeys"

  • Open
  • quality assurance status badge
Details
One participant
  • jrballesteros05
Owner
unassigned
Submitted by
jrballesteros05
Severity
normal
J
J
jrballesteros05 wrote on 21 Nov 2023 23:29
(name . Guix patches)(address . guix-patches@gnu.org)
c1d3775e586ef7e5a47f92cf8e7ce0bb@posteo.net
Hello Guix team, this is my first code contribution in a libre software
project so I would have a lot of mistakes despite I read the
documentation, if I make so many mistakes I am so sorry but many of the
stuffs from documentation are too advance for me.

I bought a couple of solokeys and I packaged the cli tool

I hope this contribution will be accepted.


Jrballesteros05 (2):
added solo2-cli software to manage solokeys
gnu: contributing: solo2 library and CLI

gnu/packages/crates-graphics.scm | 20 +
gnu/packages/crates-io.scm | 933 +++++++++++++++++++++++++++++++
gnu/packages/security-token.scm | 79 +++
3 files changed, 1032 insertions(+)


base-commit: 42be8fa560a7554ac35801b46c3a0a007fd742ce
--
2.41.0
J
J
jrballesteros05 wrote on 22 Nov 2023 09:43
[PATCH 1/2] added solo2-cli software to manage solokeys
(address . 67356@debbugs.gnu.org)
51a722a63aaeb687f9fea98e64b7a132@posteo.net
Change-Id: I08d61bee1d39066b6f2bfee35413e3963341c3f0
---
gnu/packages/crates-graphics.scm | 20 +
gnu/packages/crates-io.scm | 933 +++++++++++++++++++++++++++++++
gnu/packages/security-token.scm | 78 +++
3 files changed, 1031 insertions(+)

Toggle diff (573 lines)
diff --git a/gnu/packages/crates-graphics.scm
b/gnu/packages/crates-graphics.scm
index 22b77121e9..957ab53d39 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -198,6 +198,26 @@ (define-public rust-ansi-term-0.9
"1xif1bh938qpfc3d0f9xgidibpm65xix11w9gszwqnia00q7rb13"))))
(arguments `())))

+(define-public rust-ansi-term-0.7
+ (package
+ (inherit rust-ansi-term-0.11)
+ (name "rust-ansi-term")
+ (version "0.7.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ansi_term" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"03gpxx3vf9mlc1q5xa31dpbvf1k07k9ggcz3vl31rv44mp85l9rh"))))
+ (arguments
+ `())
+ (home-page "https://github.com/ogham/rust-ansi-term")
+ (synopsis "A library for controlling colours and formatting")
+ (description
+ "This is a library for controlling colours and formatting, such as
red bold text or blue underlined text, on ANSI terminals.")
+ (license license:expat)))
+
(define-public rust-aom-sys-0.3
(package
(name "rust-aom-sys")
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d42ff60a20..d0a42e60de 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6854,6 +6854,29 @@ (define-public rust-base16ct-0.2
embedded-friendly no_std support.")
(license (list license:asl2.0 license:expat))))

+(define-public rust-base16ct-0.1
+ (package
+ (inherit rust-base16ct-0.2)
+ (name "rust-base16ct")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "base16ct" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"1klccxr7igf73wpi0x3asjd8n0xjg0v6a7vxgvfk5ybvgh1hd6il"))))
+ (home-page
"https://github.com/RustCrypto/formats/tree/master/base16ct")
+ (synopsis
+ "Rust implementation of Base16 a.k.a hexadecimal")
+ (description
+ "This package provides a pure Rust implementation of Base16 a.k.a
+hexadecimal (RFC 4648) which avoids any usages of data-dependent
branches/LUTs
+and thereby provides portable \"best effort\" constant-time operation
and
+embedded-friendly no_std support.")
+ (license (list license:expat
+ license:asl2.0))))
+
(define-public rust-base32-0.4
(package
(name "rust-base32")
@@ -8405,6 +8428,29 @@ (define-public rust-bitflags-0.7
(base32
"0v8hh6wdkpk9my8z8442g4hqrqf05h0qj53dsay6mv18lqvqklda"))))))

+(define-public rust-bitflags-0.4
+ (package
+ (inherit rust-bitflags-1)
+ (name "rust-bitflags")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "bitflags" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"18q4xvy9m7lhqwx46x1gzy5ywvpb6h4yb89ig5iwy9qi3i3dgsld"))))
+ (home-page "https://github.com/bitflags/bitflags")
+ (synopsis
+ "Generates flags enums with well-defined semantics and ergonomic
end-user APIs.")
+ (description
+ "Generates flags enums with well-defined semantics and ergonomic
end-user APIs.
+ You can use bitflags to:
+ provide more user-friendly bindings to C APIs where flags may or
may not be fully known in advance.
+ generate efficient options types with string parsing and
formatting support.")
+ (license (list license:expat
+ license:asl2.0))))
+
(define-public rust-bitflags-0.2
(package
(inherit rust-bitflags-1)
@@ -12983,6 +13029,60 @@ (define-public rust-clap-derive-3
("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-1))))))

+(define-public rust-clap-verbosity-flag-2.1
+ (package
+ (name "rust-clap-verbosity-flag")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "clap-verbosity-flag" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"1n5lpxkvv6yyaza8smizn9i0z4gbigqxvhx7xfm61r5bg5dj92d5"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list
+ #:cargo-inputs `(("rust-clap-builder" ,rust-clap-builder-4)
+ ("rust-clap" ,rust-clap-4)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-ansi-term" ,rust-ansi-term-0.7)
+ ("rust-bitflags" ,rust-bitflags-0.4)
+ ("rust-strsim" ,rust-strsim-0.4)
+ ("rust-vec-map" ,rust-vec-map-0.4))))
+ (home-page "https://github.com/clap-rs/clap-verbosity-flag")
+ (synopsis "Easily add a `--verbose` flag to CLIs using Clap ")
+ (description "Easily add a `--verbose` flag to CLIs using Clap ")
+ (license (list license:expat
+ license:asl2.0))))
+
+(define-public rust-clap-verbosity-flag-2.0
+ (package
+ (name "rust-clap-verbosity-flag")
+ (version "2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "clap-verbosity-flag" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"1pp7zrchy9cgn0jz03v09jhp7n7sww9lcfqwxgr3sl89j1v0bvqy"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list
+ #:cargo-inputs `(("rust-clap-builder" ,rust-clap-builder-4)
+ ("rust-clap" ,rust-clap-4)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-ansi-term" ,rust-ansi-term-0.7)
+ ("rust-bitflags" ,rust-bitflags-0.4)
+ ("rust-strsim" ,rust-strsim-0.4)
+ ("rust-vec-map" ,rust-vec-map-0.4))))
+ (home-page "https://github.com/clap-rs/clap-verbosity-flag")
+ (synopsis "Easily add a `--verbose` flag to CLIs using Clap ")
+ (description "Easily add a `--verbose` flag to CLIs using Clap ")
+ (license (list license:expat
+ license:asl2.0))))
+
(define-public rust-clap-4
(package
(name "rust-clap")
@@ -15091,6 +15191,26 @@ (define-public rust-const-oid-0.9
;; The user can choose either license.
(license (list license:asl2.0 license:expat))))

+(define-public rust-const-oid-0.7
+ (package
+ (inherit rust-const-oid-0.9)
+ (name "rust-const-oid")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "const-oid" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"1wwl3cncd8p2fa54vzmghflh4nh9ml02xfbv38nf5ziifh28riz4"))))
+ (home-page
"https://github.com/RustCrypto/formats/tree/master/const-oid")
+ (synopsis "Implementation of the ISO/IEC Object Identifier (OID)")
+ (description
+ "This package is a const-friendly implementation of the ISO/IEC
Object
+Identifier (OID) standard as defined in ITU X.660, with support for
BER/DER
+encoding/decoding as well as heapless no_std (i.e., embedded)
support.")
+ (license license:expat)))
+
(define-public rust-const-oid-0.6
(package
(inherit rust-const-oid-0.9)
@@ -17785,6 +17905,51 @@ (define-public rust-crypto-bigint-0.5
using const generics.")
(license (list license:asl2.0 license:expat))))

+(define-public rust-crypto-bigint-0.4
+ (package
+ (inherit rust-crypto-bigint-0.5)
+ (name "rust-crypto-bigint")
+ (version "0.4.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "crypto-bigint" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"1vqprgj0aj1340w186zyspi58397ih78jsc0iydvhs6zrlilnazg"))))
+ (home-page "https://github.com/RustCrypto/crypto-bigint")
+ (synopsis
+ "Big integer library designed for use in cryptography")
+ (description
+ "This crate is a pure Rust implementation of a big integer library
which
+has been designed from the ground-up for use in cryptographic
applications.
+Provides constant-time, no_std-friendly implementations of modern
formulas
+using const generics.")
+ (license (list license:expat
+ license:asl2.0))))
+
+(define-public rust-crypto-bigint-0.3
+ (package
+ (inherit rust-crypto-bigint-0.5)
+ (name "rust-crypto-bigint")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "crypto-bigint" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"08gx92sj93hk2smqy4nvk8lmpjjjqm7a9ps22q3pxqqxzbas3ih3"))))
+ (home-page "https://github.com/RustCrypto/crypto-bigint")
+ (synopsis
+ "Pure Rust implementation of a big integer library which has been
designed from the ground-up for use in cryptographic applications.
Provides constant-time, no_std-friendly implementations of modern
formulas using const generics.")
+ (description
+ "Pure Rust implementation of a big integer library which has been
designed from the ground-up for use in cryptographic applications.
+ Provides constant-time, no_std-friendly implementations of modern
formulas using const generics.")
+ (license (list license:expat
+ license:asl2.0))))
+
+
(define-public rust-crypto-bigint-0.2
(package
(inherit rust-crypto-bigint-0.5)
@@ -19793,6 +19958,29 @@ (define-public rust-dbus-tree-0.9
"This crate is a framework for writing D-Bus method handlers
(legacy).")
(license (list license:asl2.0 license:expat))))

+(define-public rust-delog-0.1
+ (package
+ (name "rust-delog")
+ (version "0.1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "delog" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"13xckqdw8b4s47sfqmq9lm0vdl808n11n9a18jfhqd32h8v96axg"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list
+ #:cargo-inputs `(("rust-log" ,rust-log-0.4))))
+ (home-page "https://delog.rs/")
+ (synopsis
+ "Deferred logging, an implementation and extension of Rust's
standard logging facade.")
+ (description
+ "Deferred logging, an implementation and extension of Rust's
standard logging facade.")
+ (license (list license:expat
+ license:asl2.0))))
+
(define-public rust-deadpool-0.7
(package
(name "rust-deadpool")
@@ -20289,6 +20477,32 @@ (define-public rust-der-0.6
(("rust-hex-literal" ,rust-hex-literal-0.3)
("rust-proptest" ,rust-proptest-1))))))

+(define-public rust-der-0.5
+ (package
+ (inherit rust-der-0.7)
+ (name "rust-der")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "der" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"0p3h7nszn7jhjacpmkjrcyx5g8p3ma1qhxfy3397m7l3fdfq26b9"))))
+ (arguments
+ (list
+ #:cargo-inputs `(("rust-const-oid" ,rust-const-oid-0.7)
+ ("rust-crypto-bigint" ,rust-crypto-bigint-0.3)
+ ("rust-pem-rfc7468" ,rust-pem-rfc7468-0.3))))
+ (home-page "https://github.com/RustCrypto/formats/tree/master/der")
+ (synopsis
+ "Pure Rust embedded-friendly implementation of the Distinguished
Encoding Rules (DER) for Abstract Syntax Notation One (ASN.1) as
described in ITU X.690 with full support for heapless no_std targets")
+ (description
+ "Pure Rust embedded-friendly implementation of the Distinguished
Encoding Rules (DER) for Abstract Syntax Notation One (ASN.1) as
described in ITU X.690.")
+ (license (list license:expat
+ license:asl2.0))))
+
+
(define-public rust-der-0.4
(package
(inherit rust-der-0.7)
@@ -22774,6 +22988,30 @@ (define-public rust-ecdsa-0.16
support for added entropy.")
(license (list license:asl2.0 license:expat))))

+(define-public rust-ecdsa-0.15
+ (package
+ (inherit rust-ecdsa-0.16)
+ (name "rust-ecdsa")
+ (version "0.15.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ecdsa" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"0zk3nz2qlczayd8w7zp3nh1skxh5nvrk1l16m62l3msab50l310j"))))
+ (arguments
+ (list
+ #:cargo-inputs `(("rust-rfc6979" ,rust-rfc6979-0.3)
+ ("rust-signature" ,rust-signature-2.0))))
+ (home-page
"https://github.com/RustCrypto/signatures/tree/master/ecdsa")
+ (synopsis
+ "Pure Rust implementation of the Elliptic Curve Digital Signature
Algorithm (ECDSA) as specified in FIPS 186-4 (Digital Signature
Standard), providing RFC6979 deterministic signatures as well as support
for added entropy.")
+ (description
+ "Elliptic Curve Digital Signature Algorithm (ECDSA) as specified
in FIPS 186-4 (Digital Signature Standard).")
+ (license (list license:expat
+ license:asl2.0))))
+
(define-public rust-ecies-ed25519-0.5
(package
(name "rust-ecies-ed25519")
@@ -23053,6 +23291,35 @@ (define-public rust-elliptic-curve-0.13
curve forms, scalars, points, and public/secret keys composed
thereof.")
(license (list license:asl2.0 license:expat))))

+(define-public rust-elliptic-curve-0.12
+ (package
+ (inherit rust-elliptic-curve-0.13)
+ (name "rust-elliptic-curve")
+ (version "0.12.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "elliptic-curve" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"1lwi108mh6drw5nzqzlz7ighdba5qxdg5vmwwnw1j2ihnn58ifz7"))))
+ (arguments
+ `(#:cargo-inputs (("rust-base16ct" ,rust-base16ct-0.1)
+ ("rust-crypto-bigint" ,rust-crypto-bigint-0.4)
+ ("rust-ff" ,rust-ff-0.12)
+ ("rust-group" ,rust-group-0.12)
+ ("rust-sec1" ,rust-sec1-0.3))))
+ (home-page
+ "https://github.com/RustCrypto/traits/tree/master/elliptic-curve")
+ (synopsis
+ "General purpose Elliptic Curve Cryptography (ECC) support")
+ (description
+ "This package provides general purpose @dfn{Elliptic Curve
Cryptography}
+(ECC) support, including types and traits for representing various
elliptic
+curve forms, scalars, points, and public/secret keys composed
thereof.")
+ (license (list license:expat
+ license:asl2.0))))
+
(define-public rust-emacs-0.18
(package
(name "rust-emacs")
@@ -23829,6 +24096,49 @@ (define-public rust-enum-map-derive-0.4
@code{#[derive(Enum)]}.")
(license (list license:expat license:asl2.0))))

+(define-public rust-enum-iterator-derive-1
+ (package
+ (name "rust-enum-iterator-derive")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "enum-iterator-derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"1jzxgfhz4i0hvnw5qzqhwscky8vsmxljv89g0navisacay4qbkzf"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list
+ #:cargo-inputs `(("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-2))))
+ (home-page "https://github.com/stephaneyfx/enum-iterator.git")
+ (synopsis "Procedural macro to derive Sequence.")
+ (description "Procedural macro to derive Sequence")
+ (license license:bsd-0)))
+
+(define-public rust-enum-iterator-1
+ (package
+ (name "rust-enum-iterator")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "enum-iterator" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"12g63d7w5vpq964f7fbnahw2qiqsml3f9j3rxrk6f1yxnmrkipbs"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list
+ #:cargo-inputs `(("rust-enum-iterator-derive"
,rust-enum-iterator-derive-1))))
+ (home-page "")
+ (synopsis
+ "Tools to iterate over all values of a type (e.g. all variants of
an enumeration)")
+ (description "Tools to iterate over the values of a type.")
+ (license license:bsd-0)))
+
(define-public rust-enum-map-0.6
(package
(name "rust-enum-map")
@@ -25727,6 +26037,25 @@ (define-public rust-ff-0.13
interfacing with finite fields.")
(license (list license:expat license:asl2.0))))

+(define-public rust-ff-0.12
+ (package
+ (inherit rust-ff-0.13)
+ (name "rust-ff")
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ff" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"0q3imz4m3dj2cy182i20wa8kbclgj13ddfngqb2miicc6cjzq4yh"))))
+ (home-page "https://github.com/zkcrypto/ff")
+ (synopsis "Library for building and interfacing with finite
fields.")
+ (description
+ "ff is a finite field library written in pure Rust, with no
unsafe{} code.")
+ (license (list license:expat
+ license:asl2.0))))
+
(define-public rust-ff-derive-0.13
(package
(name "rust-ff-derive")
@@ -26221,6 +26550,30 @@ (define-public rust-flate2-1
streams.")
(license (list license:expat license:asl2.0))))

+(define-public rust-flexiber-0.1
+ (package
+ (name "rust-flexiber")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "flexiber" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"1r9qg4bsdhl7p9hxn435lahhnnlpk65kin28b0zv1izfcqa5ppz3"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list
+ #:cargo-inputs `(("rust-delog" ,rust-delog-0.1))))
+ (home-page "https://github.com/nickray/flexiber")
+ (synopsis
+ "Encoding and decoding of BER-TLV as described in ISO 7816-4,
without allocations.")
+ (description
+ "Encoding and decoding of BER-TLV as described in ISO 7816-4,
without allocations.
+ Follows the approach taken in der, and then in simple-tlv.")
+ (license (list license:expat
+ license:asl2.0))))
+
(define-public rust-float-cmp-0.9
(package
(name "rust-float-cmp")
@@ -30317,6 +30670,25 @@ (define-public rust-group-0.13
(description "Elliptic curve group traits and utilities.")
(license (list license:expat license:asl2.0))))

+(define-public rust-group-0.12
+ (package
+ (inherit rust-group-0.13)
+ (name "rust-group")
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "group" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
"1ixspxqdpq0hxg0hd9s6rngrp6rll21v4jjnr7ar1lzvdhxgpysx"))))
+ (home-page "https://github.com/zkcrypto/group")
+ (synopsis "Elliptic curve group traits and utilities")
+ (description
+ "group is a crate for working with groups over elliptic curves.")
+ (license (list license:expat
+ license:asl2.0))))
+
(define-public rust-groupable-0.2
(package
(name "rust-groupable")
@@ -30590,6 +30962,28 @@ (define-public rust-half-1
("rust-quickcheck-macros" ,rust-quickcheck-macros-1)
("rust-rand" ,rust-rand-0.8))))))

+(define-public rust-hidapi-2
+ (package
+ (name "rust-hidapi")
+ (version "2.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hidapi" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+
This message was truncated. Download the full message here.
J
J
jrballesteros05 wrote on 22 Nov 2023 09:44
[PATCH 2/2] gnu: contributing: solo2 library and CLI
(address . 67356@debbugs.gnu.org)
89b2f7b1ff7eb23b1bb537f2f8417995@posteo.net
Change-Id: Id3173e3eaf1f89eb6c799ae27dc69afc7f929f16
---
gnu/packages/security-token.scm | 21 +++++++++++----------
1 file changed, 11 insertions(+), 10 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/security-token.scm
b/gnu/packages/security-token.scm
index 1e77e01374..bf1c43f054 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -1110,15 +1110,16 @@ (define-public pcsc-cyberjack
(define-public solo2-cli
(package
(name "solo2-cli")
- (version "0.2.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/solokeys/" name
- "/archive/refs/tags/v" version ".tar.gz"))
- (sha256
- ;; (base32
"0ck95limlnkva3vg3mcmnpa2y1n9dnka6d8njja852sa2zfzk7mf"))))
- (base32
"1d2z6glya1axnbr6p3p926b0jdmrz10rf210lmlfk2zkwrg0r8s9"))))
+ (version "v0.2.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/solokeys/solo2-cli")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+
"14jzc3kpr3850lg22xwbxrfvyy1xqjf39x3h4l565npq5bk4xnpf"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
@@ -1180,6 +1181,6 @@ (define-public solo2-cli
(home-page "https://github.com/solokeys/solo2-cli")
(native-inputs (list perl pkg-config))
(inputs (list libevdev libgudev pcsc-lite))
- (synopsis "solo2 library and cli")
+ (synopsis "Solo2 library and cli")
(description "This provides the tools to manage solokeys 2
devices")
(license (list license:expat license:asl2.0))))
--
2.41.0
?