[PATCH] Update Krita to 5.2.1

  • Done
  • quality assurance status badge
Details
2 participants
  • Mehmet Tekman
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Mehmet Tekman
Severity
normal
M
M
Mehmet Tekman wrote on 21 Nov 2023 22:58
(address . guix-patches@gnu.org)
87il5uu5tt.fsf@gmail.com
This updates Krita from 5.1.5 to 5.2.1, with extra package dependencies
from:


Please apply these patches first before testing this patch.

The fftw-cmake patch aims to address some missing FFTW Cmake files,
during the Krita configure stage, but sadly it still does not find them.

I'm submitting this patch in the hopes that someone can help debug this
issue further. I've CC'd the mentors teams.

Below is the current state of the patch.
From e884efecff6841a4ed3cb5d8d8fc7a94b84194ab Mon Sep 17 00:00:00 2001
From: Mehmet Tekman <mtekman89@gmail.com>
Date: Tue, 21 Nov 2023 17:35:14 +0100
Subject: [PATCH 3/3] gnu: krita: Update to 5.2.1

* gnu/packages/kde.scm (krita): Update to 5.2.1

Change-Id: I36bd54093817245d8fa0d1362de4d95f8087861a
---
gnu/packages/kde.scm | 27 +++++++++++++++++++++++----
1 file changed, 23 insertions(+), 4 deletions(-)

Toggle diff (114 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 20fbb41d73..9dfb360a72 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -63,6 +63,7 @@ (define-module (gnu packages kde)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages fribidi)
#:use-module (gnu packages geo)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
@@ -71,6 +72,7 @@ (define-module (gnu packages kde)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gps)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages graphics)
#:use-module (gnu packages image)
#:use-module (gnu packages image-processing)
@@ -93,8 +95,10 @@ (define-module (gnu packages kde)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages samba)
+ #:use-module (gnu packages sdl)
#:use-module (gnu packages ssh)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages unicode)
#:use-module (gnu packages qt)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
@@ -702,7 +706,7 @@ (define-public kolourpaint
(define-public krita
(package
(name "krita")
- (version "5.1.5")
+ (version "5.2.1")
(source
(origin
(method url-fetch)
@@ -710,7 +714,7 @@ (define-public krita
"mirror://kde/stable/krita/" version "/krita-" version
".tar.gz"))
(sha256
- (base32 "1lx4x4affkbh47b7w5qvahkkr4db0vcw6h24nykak6gpy2z5wxqw"))))
+ (base32 "1kzmn89b1vrasba7z8hp8izyrrskgc7ggnz82zqyyy1v5d8mnri7"))))
(build-system qt-build-system)
(arguments
`(#:tests? #f
@@ -727,15 +731,21 @@ (define-public krita
(inputs
(list boost
exiv2
- fftw
+ fontconfig
+ fftw-cmake
+ freetype
+ fribidi
giflib
gsl
+ harfbuzz
imath
+ immer
karchive
kcompletion
kconfig
kcoreaddons
kcrash
+ kfkdcraw
kguiaddons
ki18n
kiconthemes
@@ -745,21 +755,27 @@ (define-public krita
kwidgetsaddons
kwindowsystem
kxmlgui
+ lager
lcms
libjpeg-turbo
+ libjxl
libheif
libmypaint
libpng
libraw
libtiff
+ libunibreak
libwebp
libx11
libxcb
libxi
+ mlt
opencolorio
openexr
openjpeg
perl
+ python-pyqt
+ python-pyqt5-sip
poppler-qt5
qtbase-5
qtdeclarative-5
@@ -767,7 +783,10 @@ (define-public krita
qtsvg-5
qtx11extras
quazip-0
- zlib))
+ sdl2
+ xsimd
+ zlib
+ zug))
(home-page "https://krita.org")
(synopsis "Digital painting application")
(description
--
2.41.0
M
M
Mehmet Tekman wrote on 24 Nov 2023 00:17
(address . 67349@debbugs.gnu.org)
87ttpcawkg.fsf@gmail.com
Disregard the last patch, the one below is the complete patch which
successfully builds the package.

It depends only on fftw-cmake (#67343) and kfkdcraw (#67342) to be
merged first.
M
M
Mehmet Tekman wrote on 28 Nov 2023 00:05
(address . 67349@debbugs.gnu.org)
87leaiyezd.fsf@gmail.com
This is a hotfix that should be applied ontop of the previous patch.
For some reason I thought that kfkdcraw did not exist already in Guix,
but upon closer inspection I see that it does indeed exist under the
name "libkdcraw".
From 1fb0c3d794589895140da05d246ac78b738be8a5 Mon Sep 17 00:00:00 2001
From: mtekman <mtekman89@gmail.com>
Date: Mon, 27 Nov 2023 23:49:35 +0100
Subject: [PATCH] gnu: krita: hotfix

* gnu/packages/kde.scm (krita): hotfix

no longer dependent on kfkdcraw but uses libkdcraw which is the
same.

Change-Id: I2a4b8b1d5ed70f5eb8a8f906413946015789ed33
---
gnu/packages/kde.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 9dfb360a72..ab25dffc1a 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021, 2022, 2023 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2023 Mehmet Tekman <mtekman89@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -745,7 +746,7 @@ (define-public krita
kconfig
kcoreaddons
kcrash
- kfkdcraw
+ libkdcraw
kguiaddons
ki18n
kiconthemes
@@ -757,9 +758,10 @@ (define-public krita
kxmlgui
lager
lcms
+ libheif
libjpeg-turbo
libjxl
- libheif
+ libkdcraw
libmypaint
libpng
libraw
--
2.41.0
M
M
Mehmet Tekman wrote on 28 Nov 2023 14:25
(address . 67349@debbugs.gnu.org)
874jh6xb60.fsf@gmail.com
Ignore previous patches.

Full patch with hotfix included, and sorted inputs.
Dependent on an updated libkdcraw (#67509) and fftw-cmake (#67343)
S
S
Sharlatan Hellseher wrote on 29 Mar 17:48 +0100
(address . 67349-done@debbugs.gnu.org)
87o7axc7cm.fsf@gmail.com
Pushed as 37d31495c1c3c38d1b74e0c5b3ba279c1d99c7d5 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmYG8MkACgkQdtcnv/Ys
0rXRMQ//bT3LpMscXh02/ZcpoHvIQpsnl6+tBHLjtb+flsd6Lhw8SLOXSZuF5o6q
r0SP6VkKWLx/ZpD+yLLU68e+JHWslNhnBrKHmDt9t0jZJrf0pID1P+T6wbiAgP6V
6NLp3oGeILScpyWX1YQnDbsIcWrYgy/jEQboVAPCwzOI9cgGQL0kgMQiYvO3+EZH
RGCxHr7YiDFvHrgti6j623Ent6lDRtjlkvAZZP+MfqxFEsriRHzzqmX3B5ov95C8
X1pGfH6+tuWJvUoXodtr9KYHVgIkDsMV+q1QhapIE3UGTxHUqcNCpXpRQRgqvVqN
M1gOITKUkeKQdpDv6jIrzGAwZKjLlRzwCfAWDtVGsdNa6bHSz8wT1yvHkfM+CNml
raLgTs+s28X68/j5hKbQFcCRLhxck+7BHF9OYyhE9tmXbgjDOSzX5Ll5B5QaKelA
J1oBIqDeTMuRhsvKIbSQ9vJkrIFPtLBXX/vDBwvFA2+IoqFv5VEUCwoZdLvSV1s1
DcUx3pFRmA9ZTUWqMhHYLFulNoeghaFhmxBhVbnfVk+nKXXUIC3V4M2DOu3YA/8D
WRd1JP9Vx5cYYPaUN3HJkht7jyudpZzhEsXzH7uL7OWPC9jSNcQaJp/aHpJKLhik
9omxbZLZlDVlrwDlSjZPb5yBXWRXk+3r7nTBhko0xbJdlMjzzCc=
=qVmS
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67349@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67349
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch