[PATCH gnome-team 1/2] gnu: gnome-music: Update to 44.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
371f906794247c9b15862880788aff6e91cc93aa.1700595559.git.vivien@planete-kraus.eu
When wrapping gnome-music, GST_PLUGIN_SYSTEM_PATH should not override the
plugins installed by the user.

* gnu/packages/gnome.scm (gnome-music): Update to 44.0.
[#:phases]<wrap-gnome-music>: Update path wrapping.
[inputs]: Add bash-minimal. Replace libsoup-minimal-2 with libsoup.

Change-Id: I9b8ac5ee65618baafc760be8f7ab3132f4d53345
---
gnu/packages/gnome.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ab485cffb1..baeda23492 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -887,7 +887,7 @@ (define-public gnome-photos
(define-public gnome-music
(package
(name "gnome-music")
- (version "42.1")
+ (version "44.0")
(source
(origin
(method url-fetch)
@@ -897,7 +897,7 @@ (define-public gnome-music
name "-" version ".tar.xz"))
(sha256
(base32
- "0w42xnp6xy3sfakb4s0wq7xfg7p507whz5gzss5b2mkbm2k7yx67"))))
+ "0l8xiw1nv8agskrpgiyr7kinna3gms1hv5d64hh4fqifaz4smlcv"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -920,7 +920,7 @@ (define-public gnome-music
(wrap-program (string-append out "/bin/gnome-music")
`("GI_TYPELIB_PATH" =
(,(getenv "GI_TYPELIB_PATH")))
- `("GST_PLUGIN_SYSTEM_PATH" =
+ `("GST_PLUGIN_SYSTEM_PATH" suffix
(,(getenv "GST_PLUGIN_SYSTEM_PATH")))
`("GRL_PLUGIN_PATH" =
(,(getenv "GRL_PLUGIN_PATH")))
@@ -934,7 +934,8 @@ (define-public gnome-music
itstool
pkg-config))
(inputs
- (list gnome-online-accounts
+ (list bash-minimal
+ gnome-online-accounts
grilo
grilo-plugins
gst-plugins-base
@@ -946,7 +947,7 @@ (define-public gnome-music
libadwaita
libdazzle
libmediaart
- libsoup-minimal-2
+ libsoup
python-pycairo
python-pygobject
python

base-commit: 1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team 2/2] gnu: gnome-music: Update style.
(address . 67340@debbugs.gnu.org)
655827cd60ca45052355f6f1f7d75af0f1c3f9d0.1700595559.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (gnome-music) [arguments]: Convert to list of G-Expressions.

Change-Id: I5cb724bc66dcfee14958753c0a129add55820db6
---
gnu/packages/gnome.scm | 53 +++++++++++++++++++++---------------------
1 file changed, 27 insertions(+), 26 deletions(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index baeda23492..3082500b4e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -900,32 +900,33 @@ (define-public gnome-music
"0l8xiw1nv8agskrpgiyr7kinna3gms1hv5d64hh4fqifaz4smlcv"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
- ;; Don't create 'icon-theme.cache'.
- (lambda _
- (substitute* "meson.build"
- (("gtk_update_icon_cache: true")
- "gtk_update_icon_cache: false"))))
- (add-after 'install 'wrap-gnome-music
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let*
- ((out (assoc-ref outputs "out"))
- (pylib (string-append out "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages")))
- (wrap-program (string-append out "/bin/gnome-music")
- `("GI_TYPELIB_PATH" =
- (,(getenv "GI_TYPELIB_PATH")))
- `("GST_PLUGIN_SYSTEM_PATH" suffix
- (,(getenv "GST_PLUGIN_SYSTEM_PATH")))
- `("GRL_PLUGIN_PATH" =
- (,(getenv "GRL_PLUGIN_PATH")))
- `("GUIX_PYTHONPATH" =
- (,(getenv "GUIX_PYTHONPATH") ,pylib)))))))))
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
+ (add-after 'install 'wrap-gnome-music
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (pylib (string-append out "/lib/python"
+ #$(version-major+minor
+ (package-version
+ (this-package-input "python")))
+ "/site-packages")))
+ (wrap-program (string-append out "/bin/gnome-music")
+ `("GI_TYPELIB_PATH" =
+ (,(getenv "GI_TYPELIB_PATH")))
+ `("GST_PLUGIN_SYSTEM_PATH" suffix
+ (,(getenv "GST_PLUGIN_SYSTEM_PATH")))
+ `("GRL_PLUGIN_PATH" =
+ (,(getenv "GRL_PLUGIN_PATH")))
+ `("GUIX_PYTHONPATH" =
+ (,(getenv "GUIX_PYTHONPATH") ,pylib)))))))))
(native-inputs
(list desktop-file-utils
gettext-minimal
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
885d455c3c9c99209116275350a6d0e3eba7bf3e.camel@gmail.com
Am Dienstag, dem 21.11.2023 um 18:56 +0100 schrieb Vivien Kraus:
Toggle quote (5 lines)
> * gnu/packages/gnome.scm (gnome-music) [arguments]: Convert to list
> of G-Expressions.
>
> Change-Id: I5cb724bc66dcfee14958753c0a129add55820db6
> ---
Pushed.

Thanks
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67340@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67340
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help