Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
When wrapping gnome-music, GST_PLUGIN_SYSTEM_PATH should not override the
plugins installed by the user.
* gnu/packages/gnome.scm (gnome-music): Update to 44.0.
[#:phases]<wrap-gnome-music>: Update path wrapping.
[inputs]: Add bash-minimal. Replace libsoup-minimal-2 with libsoup.
Change-Id: I9b8ac5ee65618baafc760be8f7ab3132f4d53345
---
gnu/packages/gnome.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)
Toggle diff (54 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ab485cffb1..baeda23492 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -887,7 +887,7 @@ (define-public gnome-photos
(define-public gnome-music
(package
(name "gnome-music")
- (version "42.1")
+ (version "44.0")
(source
(origin
(method url-fetch)
@@ -897,7 +897,7 @@ (define-public gnome-music
name "-" version ".tar.xz"))
(sha256
(base32
- "0w42xnp6xy3sfakb4s0wq7xfg7p507whz5gzss5b2mkbm2k7yx67"))))
+ "0l8xiw1nv8agskrpgiyr7kinna3gms1hv5d64hh4fqifaz4smlcv"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -920,7 +920,7 @@ (define-public gnome-music
(wrap-program (string-append out "/bin/gnome-music")
`("GI_TYPELIB_PATH" =
(,(getenv "GI_TYPELIB_PATH")))
- `("GST_PLUGIN_SYSTEM_PATH" =
+ `("GST_PLUGIN_SYSTEM_PATH" suffix
(,(getenv "GST_PLUGIN_SYSTEM_PATH")))
`("GRL_PLUGIN_PATH" =
(,(getenv "GRL_PLUGIN_PATH")))
@@ -934,7 +934,8 @@ (define-public gnome-music
itstool
pkg-config))
(inputs
- (list gnome-online-accounts
+ (list bash-minimal
+ gnome-online-accounts
grilo
grilo-plugins
gst-plugins-base
@@ -946,7 +947,7 @@ (define-public gnome-music
libadwaita
libdazzle
libmediaart
- libsoup-minimal-2
+ libsoup
python-pycairo
python-pygobject
python
base-commit: 1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523
--
2.41.0