[PATCH gnome-team] [WIP] gnu: Add gnome-logs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal
V
V
Vivien Kraus wrote on 21 Nov 2023 18:54
(address . guix-patches@gnu.org)
cb004aa4374347f7a2391fa03c1568688a093c30.1700595030.git.vivien@planete-kraus.eu
gnome-logs does not appear to support elogind as a journal provider, because
it crashes on startup.

* gnu/packages/gnome.scm (gnome-logs): New variable.

Change-Id: I3d4fff870b5b0d10bcd229c164a5bb19564880d7
---
gnu/packages/gnome.scm | 45 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ab485cffb1..61edd70d93 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13218,6 +13218,51 @@ (define-public komikku
developed with the aim of being used with the Librem 5 phone.")
(license license:gpl3+)))
+(define-public gnome-logs
+ ;; FIXME: crashes at startup because elogind does not implement the
+ ;; requested API.
+ (package
+ (name "gnome-logs")
+ (version "43.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0q88q8z7paq2r5s7pkxbclsw5mgpi9xslj2hha3q8z62bsbkpa9k"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-icon-cache
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache")
+ "true"))))
+ (add-after 'unpack 'use-elogind
+ (lambda _
+ (substitute* "src/gl-journal.h"
+ (("systemd/sd-([^.]*)\\.h" all header)
+ (string-append "elogind/sd-" header ".h")))
+ (substitute* "meson.build"
+ (("'libsystemd'")
+ "'libelogind'")))))))
+ (inputs
+ (list elogind glib gtk libadwaita))
+ (native-inputs
+ (list gettext-minimal
+ `(,glib "bin")
+ itstool
+ pkg-config))
+ (home-page "https://apps.gnome.org/Logs")
+ (synopsis "View detailed event logs for the system")
+ (description "This application shows events from the system journal.")
+ (license license:gpl3+)))
+
(define-public libgda
(package
(name "libgda")

base-commit: 1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523
--
2.41.0
L
L
Liliana Marie Prikler wrote on 21 Nov 2023 21:28
89c7a37a3007b45144554f4acb0472f98f0f2587.camel@gmail.com
Am Dienstag, dem 21.11.2023 um 18:54 +0100 schrieb Vivien Kraus:
Toggle quote (4 lines)
> gnome-logs does not appear to support elogind as a journal provider,
> because it crashes on startup.
>
> * gnu/packages/gnome.scm (gnome-logs): New variable.
Yeah, this is pretty much useless in Guix. gnome-logs requires
systemd-journald, whereas we use syslogd. I think it's safe to ship
our GNOME 44 without it.

Cheers
V
V
Vivien Kraus wrote on 29 Jan 19:15 +0100
[PATCH gnome-team] [WIP] gnu: Add gnome-logs.
(address . 67338-done@debbugs.gnu.org)
0f9e3b79cb60bd867ccadd0f4bfe5a203ffe1e86.camel@planete-kraus.eu
I’m retracting this, it is obviously out of scope.

Best regards,

Vivien
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67338@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67338
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch