Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/gnome.scm (gnome-contacts): Update to 44.0.
[arguments]: Convert to list of G-Expressions.
[#:configure-flags]: Add -Ddocs=false.
[inputs]: Replace evolution-data-server-3.44 with evolution-data-server.
Replace gnome-online-accounts-3.44 with gnome-online-accounts. Remove
libhandy. Add qrencode.
[propagated-inputs]: Replace folks-with-libsoup2 with folks.
Change-Id: Ib2e1f4a8db6877a203a963cb0d36d194bf62f60e
---
Hello Guix,
This updates gnome-contacts to get rid of libsoup2. I’m not sure why the
propagated-inputs are required. I understand why you would want them though.
Best regards,
Vivien
gnu/packages/gnome.scm | 32 ++++++++++++++++++--------------
1 file changed, 18 insertions(+), 14 deletions(-)
Toggle diff (72 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ab485cffb1..4c7bf53ba8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2138,7 +2138,7 @@ (define-public gnome-common
(define-public gnome-contacts
(package
(name "gnome-contacts")
- (version "42.0")
+ (version "44.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gnome-contacts/"
@@ -2146,17 +2146,21 @@ (define-public gnome-contacts
name "-" version ".tar.xz"))
(sha256
(base32
- "05jj5kiab13crm18r166w7h31jpny7f3px98q7d2ix93vj7w60l8"))))
+ "1vbvvv8954j4znczqa41j892rvj36k21ah5f5lwgcsphq4xidlbx"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
- (lambda _
- (substitute* "meson.build"
- (("gtk_update_icon_cache: true")
- "gtk_update_icon_cache: false")))))))
+ (list
+ #:glib-or-gtk? #t
+ ;; FIXME: Cannot build the Valadoc, because both gtk+ and gtk are in the
+ ;; same profile (evolution-data-server propagates both).
+ #:configure-flags #~'("-Ddocs=false")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false")))))))
(native-inputs
(list desktop-file-utils
docbook-xml
@@ -2168,19 +2172,19 @@ (define-public gnome-contacts
libxslt
pkg-config))
(inputs
- (list evolution-data-server-3.44
+ (list evolution-data-server
gnome-desktop
- gnome-online-accounts-3.44
+ gnome-online-accounts
gst-plugins-base
gtk
libadwaita
libgee
- libhandy
libportal
+ qrencode
telepathy-glib
vala))
(propagated-inputs
- (list folks-with-libsoup2
+ (list folks
telepathy-mission-control))
(synopsis "GNOME's integrated address book")
(description
base-commit: 1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523
--
2.41.0