* gnu/packages/gnome.scm (gnome-connections): New variable.
Change-Id: I4c026ab3aae07a73fcbc9b4b0612538455fe126a
* gnu/packages/patches/gnome-connections-disable-nonfree-desktop-page.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Register it here.
Change-Id: If88a6e4c4f640a1175a8c98d13986f7520fe77b7
---
gnu/local.mk | 1 +
gnu/packages/gnome.scm | 51 ++++++++++++++++++
...ections-disable-nonfree-desktop-page.patch | 52 +++++++++++++++++++
3 files changed, 104 insertions(+)
create mode 100644 gnu/packages/patches/gnome-connections-disable-nonfree-desktop-page.patch
Toggle diff (123 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 5cb9874d9f..6ae7e9b577 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1332,6 +1332,7 @@ dist_patch_DATA = \
%D%/packages/patches/gnome-2048-fix-positional-argument.patch \
%D%/packages/patches/gnome-control-center-firmware-security.patch \
%D%/packages/patches/gnome-control-center-libexecdir.patch \
+ %D%/packages/patches/gnome-connections-disable-nonfree-desktop-page.patch \
%D%/packages/patches/gnome-dictionary-meson-i18n.patch \
%D%/packages/patches/gnome-online-miners-tracker-3.patch \
%D%/packages/patches/gnome-settings-daemon-gc.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d354327497..f2ed075172 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13623,3 +13623,54 @@ (define-public calls
backends, such as ModemManager for phones and @acronym{SIP, Session Initiation
Protocol} for @acronym{VoIP, Voice over @acronym{IP, Internet Protocol}}.")
(license license:gpl3+)))
+
+(define-public gnome-connections
+ (package
+ (name "gnome-connections")
+ (version "44.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0sv238bq0dhi68ksr3bcl4q44i3ishk5i10c2325qz879f92sshk"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "subprojects")))
+ (patches
+ (search-patches "gnome-connections-disable-nonfree-desktop-page.patch"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-meson
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false")
+ (("update_desktop_database: true")
+ "update_desktop_database: false"))))
+ (add-after 'unpack 'say-gnu/linux
+ (lambda _
+ (substitute* "src/ui/assistant.ui"
+ (("\\(standard for connecting to Linux\\)")
+ "(standard for connecting to GNU/Linux)")))))))
+ (inputs
+ (list gtk+ gtk-frdp gtk-vnc libhandy libsecret libxml2))
+ (native-inputs
+ (list gettext-minimal
+ `(,glib "bin")
+ itstool
+ pkg-config
+ vala))
+ (home-page "https://apps.gnome.org/Connections")
+ (synopsis "View and use other desktops")
+ (description "Connections allows the user to connect to different
+real or virtual machines, using @acronym{VNC,Virtual Network Computing}
+or @acronym{RDP,Remote Desktop Protocol}.")
+ (license license:gpl3+)))
diff --git a/gnu/packages/patches/gnome-connections-disable-nonfree-desktop-page.patch b/gnu/packages/patches/gnome-connections-disable-nonfree-desktop-page.patch
new file mode 100644
index 0000000000..10ff421864
--- /dev/null
+++ b/gnu/packages/patches/gnome-connections-disable-nonfree-desktop-page.patch
@@ -0,0 +1,52 @@
+From d6841278e27ee560c080867ec128add9e1faab8c Mon Sep 17 00:00:00 2001
+Message-ID: <d6841278e27ee560c080867ec128add9e1faab8c.1701024334.git.vivien@planete-kraus.eu>
+From: Vivien Kraus <vivien@planete-kraus.eu>
+Date: Sun, 26 Nov 2023 19:23:43 +0100
+Subject: [PATCH] =?UTF-8?q?Onboarding:=20Remove=20the=20=E2=80=9CDifferent?=
+ =?UTF-8?q?=20operating=20systems=E2=80=9D=20page.?=
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This page may be used to push users to use non-free software on a
+remote computer.
+---
+Discussion: https://gitlab.gnome.org/GNOME/connections/-/issues/144
+
+ src/ui/onboarding-dialog.ui | 8 --------
+ src/ui/onboarding/multiplatform.svg | 1 -
+ 2 files changed, 9 deletions(-)
+ delete mode 100644 src/ui/onboarding/multiplatform.svg
+
+diff --git a/src/ui/onboarding-dialog.ui b/src/ui/onboarding-dialog.ui
+index 3ab8a1d..80d6a64 100644
+--- a/src/ui/onboarding-dialog.ui
++++ b/src/ui/onboarding-dialog.ui
+@@ -53,14 +53,6 @@
+ </object>
+ </child>
+
+- <child>
+- <object class="ConnectionsOnboardingDialogPage">
+- <property name="title" translatable="yes">Connect to different operating systems</property>
+- <property name="description" translatable="yes">Access Linux, Mac, and Windows desktops using Connections.</property>
+- <property name="image">/org/gnome/Connections/ui/onboarding/multiplatform.svg</property>
+- </object>
+- </child>
+-
+ <child>
+ <object class="ConnectionsOnboardingDialogPage">
+ <property name="title" translatable="yes">Enable remote desktop before connecting</property>
+diff --git a/src/ui/onboarding/multiplatform.svg b/src/ui/onboarding/multiplatform.svg
+deleted file mode 100644
+index 5b3e6a1..0000000
+--- a/src/ui/onboarding/multiplatform.svg
++++ /dev/null
+@@ -1 +0,0 @@
+-<svg height="600" width="800" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns="http://www.w3.org/2000/svg"><defs><linearGradient id="c"><stop style="stop-color:#8ff0a4;stop-opacity:1" offset="0"/><stop style="stop-color:#99c1f1;stop-opacity:1" offset="1"/></linearGradient><linearGradient id="b"><stop style="stop-color:#c5dbf7;stop-opacity:1" offset="0"/><stop style="stop-color:#1b6fd4;stop-opacity:1" offset=".08"/><stop style="stop-color:#175fb6;stop-opacity:1" offset=".798"/><stop style="stop-color:#438de7;stop-opacity:1" offset=".932"/><stop style="stop-color:#175caf;stop-opacity:1" offset="1"/></linearGradient><linearGradient xlink:href="#a" id="d" x1="-46.029" y1="119.025" x2="139.157" y2="119.025" gradientUnits="userSpaceOnUse"/><linearGradient id="a"><stop style="stop-color:#4a86cf;stop-opacity:1" offset="0"/><stop style="stop-color:#33d17a;stop-opacity:1" offset=".144"/><stop style="stop-color:#f6d32d;stop-opacity:1" offset=".322"/><stop style="stop-color:#ff7800;stop-opacity:1" offset=".499"/><stop style="stop-color:#e01b24;stop-opacity:1" offset=".681"/><stop style="stop-color:#9141ac;stop-opacity:1" offset=".853"/><stop style="stop-color:#613583;stop-opacity:1" offset="1"/></linearGradient><linearGradient xlink:href="#b" id="f" x1="526.469" y1="262.426" x2="731.547" y2="262.426" gradientUnits="userSpaceOnUse"/><linearGradient xlink:href="#b" id="g" gradientUnits="userSpaceOnUse" x1="73.23" y1="262.426" x2="263.805" y2="262.426"/><linearGradient xlink:href="#c" id="e" x1="403.101" y1="232.449" x2="341.082" y2="463.905" gradientUnits="userSpaceOnUse"/><clipPath clipPathUnits="userSpaceOnUse" id="h"><rect style="fill:#e01b24;stroke-width:6;stop-color:#000" width="192.919" height="192.919" x="70.218" y="71.496" rx="23.687" ry="23.687"/></clipPath></defs><g transform="translate(-1536.865 -208.68) scale(3.8216)" style="display:inline"><rect style="opacity:1;vector-effect:none;fill:#000;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="95.25" height="58.208" x="47.625" y="84.667" rx="2.884" ry="2.884"/><rect ry="2.884" rx="2.884" y="145.256" x="47.625" height="58.208" width="95.25" style="opacity:1;vector-effect:none;fill:#000;fill-opacity:.102362;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#deddda;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="95.25" height="58.208" x="47.625" y="144.198" rx="2.884" ry="2.884"/><rect ry="2.884" rx="2.884" y="142.875" x="47.625" height="58.208" width="95.25" style="opacity:1;vector-effect:none;fill:#f6f5f4;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#c0bfbc;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="84.667" height="29.104" x="52.917" y="148.167" rx="1.958" ry="1.958"/><rect ry="1.958" rx="1.958" y="148.696" x="52.917" height="29.104" width="84.667" style="opacity:1;vector-effect:none;fill:#deddda;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect ry=".826" rx=".826" y="137.583" x="63.5" height="7.408" width="63.5" style="opacity:1;vector-effect:none;fill:#000;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect ry="2.884" rx="2.884" y="179.917" x="82.021" height="15.875" width="26.458" style="opacity:1;vector-effect:none;fill:#deddda;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="46.302" height="5.292" x="74.083" y="170.656" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="170.656" x="121.708" height="5.292" width="6.615" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="6.615" height="5.292" x="129.646" y="170.656" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="164.042" x="125.677" height="5.292" width="5.292" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="6.615" height="5.292" x="117.74" y="164.042" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="164.042" x="109.802" height="5.292" width="6.615" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="6.615" height="5.292" x="101.865" y="164.042" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="164.042" x="93.927" height="5.292" width="6.615" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="6.615" height="5.292" x="85.99" y="164.042" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="164.042" x="78.052" height="5.292" width="6.615" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="6.615" height="5.292" x="70.115" y="164.042" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="164.042" x="62.177" height="5.292" width="6.615" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="6.615" height="5.292" x="121.708" y="157.427" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="157.427" x="113.771" height="5.292" width="6.615" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="6.615" height="5.292" x="105.833" y="157.427" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="157.427" x="97.896" height="5.292" width="6.615" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="6.615" height="5.292" x="89.958" y="157.427" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="157.427" x="82.021" height="5.292" width="6.615" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="6.615" height="5.292" x="74.083" y="157.427" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="157.427" x="66.146" height="5.292" width="6.615" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="10.583" height="5.292" x="54.24" y="157.427" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="150.813" x="125.677" height="5.292" width="10.583" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal"/><rect style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;marker-start:none;marker-mid:none;marker-end:none;paint-order:normal" width="6.615" height="5.292" x="117.74" y="150.813" rx="1.013" ry="1.013"/><rect ry="1.013" rx="1.013" y="150.813" x="109.802" height="5.292" width="6.615" style="opacity:1;vector-effect:none;fill:#241f31;fill-opacity:1;stroke:none;stroke-width:1.5875;stroke-linecap:round;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;