Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/gnome.scm (gnome-characters): Update to 44.0.
[#:phases]<disable-gtk-update-icon-cache>: Update to build system changes.
[inputs]: Remove libhandy.
[home-page]: Update.
Change-Id: I416718a7b729b848cbefdb4cdd8677c3ae2fe88b
---
gnu/packages/gnome.scm | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)
Toggle diff (56 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ab485cffb1..ea4ee9a650 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2068,7 +2068,7 @@ (define-public libgxps
(define-public gnome-characters
(package
(name "gnome-characters")
- (version "42.0")
+ (version "44.0")
(source
(origin
(method url-fetch)
@@ -2077,7 +2077,7 @@ (define-public gnome-characters
"/gnome-characters-" version ".tar.xz"))
(sha256
(base32
- "1y40g7k7yyzikbbxhf69q4c0221lga1cli1p617v99pq2swgz82x"))))
+ "02zm3w43lvsnld3681z9w1428pwdza2gv4k05vwsx461ih15rc85"))))
(build-system meson-build-system)
(arguments
(list
@@ -2085,7 +2085,11 @@ (define-public gnome-characters
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'disable-gtk-update-icon-cache
(lambda _
- (setenv "DESTDIR" "/")))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false")
+ (("update_desktop_database: true")
+ "update_desktop_database: false"))))
(add-after 'install 'wrap
(lambda* (#:key outputs #:allow-other-keys)
;; GNOME Characters needs Typelib files from GTK and
@@ -2100,13 +2104,13 @@ (define-public gnome-characters
pkg-config
python-minimal))
(inputs
- (list gjs
+ (list bash-minimal ;for wrap-program
+ gjs
gnome-desktop
gtk
libadwaita
- libhandy
libunistring))
- (home-page "https://wiki.gnome.org/Apps/CharacterMap")
+ (home-page "https://wiki.gnome.org/Apps/Characters")
(synopsis "Find and insert unusual characters")
(description "Characters is a simple utility application to find
and insert unusual characters. It allows you to quickly find the
base-commit: 1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523
--
2.41.0