[PATCH] gnu: qutebrowser: Update to 3.0.2.

  • Done
  • quality assurance status badge
Details
5 participants
  • chris
  • Clément Lassieur
  • Herman Rimm
  • Sergey Trofimov
  • Wilko Meyer
Owner
unassigned
Submitted by
Herman Rimm
Severity
normal
H
H
Herman Rimm wrote on 19 Nov 2023 21:35
(address . guix-patches@gnu.org)(name . Herman Rimm)(address . herman@rimm.ee)
3514f2342b3788d19c49aa6e9e2971f3d31c892c.1700426152.git.herman@rimm.ee
* gnu/packages/web-browsers (qutebrowser): Update to 3.0.2.
[source]: Bump version and recompute hash.
[inputs]: Use PyQt6, placed before PyQtWebengine.
[arguments]: Replace qt5 path with qt6 path.
[description]: Replace PyQt5 with PyQt6.
---
gnu/packages/web-browsers.scm | 21 ++++++++++-----------
1 file changed, 10 insertions(+), 11 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index d38882046d..9257d541a8 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2021 Alexander Krotov <krotov@iitp.ru>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Christopher Howard <christopher@librehacker.com>
+;;; Copyright © 2023 Herman Rimm <herman@rimm.ee>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -459,7 +460,7 @@ (define-public kristall
(define-public qutebrowser
(package
(name "qutebrowser")
- (version "2.5.4")
+ (version "3.0.2")
(source
(origin
(method url-fetch)
@@ -467,7 +468,7 @@ (define-public qutebrowser
"qutebrowser/releases/download/v" version "/"
"qutebrowser-" version ".tar.gz"))
(sha256
- (base32 "1c8skkc5vjbvbslz65hzrj9d05v4zbcjbli61ikjmr174lhb4q54"))))
+ (base32 "0ldwslgakpcv3v47hli8lm68zndjsb7bj8rpp2pijd8j9bg96655"))))
(build-system python-build-system)
(native-inputs
(list python-attrs)) ; for tests
@@ -480,15 +481,13 @@ (define-public qutebrowser
python-pynacl
python-pypeg2
python-pyyaml
- ;; FIXME: python-pyqtwebengine needs to come before python-pyqt so
- ;; that it's __init__.py is used first.
- python-pyqtwebengine
- python-pyqt
- ;; While qtwebengine-5 is provided by python-pyqtwebengine, it's
+ python-pyqt-6
+ python-pyqtwebengine-6
+ ;; While qtwebengine is provided by python-pyqtwebengine-6, it's
;; included here so we can wrap QTWEBENGINEPROCESS_PATH.
- qtwebengine-5))
+ qtwebengine))
(arguments
- `(;; FIXME: With the existance of qtwebengine-5, tests can now run. But
+ `(;; FIXME: With the existence of qtwebengine, tests can now run. But
;; they are still disabled because test phase hangs. It's not readily
;; apparent as to why.
#:tests? #f
@@ -540,11 +539,11 @@ (define-public qutebrowser
(wrap-program (search-input-file outputs "bin/qutebrowser")
`("QTWEBENGINEPROCESS_PATH" =
(,(search-input-file
- inputs "/lib/qt5/libexec/QtWebEngineProcess")))))))))
+ inputs "/lib/qt6/libexec/QtWebEngineProcess")))))))))
(home-page "https://qutebrowser.org/")
(synopsis "Minimal, keyboard-focused, vim-like web browser")
(description "qutebrowser is a keyboard-focused browser with a minimal
-GUI. It is based on PyQt5 and QtWebEngine.")
+GUI. It is based on PyQt6 and QtWebEngine.")
(license license:gpl3+)))
(define-public vimb

base-commit: 761810d32a0550912b5bb36a0c9f60141bcb7d20
prerequisite-patch-id: 8ae6d4a62bd979a3fe4758d95ed7fc0749063e9b
prerequisite-patch-id: 83df61ed11d3c78120bb78ef098bc182b7f2b300
prerequisite-patch-id: 889819768a466a7f2ccd7ca2ab21f0972563b8b0
--
2.41.0
H
H
Herman Rimm wrote on 20 Nov 2023 09:05
(address . 67289@debbugs.gnu.org)
d4tn7wbclfztrlx4jh2wfipzvad2eqggudjkdcpibdxjlb3v26@a5jzkdtolfpp
I wanted to say that this patch depends on #57431, where the PyQt6 packages are added.

Cheers,
Herman Rimm
S
S
Sergey Trofimov wrote on 20 Nov 2023 11:40
(name . Herman Rimm)(address . herman@rimm.ee)(address . 67289@debbugs.gnu.org)
87cyw4iu72.fsf@sarg.org.ru
Herman Rimm <herman@rimm.ee> writes:

Toggle quote (5 lines)
> I wanted to say that this patch depends on #57431, where the PyQt6 packages are added.
>
> Cheers,
> Herman Rimm

I can confirm, that this change + 3 patches from pyqt6 ticket build and
work fine on my machine (x86_64). Thanks for finally making it happen.
C
[PATCH] gnu: qutebrowser: Update to 3.0.2.
(address . 67289@debbugs.gnu.org)(address . chris@bumblehead.com)
ZVwnUiAr7fr0BmPk@guix-xps
I want this! thank you Herman
H
H
Herman Rimm wrote on 25 Dec 2023 18:22
[PATCH v2] gnu: qutebrowser: Update to 3.1.0.
(address . 67289@debbugs.gnu.org)(name . Herman Rimm)(address . herman@rimm.ee)
eb07356260b8e4c80ef253d7afbe5db949cd6c7d.1703524955.git.herman@rimm.ee
* gnu/packages/web-browsers (qutebrowser): Update to 3.1.0.
[source]: Bump version and recompute hash.
[inputs]: Use PyQt6, placed before PyQtWebengine.
[arguments]: Replace qt5 path with qt6 path and wrap program with
QTWEBENGINE_RESOURCES_PATH.
[description]: Replace PyQt5 with PyQt6.
---
Hello,

A qutebrowser 3.0.2 and 3.1.0 bug: Start a video (on invidio.us), switch
to another workspace in Sway wm, the video stutters for a few seconds
and recovers. A workaround is to use mpv or the like to play videos. May
be related to #63863 of guix-patches, which implements a pipewire home
service. Let me know if you experience it using ALSA/Pulseaudio service.

Cheers,
Herman Rimm
gnu/packages/web-browsers.scm | 24 +++++++++++++-----------
1 file changed, 13 insertions(+), 11 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 141917ad42..5477584805 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2021 Alexander Krotov <krotov@iitp.ru>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Christopher Howard <christopher@librehacker.com>
+;;; Copyright © 2023 Herman Rimm <herman@rimm.ee>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -460,7 +461,7 @@ (define-public kristall
(define-public qutebrowser
(package
(name "qutebrowser")
- (version "2.5.4")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
@@ -468,7 +469,7 @@ (define-public qutebrowser
"qutebrowser/releases/download/v" version "/"
"qutebrowser-" version ".tar.gz"))
(sha256
- (base32 "1c8skkc5vjbvbslz65hzrj9d05v4zbcjbli61ikjmr174lhb4q54"))))
+ (base32 "0prf9c7nx4aizfczjb0fpsn3alz210i6wc7s2jwb1mh8r8fcq3ah"))))
(build-system python-build-system)
(native-inputs
(list python-attrs)) ; for tests
@@ -481,15 +482,13 @@ (define-public qutebrowser
python-pynacl
python-pypeg2
python-pyyaml
- ;; FIXME: python-pyqtwebengine needs to come before python-pyqt so
- ;; that it's __init__.py is used first.
- python-pyqtwebengine
- python-pyqt
- ;; While qtwebengine-5 is provided by python-pyqtwebengine, it's
+ python-pyqt-6
+ python-pyqtwebengine-6
+ ;; While qtwebengine is provided by python-pyqtwebengine-6, it's
;; included here so we can wrap QTWEBENGINEPROCESS_PATH.
- qtwebengine-5))
+ qtwebengine))
(arguments
- `(;; FIXME: With the existance of qtwebengine-5, tests can now run. But
+ `(;; FIXME: With the existence of qtwebengine, tests can now run. But
;; they are still disabled because test phase hangs. It's not readily
;; apparent as to why.
#:tests? #f
@@ -539,13 +538,16 @@ (define-public qutebrowser
(add-after 'wrap 'wrap-qt-process-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/qutebrowser")
+ `("QTWEBENGINE_RESOURCES_PATH" =
+ (,(search-input-directory
+ inputs "/share/qt6/resources")))
`("QTWEBENGINEPROCESS_PATH" =
(,(search-input-file
- inputs "/lib/qt5/libexec/QtWebEngineProcess")))))))))
+ inputs "/lib/qt6/libexec/QtWebEngineProcess")))))))))
(home-page "https://qutebrowser.org/")
(synopsis "Minimal, keyboard-focused, vim-like web browser")
(description "qutebrowser is a keyboard-focused browser with a minimal
-GUI. It is based on PyQt5 and QtWebEngine.")
+GUI. It is based on PyQt6 and QtWebEngine.")
(license license:gpl3+)))
(define-public vimb

base-commit: 0d13d095420861022e68e87ceebd5e037e12a8b3
--
2.41.0
W
W
Wilko Meyer wrote on 14 Jan 13:21 +0100
[PATCH] gnu: qutebrowser: Update to 3.0.2.
(address . 67289@debbugs.gnu.org)
877ckcrsxl.fsf@wmeyer.eu
Hi Guix,

I tested the changes made in v2 of this patch locally and qutebrowser
v3.1.0 builds fine (on x86_64). I kept tests disabled, as they partially
seem to lack dependencies (e.g. I assume python-boltons for urlutils?)
and I didn't want to invest time to resolve those. Anyways, thanks for
the patch/the possibility to be able to use a recent and usable
qutebrowser version again!

--
Kind regards,

Wilko Meyer
w@wmeyer.eu
C
C
Clément Lassieur wrote on 14 Jan 22:21 +0100
Re: [bug#67289] [PATCH v2] gnu: qutebrowser: Update to 3.1.0.
(name . Herman Rimm)(address . herman@rimm.ee)(address . 67289-done@debbugs.gnu.org)
87cyu3ehmb.fsf@lassieur.org
On Mon, Dec 25 2023, Herman Rimm wrote:

Toggle quote (18 lines)
> * gnu/packages/web-browsers (qutebrowser): Update to 3.1.0.
> [source]: Bump version and recompute hash.
> [inputs]: Use PyQt6, placed before PyQtWebengine.
> [arguments]: Replace qt5 path with qt6 path and wrap program with
> QTWEBENGINE_RESOURCES_PATH.
> [description]: Replace PyQt5 with PyQt6.
> ---
> Hello,
>
> A qutebrowser 3.0.2 and 3.1.0 bug: Start a video (on invidio.us), switch
> to another workspace in Sway wm, the video stutters for a few seconds
> and recovers. A workaround is to use mpv or the like to play videos. May
> be related to #63863 of guix-patches, which implements a pipewire home
> service. Let me know if you experience it using ALSA/Pulseaudio service.
>
> Cheers,
> Herman Rimm

Pushed (I just removed the source part in the commit message, which is
implicit).

Thank you!
Closed
C
Qt platform plugin could be initialized
(address . 67289@debbugs.gnu.org)(address . chris@bumblehead.com)
ZaS4X_PXUc2kgtJ7@guix-xps
After running guix reconfigure on my home config qutebrowser 3 was installed and now qutebrowser does not start. Here is the qutebrowser process shell output. Would anyone here recommend a solution?

```
$ qutebrowser
20:40:33 WARNING: Could not find the Qt platform plugin "wayland" in ""
20:40:33 CRITICAL: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: offscreen, vnc, minimal, xcb, vkkhrdisplay, linuxfb, minimalegl, eglfs.

Fatal Python error: Aborted

Current thread 0x00007f36c07e6740 (most recent call first):
File "/gnu/store/xc2z9q7z036ny3fipgqvwc01yn20j2jh-qutebrowser-3.1.0/lib/python3.10/site-packages/qutebrowser/app.py", line 545 in __init__
File "/gnu/store/xc2z9q7z036ny3fipgqvwc01yn20j2jh-qutebrowser-3.1.0/lib/python3.10/site-packages/qutebrowser/app.py", line 80 in run
File "/gnu/store/xc2z9q7z036ny3fipgqvwc01yn20j2jh-qutebrowser-3.1.0/lib/python3.10/site-packages/qutebrowser/qutebrowser.py", line 231 in main
File "/gnu/store/xc2z9q7z036ny3fipgqvwc01yn20j2jh-qutebrowser-3.1.0/bin/.qutebrowser-real", line 33 in <module>

Extension modules: PyQt6.QtCore, PyQt6.QtGui, PyQt6.QtWidgets, markupsafe._speedups, yaml._yaml, PyQt6.QtNetwork, PyQt6.QtQml, PyQt6.QtOpenGL, PyQt6.QtDBus, PyQt6.QtPrintSupport, PyQt6.QtWebChannel, PyQt6.QtWebEngineCore, PyQt6.QtWebEngineWidgets, PyQt6.QtSql (total: 14)
```
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67289@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67289
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch