(address . guix-patches@gnu.org)(name . Herman Rimm)(address . herman@rimm.ee)
* gnu/packages/web-browsers (qutebrowser): Update to 3.0.2.
[source]: Bump version and recompute hash.
[inputs]: Use PyQt6, placed before PyQtWebengine.
[arguments]: Replace qt5 path with qt6 path.
[description]: Replace PyQt5 with PyQt6.
---
gnu/packages/web-browsers.scm | 21 ++++++++++-----------
1 file changed, 10 insertions(+), 11 deletions(-)
Toggle diff (72 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index d38882046d..9257d541a8 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2021 Alexander Krotov <krotov@iitp.ru>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Christopher Howard <christopher@librehacker.com>
+;;; Copyright © 2023 Herman Rimm <herman@rimm.ee>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -459,7 +460,7 @@ (define-public kristall
(define-public qutebrowser
(package
(name "qutebrowser")
- (version "2.5.4")
+ (version "3.0.2")
(source
(origin
(method url-fetch)
@@ -467,7 +468,7 @@ (define-public qutebrowser
"qutebrowser/releases/download/v" version "/"
"qutebrowser-" version ".tar.gz"))
(sha256
- (base32 "1c8skkc5vjbvbslz65hzrj9d05v4zbcjbli61ikjmr174lhb4q54"))))
+ (base32 "0ldwslgakpcv3v47hli8lm68zndjsb7bj8rpp2pijd8j9bg96655"))))
(build-system python-build-system)
(native-inputs
(list python-attrs)) ; for tests
@@ -480,15 +481,13 @@ (define-public qutebrowser
python-pynacl
python-pypeg2
python-pyyaml
- ;; FIXME: python-pyqtwebengine needs to come before python-pyqt so
- ;; that it's __init__.py is used first.
- python-pyqtwebengine
- python-pyqt
- ;; While qtwebengine-5 is provided by python-pyqtwebengine, it's
+ python-pyqt-6
+ python-pyqtwebengine-6
+ ;; While qtwebengine is provided by python-pyqtwebengine-6, it's
;; included here so we can wrap QTWEBENGINEPROCESS_PATH.
- qtwebengine-5))
+ qtwebengine))
(arguments
- `(;; FIXME: With the existance of qtwebengine-5, tests can now run. But
+ `(;; FIXME: With the existence of qtwebengine, tests can now run. But
;; they are still disabled because test phase hangs. It's not readily
;; apparent as to why.
#:tests? #f
@@ -540,11 +539,11 @@ (define-public qutebrowser
(wrap-program (search-input-file outputs "bin/qutebrowser")
`("QTWEBENGINEPROCESS_PATH" =
(,(search-input-file
- inputs "/lib/qt5/libexec/QtWebEngineProcess")))))))))
+ inputs "/lib/qt6/libexec/QtWebEngineProcess")))))))))
(home-page "https://qutebrowser.org/")
(synopsis "Minimal, keyboard-focused, vim-like web browser")
(description "qutebrowser is a keyboard-focused browser with a minimal
-GUI. It is based on PyQt5 and QtWebEngine.")
+GUI. It is based on PyQt6 and QtWebEngine.")
(license license:gpl3+)))
(define-public vimb
base-commit: 761810d32a0550912b5bb36a0c9f60141bcb7d20
prerequisite-patch-id: 8ae6d4a62bd979a3fe4758d95ed7fc0749063e9b
prerequisite-patch-id: 83df61ed11d3c78120bb78ef098bc182b7f2b300
prerequisite-patch-id: 889819768a466a7f2ccd7ca2ab21f0972563b8b0
--
2.41.0