[PATCH gnome-team 0/5] update lilv and its dependency.

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Wicki
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote on 19 Nov 2023 11:03
(address . guix-patches@gnu.org)
cover.1700387828.git.zhengjunjie@iscas.ac.cn
update lilv and its dependency, this update allow cross compile lilv, lv2,sratom.

Zheng Junjie (5):
gnu: zix: Update to 0.4.2.
gnu: sord: Update to 0.16.16.
gnu: sratom: Update to 0.6.16.
gnu: lv2: Update to 1.18.10.
gnu: lilv: Update to 0.24.22.

gnu/packages/audio.scm | 69 +++++++++++++--------------------
gnu/packages/datastructures.scm | 45 +++++++++++----------
gnu/packages/rdf.scm | 18 +++++----
3 files changed, 58 insertions(+), 74 deletions(-)


base-commit: 1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523
--
2.41.0
Z
Z
Zheng Junjie wrote on 19 Nov 2023 11:07
[PATCH gnome-team 2/5] gnu: sord: Update to 0.16.16.
(address . 67273@debbugs.gnu.org)
cacc9f318f7345e15242d2ab2259b87a005fa97c.1700387828.git.zhengjunjie@iscas.ac.cn
* gnu/packages/rdf.scm (sord): Update to 0.16.16.
[propagated-inputs]: Add zix.

Change-Id: I8acc702f56cb08689323e541ddf1371b683df4cf
---
gnu/packages/rdf.scm | 18 ++++++++++--------
1 file changed, 10 insertions(+), 8 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 23f020df28..2a9bbf4aed 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -58,6 +59,7 @@ (define-module (gnu packages rdf)
#:use-module (gnu packages qt)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages datastructures)
#:use-module (gnu packages xml))
(define-public raptor2
@@ -311,14 +313,14 @@ (define-public serd
(define-public sord
(package
(name "sord")
- (version "0.16.14")
+ (version "0.16.16")
(source (origin
- (method url-fetch)
- (uri (string-append "https://download.drobilla.net/sord-"
- version ".tar.xz"))
- (sha256
- (base32
- "06vkqk3dnn15zdnzklahib2pvbfspy2zcrnvhmxnw8fbbxyxj3r2"))))
+ (method url-fetch)
+ (uri (string-append "https://download.drobilla.net/sord-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1l2zjz6gypxbf1z32zyqkljdcn9mz452djc4xq1dlhv1fmnqfzr5"))))
(build-system meson-build-system)
(arguments
(list
@@ -334,7 +336,7 @@ (define-public sord
(native-inputs
(list pkg-config))
(propagated-inputs
- (list serd)) ; required by sord-0.pc
+ (list serd zix)) ; required by sord-0.pc
(home-page "https://drobilla.net/software/sord/")
(synopsis "C library for storing RDF data in memory")
(description
--
2.41.0
Z
Z
Zheng Junjie wrote on 19 Nov 2023 11:07
[PATCH gnome-team 4/5] gnu: lv2: Update to 1.18.10.
(address . 67273@debbugs.gnu.org)
1da5b7c9f86d3cc83dd1e4a7b21e91f814407a50.1700387828.git.zhengjunjie@iscas.ac.cn
* gnu/packages/audio.scm (lv2): Update to 1.18.10.
[source]: Update url.
[build-system]: Change to meson-build-system.
[arguments]: Remove it.

Change-Id: I106b1401385b6ff9f3225cd50b428081dfe445e3
---
gnu/packages/audio.scm | 19 ++++++++-----------
1 file changed, 8 insertions(+), 11 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 9b6bf0e7e5..ef952480f8 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3081,18 +3081,15 @@ (define-public lilv
(define-public lv2
(package
(name "lv2")
- (version "1.18.2")
+ (version "1.18.10")
(source (origin
- (method url-fetch)
- (uri (string-append "https://lv2plug.in/spec/lv2-"
- version ".tar.bz2"))
- (sha256
- (base32
- "0pp0n9x1rg8d4fw853z9cvfifjdi4bl85yjxxddqa1acfjy1z2af"))))
- (build-system waf-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:configure-flags '("--no-plugins")))
+ (method url-fetch)
+ (uri (string-append "https://lv2plug.in/spec/lv2-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0gwm63jrvg9lww0rl3sjkgbjwfz0vascpb19cfxmhkmm477ipibq"))))
+ (build-system meson-build-system)
(inputs
;; Leaving off cairo and gtk+-2.0 which are needed for example plugins
(list libsndfile))
--
2.41.0
Z
Z
Zheng Junjie wrote on 19 Nov 2023 11:07
[PATCH gnome-team 5/5] gnu: lilv: Update to 0.24.22.
(address . 67273@debbugs.gnu.org)
39f000643e29f08d37d3df0b3928d64e2ef92e0c.1700387828.git.zhengjunjie@iscas.ac.cn
* gnu/packages/audio.scm (lilv): Update to 0.24.22.
[source]: Use git-fetch.
[build-system]: Change to meson-build-system
[arguments]: Remove it.
[propagated-inputs]: Add zix.

Change-Id: I7d50dbf941165ebf99467272d6e6c3987e933d86
---
gnu/packages/audio.scm | 41 ++++++++++++++---------------------------
1 file changed, 14 insertions(+), 27 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index ef952480f8..ea2aafa2b0 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -141,6 +141,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages datastructures)
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
#:use-module (guix build-system glib-or-gtk)
@@ -3041,33 +3042,19 @@ (define-public audio-to-midi
(define-public lilv
(package
(name "lilv")
- (version "0.24.12")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://download.drobilla.net/lilv-"
- version ".tar.bz2"))
- (sha256
- (base32
- "0qchfsyrsrp2pdpd59025kllycr04ddpzd03ha1iz70ci687g8r6"))))
- (build-system waf-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'set-ldflags
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "LDFLAGS"
- (string-append "-Wl,-rpath="
- (assoc-ref outputs "out") "/lib"))))
- (add-after 'unpack 'full-store-path-to-shared-library
- (lambda* (#:key outputs #:allow-other-keys)
- (with-directory-excursion "bindings/python"
- (substitute* "lilv.py"
- (("liblilv-0.so") (string-append (assoc-ref outputs "out")
- "/lib/liblilv-0.so")))))))))
- ;; Required by lilv-0.pc.
- (propagated-inputs
- (list lv2 serd sord sratom))
+ (version "0.24.22")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/lv2/lilv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kvg56vh61p91kl8yzh6r1px8yk80gv92v38fmvk7r592kp5y8j0"))))
+ (build-system meson-build-system)
+ (propagated-inputs (list lv2 serd sord sratom zix))
(native-inputs
(list python pkg-config))
(home-page "https://drobilla.net/software/lilv")
--
2.41.0
Z
Z
Zheng Junjie wrote on 19 Nov 2023 11:07
[PATCH gnome-team 1/5] gnu: zix: Update to 0.4.2.
(address . 67273@debbugs.gnu.org)
92b11b55ad9f897cc29208dcb830c49154978290.1700387828.git.zhengjunjie@iscas.ac.cn
* gnu/packages/datastructures.scm (zix): Update to 0.4.2.

Change-Id: I4465ff6eefbdbb7a3de1806fc4adbec285fa26a1
---
gnu/packages/datastructures.scm | 45 ++++++++++++++++-----------------
1 file changed, 22 insertions(+), 23 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 0689ef4259..c6b2396537 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -444,28 +445,26 @@ (define-public robin-map
(license license:expat)))
(define-public zix
- (let ((commit "a13ae5ad9dc70075740f11139f1db96cc79faa59")
- (revision "0"))
- (package
- (name "zix")
- (version (git-version "0.3.3" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/drobilla/zix.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1njyb8lz1d5qzf0k14pb3rq13xkxnddwbz090dj69138ymz1xgyl"))))
- (build-system meson-build-system)
- (arguments
- (list #:configure-flags #~(list "-Ddocs=disabled"))) ;needs "sphinxygen"
- (native-inputs (list pkg-config))
- (home-page "https://gitlab.com/drobilla/zix")
- (synopsis "C library of portability wrappers and data structures")
- (description
- "Zix is a C library of portability wrappers and data structures. It
+ (package
+ (name "zix")
+ (version "0.4.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/drobilla/zix.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07pbq4bi64iv39swldfbcp7131b5n4hs64pgd417gqlwv8qvgjcw"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-Ddocs=disabled"))) ;needs "sphinxygen"
+ (native-inputs (list pkg-config))
+ (home-page "https://gitlab.com/drobilla/zix")
+ (synopsis "C library of portability wrappers and data structures")
+ (description
+ "Zix is a C library of portability wrappers and data structures. It
provides the following components:
@table @code
@item ZixAllocator A customizable allocator.
@@ -480,4 +479,4 @@ (define-public zix
zix/filesystem.h Functions for working with filesystems.
@item zix/path.h Functions for working with filesystem paths lexically.
@end table")
- (license license:isc))))
+ (license license:isc)))
--
2.41.0
Z
Z
Zheng Junjie wrote on 19 Nov 2023 11:07
[PATCH gnome-team 3/5] gnu: sratom: Update to 0.6.16.
(address . 67273@debbugs.gnu.org)
3da8ef93a1b879fd1219139c8b961ee8f754b5b7.1700387828.git.zhengjunjie@iscas.ac.cn
* gnu/packages/audio.scm (sratom): Update to 0.6.16.
[source]: Update url.
[build-system]: Change to meson-build-system.
[arguments]: Remove it.

Change-Id: If24bcd75a79c5e27e1a40647651573d72b48bdf3
---
gnu/packages/audio.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 7c49ba1841..9b6bf0e7e5 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3725,16 +3725,15 @@ (define-public rtmidi-4.0
(define-public sratom
(package
(name "sratom")
- (version "0.6.6")
+ (version "0.6.16")
(source (origin
(method url-fetch)
(uri (string-append "https://download.drobilla.net/sratom-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
(base32
- "178v90qvsp6lw4sqdmdz0bzyjkgwhv9m75ph1d1z8say5bv0p4gv"))))
- (build-system waf-build-system)
- (arguments `(#:tests? #f)) ;no check target
+ "1i12wcnv52r05zr5wjmpvbsvbjbm3hkv8frral2kvrc326cmghbi"))))
+ (build-system meson-build-system)
(propagated-inputs
;; In Requires of sratom-0.pc.
(list lv2 serd sord))
--
2.41.0
G
G
Gabriel Wicki wrote on 29 Nov 2023 14:19
(name . Zheng Junjie)(address . zhengjunjie@iscas.ac.cn)(address . 67273@debbugs.gnu.org)
vf2xiohj4dadvb2oexkxswc73fma222bnc25yepeez2kc4wjpf@de2cd6waonj5
Hi!

Thanks for the explanation!

So the patch set should be changed in order - i can confirm that all
packages now build just fine!

They generally look good to me, except for one question: is it
impossible to patch the sources so we wouldn't need to propagate more
inputs? Otherwise all seems fine.


So, if you could re-send your patchset with
- the correct order,
- $(guix style) ran on all the packages,
- and maybe less input propagation (if possible)

that'd be great!

Thanks for your time and effort!
Z
Z
Zheng Junjie wrote on 30 Mar 15:27 +0100
close
(address . 67273-done@debbugs.gnu.org)
871q7raij0.fsf@iscas.ac.cn
Has been updated, no longer needed.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmYIJLMACgkQO1qpk+Gi
3/A6xhAAkRzzybw6qfwJk1HByci5Jr7ERARjrZeH0QlKs2nWHxNDpQHPyzN83Tlx
6t68pZ//t+VVINDioltpEGDxMn8Xzcye5Cn8pdk7sAGik16vLz9W5+GVge19jJmr
Zrv9g3PsPUWkORIQ4inbo2agzBk2a5QQfNHo3AedS6uuBK4BocUAJE9c8IPCbp6U
BodJjzP9NvF9wUictbrkM937anrxRQBy1BwlEYNCLZ/Lr9Qsy+7BOOacPYFWuCpF
alcL0oDCDN3mHjUaCpy/GmXes2ozuu+U0p/iBSmUnQyAs0pCjnsXfnLtLAZCgo0w
3IcFivIbd2RmIqtM7jZB0/zL/8DCV1ToCXBM7I1VtHx3eO68KSIAd0opL8J0CzAJ
QpqVEbHvGOfw00Y62lf8iRAalrCLSbLFB0aaQr34QBzs3Dx1BxIKi9rt/r/3RMru
o0U74y1obmv4CHXAjoeLa5xYoRTV3MbyN38kbhnYrU3M5OhwZo/lUCRSz6UHqQTR
Yf3RODoq+hvyIlkKcEdLb3G703ZDVZyGKEq03LgM6Oh3XBBDD37JTOxtWvq5kYV4
oonBvarzrRlBwASPxbmVKSEgZuOT8OTAZnPP24LP9HSxpWh8GJ0Q/JS9jdVOLsmz
6wHRX4NmnW5ujc44xyTXZdiCOsS6/zjOCGM9VK/bDqcZmnFj1HE=
=FOYV
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67273@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67273
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch