[PATCH] gnu: at-spi2-core: Honor tests? flag..

  • Open
  • quality assurance status badge
Details
3 participants
  • Maxim Cournoyer
  • Mathieu Othacehe
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote on 19 Nov 2023 10:52
(address . guix-patches@gnu.org)
bf2ddc3cec23a5127384cfb840344d2702300cc0.1700387396.git.zhengjunjie@iscas.ac.cn
* gnu/packages/gtk.scm (at-spi2-core)[arguments]<#:phases>: Honor tests? flag.

Change-Id: Ie38226c0ceacd7afb54adff073c1f71eb596e10d
---
gnu/packages/gtk.scm | 46 ++++++++++++++++++++++----------------------
1 file changed, 23 insertions(+), 23 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 67611efaae..745c3a9a55 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -811,31 +811,31 @@ (define-public at-spi2-core
(delete 'check)
;; The CI test suite fails completely on powerpc-linux.
;; The name org.gnome.SessionManager was not provided by any .service
- ;; TODO: Wrap 'check phase with 'tests?'.
#$@(if (not (target-ppc32?))
#~((add-after 'install 'check
- (lambda _
- ;; xfconfd requires a writable HOME
- (setenv "HOME" (getenv "TMPDIR"))
- ;; dbus-run-session may crash if XDG_DATA_DIRS has too
- ;; many entries, maybe related to
- ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
- (setenv "XDG_DATA_DIRS"
- (string-append
- #$output "/share:"
- #$(this-package-native-input
- "gsettings-desktop-schemas")
- "/share"))
- ;; Don't fail on missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (with-directory-excursion (string-append "../at-spi2-core-"
- #$version "")
- (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
- (substitute* "ci/run-tests.sh"
- (("ps auxwww") "") ;avoid a dependency on procps
- (("meson test -C _build")
- "meson test -C ../build")) ;adjust build directory
- (invoke "dbus-run-session" "--" "ci/run-tests.sh")))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; xfconfd requires a writable HOME
+ (setenv "HOME" (getenv "TMPDIR"))
+ ;; dbus-run-session may crash if XDG_DATA_DIRS has too
+ ;; many entries, maybe related to
+ ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
+ (setenv "XDG_DATA_DIRS"
+ (string-append
+ #$output "/share:"
+ #$(this-package-native-input
+ "gsettings-desktop-schemas")
+ "/share"))
+ ;; Don't fail on missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (with-directory-excursion (string-append "../at-spi2-core-"
+ #$version "")
+ (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
+ (substitute* "ci/run-tests.sh"
+ (("ps auxwww") "") ;avoid a dependency on procps
+ (("meson test -C _build")
+ "meson test -C ../build")) ;adjust build directory
+ (invoke "dbus-run-session" "--" "ci/run-tests.sh"))))))
#~()))))
(inputs
(list bash-minimal libxml2))

base-commit: 1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523
--
2.41.0
M
M
Mathieu Othacehe wrote on 25 Nov 2023 14:43
(name . Zheng Junjie)(address . zhengjunjie@iscas.ac.cn)
87plzyt0cl.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> * gnu/packages/gtk.scm (at-spi2-core)[arguments]<#:phases>: Honor tests? flag.

Could you please rebase it on top of
9210ca9b0498d3360ee247841a6bd212d6aa8ec4?

Thanks,

Mathieu
Z
Z
Zheng Junjie wrote on 29 Nov 2023 11:51
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
87cyvsq0xx.fsf@iscas.ac.cn
Mathieu Othacehe <othacehe@gnu.org> writes:

Toggle quote (7 lines)
> Hello,
>
>> * gnu/packages/gtk.scm (at-spi2-core)[arguments]<#:phases>: Honor tests? flag.
>
> Could you please rebase it on top of
> 9210ca9b0498d3360ee247841a6bd212d6aa8ec4?

sorry, this patch should prefix with [PATCH gnome-term]

Toggle quote (4 lines)
>
> Thanks,
>
> Mathieu
M
M
Maxim Cournoyer wrote on 31 Dec 2023 07:09
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
874jfyrjhi.fsf@gmail.com
Hi,

Mathieu Othacehe <othacehe@gnu.org> writes:

Toggle quote (7 lines)
> Hello,
>
>> * gnu/packages/gtk.scm (at-spi2-core)[arguments]<#:phases>: Honor tests? flag.
>
> Could you please rebase it on top of
> 9210ca9b0498d3360ee247841a6bd212d6aa8ec4?

Is this core-updates?

--
Thanks,
Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67271@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67271
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch