(address . guix-patches@gnu.org)
* gnu/packages/gtk.scm (at-spi2-core)[arguments]<#:phases>: Honor tests? flag.
Change-Id: Ie38226c0ceacd7afb54adff073c1f71eb596e10d
---
gnu/packages/gtk.scm | 46 ++++++++++++++++++++++----------------------
1 file changed, 23 insertions(+), 23 deletions(-)
Toggle diff (63 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 67611efaae..745c3a9a55 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -811,31 +811,31 @@ (define-public at-spi2-core
(delete 'check)
;; The CI test suite fails completely on powerpc-linux.
;; The name org.gnome.SessionManager was not provided by any .service
- ;; TODO: Wrap 'check phase with 'tests?'.
#$@(if (not (target-ppc32?))
#~((add-after 'install 'check
- (lambda _
- ;; xfconfd requires a writable HOME
- (setenv "HOME" (getenv "TMPDIR"))
- ;; dbus-run-session may crash if XDG_DATA_DIRS has too
- ;; many entries, maybe related to
- ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
- (setenv "XDG_DATA_DIRS"
- (string-append
- #$output "/share:"
- #$(this-package-native-input
- "gsettings-desktop-schemas")
- "/share"))
- ;; Don't fail on missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (with-directory-excursion (string-append "../at-spi2-core-"
- #$version "")
- (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
- (substitute* "ci/run-tests.sh"
- (("ps auxwww") "") ;avoid a dependency on procps
- (("meson test -C _build")
- "meson test -C ../build")) ;adjust build directory
- (invoke "dbus-run-session" "--" "ci/run-tests.sh")))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; xfconfd requires a writable HOME
+ (setenv "HOME" (getenv "TMPDIR"))
+ ;; dbus-run-session may crash if XDG_DATA_DIRS has too
+ ;; many entries, maybe related to
+ ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
+ (setenv "XDG_DATA_DIRS"
+ (string-append
+ #$output "/share:"
+ #$(this-package-native-input
+ "gsettings-desktop-schemas")
+ "/share"))
+ ;; Don't fail on missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (with-directory-excursion (string-append "../at-spi2-core-"
+ #$version "")
+ (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
+ (substitute* "ci/run-tests.sh"
+ (("ps auxwww") "") ;avoid a dependency on procps
+ (("meson test -C _build")
+ "meson test -C ../build")) ;adjust build directory
+ (invoke "dbus-run-session" "--" "ci/run-tests.sh"))))))
#~()))))
(inputs
(list bash-minimal libxml2))
base-commit: 1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523
--
2.41.0