For some applications, it's important to establish a non-blocking connection
rather than just making the socket non-blocking after the connection is
established. This is because there is I/O on the socket that will block during
the handshake.
I've noticed this blocking during the handshake causing issues in the build
coordinator for example.
This commit adds a new with-store variant to avoid changing the behaviour of
with-store/open-connection to ensure that this change can't break anything
that depends on the blocking nature of the socket.
* guix/store.scm (open-unix-domain-socket, open-inet-socket): Take
#:non-blocking? and use SOCK_NONBLOCK when calling socket if appropriate.
(connect-to-daemon, open-connection, call-with-store): Take #:non-blocking?
and pass it on.
(with-store/non-blocking): New syntax rule.
Change-Id: I8225762b78448bc1f7b698c8de5d736e13f577bf
---
guix/store.scm | 53 +++++++++++++++++++++++++++++++++++---------------
1 file changed, 37 insertions(+), 16 deletions(-)
Toggle diff (146 lines)
diff --git a/guix/store.scm b/guix/store.scm
index a238cb627a..3e8202a43a 100644
--- a/guix/store.scm
+++ b/guix/store.scm
@@ -106,6 +106,7 @@ (define-module (guix store)
port->connection
close-connection
with-store
+ with-store/non-blocking
set-build-options
set-build-options*
valid-path?
@@ -462,12 +463,15 @@ (define-syntax-rule (system-error-to-connection-error file exp ...)
(file file)
(errno errno))))))))
-(define (open-unix-domain-socket file)
+(define* (open-unix-domain-socket file #:key non-blocking?)
"Connect to the Unix-domain socket at FILE and return it. Raise a
-'&store-connection-error' upon error."
+'&store-connection-error' upon error. If NON-BLOCKING?, make the socket
+non-blocking."
(let ((s (with-fluids ((%default-port-encoding #f))
;; This trick allows use of the `scm_c_read' optimization.
- (socket PF_UNIX (logior SOCK_STREAM SOCK_CLOEXEC) 0)))
+ (socket PF_UNIX
+ (logior SOCK_STREAM SOCK_CLOEXEC SOCK_NONBLOCK)
+ 0)))
(a (make-socket-address PF_UNIX file)))
(system-error-to-connection-error file
@@ -478,9 +482,10 @@ (define %default-guix-port
;; Default port when connecting to a daemon over TCP/IP.
44146)
-(define (open-inet-socket host port)
+(define* (open-inet-socket host port #:key non-blocking?)
"Connect to the Unix-domain socket at HOST:PORT and return it. Raise a
-'&store-connection-error' upon error."
+'&store-connection-error' upon error. If NON-BLOCKING?, make the socket
+non-blocking."
(define addresses
(getaddrinfo host
(if (number? port) (number->string port) port)
@@ -495,7 +500,10 @@ (define (open-inet-socket host port)
((ai rest ...)
(let ((s (socket (addrinfo:fam ai)
;; TCP/IP only
- (logior SOCK_STREAM SOCK_CLOEXEC) IPPROTO_IP)))
+ (if non-blocking?
+ (logior SOCK_STREAM SOCK_CLOEXEC SOCK_NONBLOCK)
+ (logior SOCK_STREAM SOCK_CLOEXEC))
+ IPPROTO_IP)))
(catch 'system-error
(lambda ()
@@ -514,9 +522,10 @@ (define (open-inet-socket host port)
(errno (system-error-errno args)))))
(loop rest)))))))))
-(define (connect-to-daemon uri)
+(define* (connect-to-daemon uri #:key non-blocking?)
"Connect to the daemon at URI, a string that may be an actual URI or a file
-name, and return an input/output port.
+name, and return an input/output port. If NON-BLOCKING?, use a non-blocking
+socket when using the file, unix or guix URI schemes.
This is a low-level procedure that does not perform the initial handshake with
the daemon. Use 'open-connection' for that."
@@ -533,11 +542,13 @@ (define (connect-to-daemon uri)
(match (uri-scheme uri)
((or #f 'file 'unix)
(lambda (_)
- (open-unix-domain-socket (uri-path uri))))
+ (open-unix-domain-socket (uri-path uri)
+ #:non-blocking? non-blocking?)))
('guix
(lambda (_)
(open-inet-socket (uri-host uri)
- (or (uri-port uri) %default-guix-port))))
+ (or (uri-port uri) %default-guix-port)
+ #:non-blocking? non-blocking?)))
((? symbol? scheme)
;; Try to dynamically load a module for SCHEME.
;; XXX: Errors are swallowed.
@@ -557,7 +568,8 @@ (define (connect-to-daemon uri)
(connect uri))
(define* (open-connection #:optional (uri (%daemon-socket-uri))
- #:key port (reserve-space? #t) cpu-affinity)
+ #:key port (reserve-space? #t) cpu-affinity
+ non-blocking?)
"Connect to the daemon at URI (a string), or, if PORT is not #f, use it as
the I/O port over which to communicate to a build daemon.
@@ -565,7 +577,9 @@ (define* (open-connection #:optional (uri (%daemon-socket-uri))
space on the file system so that the garbage collector can still operate,
should the disk become full. When CPU-AFFINITY is true, it must be an integer
corresponding to an OS-level CPU number to which the daemon's worker process
-for this connection will be pinned. Return a server object."
+for this connection will be pinned. If NON-BLOCKING?, use a non-blocking
+socket when using the file, unix or guix URI schemes. Return a server
+object."
(define (handshake-error)
(raise (condition
(&store-connection-error (file (or port uri))
@@ -577,7 +591,8 @@ (define* (open-connection #:optional (uri (%daemon-socket-uri))
;; really a connection error.
(handshake-error)))
(let*-values (((port)
- (or port (connect-to-daemon uri)))
+ (or port (connect-to-daemon
+ uri #:non-blocking? non-blocking?)))
((output flush)
(buffering-output-port port
(make-bytevector 8192))))
@@ -657,9 +672,10 @@ (define (close-connection server)
"Close the connection to SERVER."
(close (store-connection-socket server)))
-(define (call-with-store proc)
- "Call PROC with an open store connection."
- (let ((store (open-connection)))
+(define* (call-with-store proc #:key non-blocking?)
+ "Call PROC with an open store connection. Pass NON-BLOCKING? to
+open-connection."
+ (let ((store (open-connection #:non-blocking? non-blocking?)))
(define (thunk)
(parameterize ((current-store-protocol-version
(store-connection-version store)))
@@ -678,6 +694,11 @@ (define-syntax-rule (with-store store exp ...)
automatically close the store when the dynamic extent of EXP is left."
(call-with-store (lambda (store) exp ...)))
+(define-syntax-rule (with-store/non-blocking store exp ...)
+ "Bind STORE to an non-blocking open connection to the store and evaluate
+EXPs; automatically close the store when the dynamic extent of EXP is left."
+ (call-with-store (lambda (store) exp ...) #:non-blocking? #t))
+
(define current-store-protocol-version
;; Protocol version of the store currently used. XXX: This is a hack to
;; communicate the protocol version to the build output port. It's a hack
base-commit: 9288654773a110156e0bb6fc703a9c24f5bfc527
--
2.41.0