* gnu/packages/gnome.scm (gnome-calculator) [arguments]: Convert to list of
G-Expressions.
Change-Id: I217aec53e66808cc11a26f5df58fd25355d898b0
---
gnu/packages/gnome.scm | 25 +++++++++++++------------
1 file changed, 13 insertions(+), 12 deletions(-)
Toggle diff (38 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8cd7d47d33..e0dbf7ba5a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10813,18 +10813,19 @@ (define-public gnome-calculator
"0hqhnwaw7zam0r7b61ir68710hxmc5rxb0172mz9lc48kwr67rql"))))
(build-system meson-build-system)
(arguments
- '(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
- (lambda _
- (substitute* "meson.build"
- (("gtk_update_icon_cache: true")
- "gtk_update_icon_cache: false"))))
- (add-before 'check 'pre-check
- (lambda _
- ;; Tests require a writable HOME.
- (setenv "HOME" (getcwd)))))))
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a writable HOME.
+ (setenv "HOME" (getcwd)))))))
(native-inputs
(list gettext-minimal
`(,glib "bin") ;for glib-compile-schemas, gio-2.0.
--
2.41.0