[PATCH] gnu: Add leafnode.

  • Open
  • quality assurance status badge
Details
One participant
  • VÖRÖSK?I András
Owner
unassigned
Submitted by
VÖRÖSK?I András
Severity
normal
V
V
VÖRÖSK?I András wrote on 16 Nov 2023 22:59
(address . guix-patches@gnu.org)(name . VÖRÖSK?I András)(address . voroskoi@gmail.com)
d6efe23482cfecdcfd95ff334e0213d6004fda2a.1700171952.git.voroskoi@gmail.com
* gnu/packages/web.scm (leafnode): New variable.

Change-Id: I7ab6823ecdf91e278176d408e4e99b4be1a70781
---
gnu/packages/web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 389f7d1375..61496c20c7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2023 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
+;;; Copyright © 2023 VÖRÖSK?I András <voroskoi@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2091,6 +2092,34 @@ (define-public liboauth
;; Source code may be distributed under either license.
(license (list license:expat license:gpl2+))))
+(define-public leafnode
+ (package
+ (name "leafnode")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/leafnode/leafnode/"
+ version "/leafnode-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pkryzndqaxs1ym7gs77r6x8mmzpnm5x7n2ph8ga45zn45rwwrxl"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake))
+ (inputs (list pcre2))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (substitute* "Makefile.am" (("/bin/sh") (which "sh"))))))))
+ (home-page "https://sourceforge.net/projects/leafnode/")
+ (synopsis "NNTP news proxy")
+ (description
+ "Leafnode is a caching Usenet news proxy that enables online newsreaders
+to read news off-line and aggregates news from various NNTP servers into one.")
+ ;; Most of the code is under Expat license, with some GPL, LGPL exceptions.
+ (license license:gpl2+)))
+
(define-public libquvi-scripts
(package
(name "libquvi-scripts")

base-commit: fc6bdaad57bf91609849623c5f485403c030cb49
--
2.41.0
?