[PATCH] gnu: aerc: Fix notmuch support.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
  • VÖRÖSK?I András
Owner
unassigned
Submitted by
VÖRÖSK?I András
Severity
normal
V
V
VÖRÖSK?I András wrote on 16 Nov 2023 18:34
(address . guix-patches@gnu.org)(name . VÖRÖSK?I András)(address . voroskoi@gmail.com)
a10d0bdf6cc5e390ead227e0efdb7bcb4ffcb3e5.1700156042.git.voroskoi@gmail.com
* gnu/packages/mail.scm (aerc)[inputs]: Add notmuch, remove go modules and zoxide.
* gnu/packages/mail.scm (aerc)[native-inputs] Add go modules and zoxide.

Change-Id: I697cee112bcc37f87681ee16de6ffc3f7b13ec3d
---

For notmuch support notmuch.h has to be included build time, so added to inputs.
Zoxide moved to native-inputs as it is an optional depencency, aerc works fine
without it.

I am not sure about the go modules, but I think they also sould be just native-inputs
as we only need those at build time.

gnu/packages/mail.scm | 84 ++++++++++++++++++++++---------------------
1 file changed, 44 insertions(+), 40 deletions(-)

Toggle diff (106 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 256bd4b03a..1f71a16bcd 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
+;;; Copyright © 2023 VÖRÖSK?I András <voroskoi@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4932,46 +4933,49 @@ (define-public aerc
(invoke "make" "CC=gcc" "install" "-C"
(string-append "src/" import-path)
(string-append "PREFIX=" #$output)))))))
- (inputs (list gnupg
- go-github-com-zenhack-go-notmuch
- go-golang-org-x-oauth2
- go-github-com-xo-terminfo
- go-github-com-stretchr-testify
- go-github-com-riywo-loginshell
- go-github-com-pkg-errors
- go-github-com-mitchellh-go-homedir
- go-github-com-miolini-datacounter
- go-github-com-mattn-go-runewidth
- go-github-com-mattn-go-isatty
- go-github-com-lithammer-fuzzysearch
- go-github-com-kyoh86-xdg
- go-github-com-imdario-mergo
- go-github-com-google-shlex
- go-github-com-go-ini-ini
- go-github-com-gdamore-tcell-v2
- go-github-com-gatherstars-com-jwz
- go-github-com-fsnotify-fsnotify
- go-github-com-emersion-go-smtp
- go-github-com-emersion-go-sasl
- go-github-com-emersion-go-pgpmail
- go-github-com-emersion-go-message
- go-github-com-emersion-go-maildir
- go-github-com-emersion-go-imap-sortthread
- go-github-com-emersion-go-imap
- go-github-com-emersion-go-msgauth
- go-github-com-emersion-go-mbox
- go-github-com-ddevault-go-libvterm
- go-github-com-danwakefield-fnmatch
- go-github-com-creack-pty
- go-github-com-arran4-golang-ical
- go-github-com-protonmail-go-crypto
- go-github-com-syndtr-goleveldb-leveldb
- go-git-sr-ht-sircmpwn-getopt
- go-git-sr-ht-rockorager-tcell-term
- python
- python-vobject
- zoxide))
- (native-inputs (list scdoc))
+ (inputs (list
+ gnupg
+ notmuch
+ python
+ python-vobject))
+ (native-inputs (list
+ go-github-com-zenhack-go-notmuch
+ go-golang-org-x-oauth2
+ go-github-com-xo-terminfo
+ go-github-com-stretchr-testify
+ go-github-com-riywo-loginshell
+ go-github-com-pkg-errors
+ go-github-com-mitchellh-go-homedir
+ go-github-com-miolini-datacounter
+ go-github-com-mattn-go-runewidth
+ go-github-com-mattn-go-isatty
+ go-github-com-lithammer-fuzzysearch
+ go-github-com-kyoh86-xdg
+ go-github-com-imdario-mergo
+ go-github-com-google-shlex
+ go-github-com-go-ini-ini
+ go-github-com-gdamore-tcell-v2
+ go-github-com-gatherstars-com-jwz
+ go-github-com-fsnotify-fsnotify
+ go-github-com-emersion-go-smtp
+ go-github-com-emersion-go-sasl
+ go-github-com-emersion-go-pgpmail
+ go-github-com-emersion-go-message
+ go-github-com-emersion-go-maildir
+ go-github-com-emersion-go-imap-sortthread
+ go-github-com-emersion-go-imap
+ go-github-com-emersion-go-msgauth
+ go-github-com-emersion-go-mbox
+ go-github-com-ddevault-go-libvterm
+ go-github-com-danwakefield-fnmatch
+ go-github-com-creack-pty
+ go-github-com-arran4-golang-ical
+ go-github-com-protonmail-go-crypto
+ go-github-com-syndtr-goleveldb-leveldb
+ go-git-sr-ht-sircmpwn-getopt
+ go-git-sr-ht-rockorager-tcell-term
+ scdoc
+ zoxide))
(home-page "https://git.sr.ht/~rjarry/aerc")
(synopsis "Email client for the terminal")
(description "@code{aerc} is a textual email client for terminals. It

base-commit: fc6bdaad57bf91609849623c5f485403c030cb49
--
2.41.0
L
L
Ludovic Courtès wrote on 11 Dec 2023 23:38
(name . VÖRÖSK?I András)(address . voroskoi@gmail.com)(address . 67231@debbugs.gnu.org)
871qbs2wm9.fsf@gnu.org
Hi,

VÖRÖSK?I András <voroskoi@gmail.com> skribis:

Toggle quote (13 lines)
> * gnu/packages/mail.scm (aerc)[inputs]: Add notmuch, remove go modules and zoxide.
> * gnu/packages/mail.scm (aerc)[native-inputs] Add go modules and zoxide.
>
> Change-Id: I697cee112bcc37f87681ee16de6ffc3f7b13ec3d
> ---
>
> For notmuch support notmuch.h has to be included build time, so added to inputs.
> Zoxide moved to native-inputs as it is an optional depencency, aerc works fine
> without it.
>
> I am not sure about the go modules, but I think they also sould be just native-inputs
> as we only need those at build time.

Zoxide is definitely present at run-time, as can be seen when running
‘guix size aerc’. So I think it should remain in ‘inputs’.

As for the Go modules, my inclination is that they should be in ‘inputs’
as well because surely the resulting binaries must be linked against
them, even if statically?

IOW, I guess I’d just add ‘notmuch’ to ‘inputs’ and not make the other
changes. If that’s fine with you, could you send an updated patch?

Thanks,
Ludo’.
S
S
Sharlatan Hellseher wrote on 29 Jul 00:44 +0200
[PATCH] gnu: aerc: Fix notmuch support.
(address . 67231@debbugs.gnu.org)
871q3dnnlg.fsf@gmail.com
Hi,

I've updated aerec to the latest version and adjust inputs similar to
this issue on go-team branch

For any final application in Golang sources used during compile time are
not "linked" like in C/C++ but placed as pure text into location known
for Golang compiler e.g. the final binary has not any references to
libraries from inputs after build is completed.

Generally speaking when we build some CLI from Golang sources all inputs
may be native-inputs.

If the current source would be used as dependency all of it's inputs
need to go to propagated-inputs which prevent packaging complexity.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmamycsACgkQdtcnv/Ys
0rUYYRAApaSr76wq4444vLxfvjUu8qRX70/CT7+GLwf28RzhucH930m5r6k02J7k
BqX0ZQyK9EFIZYqF4e9DJXtpV9eP0ZC0bxkNjJN/gminohJghasvLaV0P72QXtnZ
el7BzOqAdYiKphUMwjZ819dUmZ1ZxAxD6MvYh3Jbvx3DaxjD9eEeJ39wC9osda7U
bfcN0yytOisCOfEAxgqjnDGGm5atCVClV0NWqTq28mzzIOWjetg4mZr/OIOFZyYu
HecJsr105/w1ILxW/ievnHK7i7A26uTealjvi8BL2/XlmeJBBTQevtIGL84/5P//
zS62p4YTT4DoeVMzk5co37pN+vqIilE/53xNnyV++tLJnCaA+1a06XcRO7dDc/9I
3wR028cAHxZ70hUnj6w6o2EMM1HElKCpq4hRdKeZR4QR3NmqItXFiEufuLWSMSQ9
z5rmrSEF/J5bK+rSWE8F5nfGehQXBRK9in4HXJ/553/DLJ0o6dsB09/TUTY1nPv5
AFG1ovx4/1a878LeKU/wABM6WHTDW9fXbm9ktn/euxuFN1YSVYtKyr2JkJ9+/2AV
GW8P/7dNW46aoY0AfYSR5+N7WNru62RcOKl+IgwWVEeiRlLOawhe9PgsoVvmSh6d
Wy1WINI7uxUS0yltSbfBIIwlA7/qVGSgjd76VoIroHD7xxBTcNE=
=Z77+
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 11 Aug 12:36 +0200
(address . 67231-done@debbugs.gnu.org)
87ed6v1h2z.fsf@gmail.com
Hi,

Thank you for highlighting it, it was resolved in the latest go-team to
master merge:

* 5cb835a839 gnu: aerc: Update to 0.18.1.
* 51fec36901 gnu: aerc: Adjust inputs.
* 5a2910d20d gnu: aerc: Fix indentation.
* e4397a32ac gnu: aerc: Enable building without zoxide.

Closing as implemented in other commits.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAma4lEQACgkQdtcnv/Ys
0rWUPg//aOBIIGJGP2XCmbA6Y7bPRyfapnPWb49HzsykDOFwfOXzs5vPjVsqPrPf
uo7hgeIg3Gz2x2Ajr1OQsHaCeU3O48dP+ttI1FacCPfaP/jq04tFdgD8V3Ls4ZUC
QV1j05r1XaGuxVMnaklyMES/5OoKf492gU9mqRe4PECtqJkp6wE/XymUguObuBaH
XqZZjgc0Ar8J7EvH2frEERp7OjZoToMZ7ER69Ni2RINNtp+BZIcGHbh40Kd/C3ei
GH37wJ5PzBKz099h3rzljK+ED0FjOrnGcXuJZjhflSuYqhnyBPBf99G0d1HMLWdt
t5jSZNwEk+QVSR+reG1q3PSnLpwrCdi3G1hKCV9GXwr7h2qRpd7XWHcCYgkfpfW5
DIaz9xnnXfc+mE8boNzHZdukgpGklBD9QaHQG/ZRyuBMKisfjJnxJaktpQCu2Kj/
j1rep5da8RfnWMReDI3arwLw6Xcx0A9O3AmuKJb8Y6XaTFI9JkF9AbPeB/oossyF
N1i5vZ+x0pk9WETDyNlaXzvdd4rC3Ksi8t8Xk5Xanl5mYxLh6d/oa83c5mQLTjUv
t90pmCYEM34U7nb7aB/hu/5ogWQRV8YR+tens39rrF08Tnjm6hzNcsFvl3vUghdD
AVcz6kltf+SABUPL6EsUtCtZIVU0cLHLQJVpU/PsO+9d1NfvCaQ=
=8VH/
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67231@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67231
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch