(address . guix-patches@gnu.org)(name . VÖRÖSK?I András)(address . voroskoi@gmail.com)
* gnu/packages/mail.scm (aerc)[inputs]: Add notmuch, remove go modules and zoxide.
* gnu/packages/mail.scm (aerc)[native-inputs] Add go modules and zoxide.
Change-Id: I697cee112bcc37f87681ee16de6ffc3f7b13ec3d
---
For notmuch support notmuch.h has to be included build time, so added to inputs.
Zoxide moved to native-inputs as it is an optional depencency, aerc works fine
without it.
I am not sure about the go modules, but I think they also sould be just native-inputs
as we only need those at build time.
gnu/packages/mail.scm | 84 ++++++++++++++++++++++---------------------
1 file changed, 44 insertions(+), 40 deletions(-)
Toggle diff (106 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 256bd4b03a..1f71a16bcd 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
+;;; Copyright © 2023 VÖRÖSK?I András <voroskoi@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4932,46 +4933,49 @@ (define-public aerc
(invoke "make" "CC=gcc" "install" "-C"
(string-append "src/" import-path)
(string-append "PREFIX=" #$output)))))))
- (inputs (list gnupg
- go-github-com-zenhack-go-notmuch
- go-golang-org-x-oauth2
- go-github-com-xo-terminfo
- go-github-com-stretchr-testify
- go-github-com-riywo-loginshell
- go-github-com-pkg-errors
- go-github-com-mitchellh-go-homedir
- go-github-com-miolini-datacounter
- go-github-com-mattn-go-runewidth
- go-github-com-mattn-go-isatty
- go-github-com-lithammer-fuzzysearch
- go-github-com-kyoh86-xdg
- go-github-com-imdario-mergo
- go-github-com-google-shlex
- go-github-com-go-ini-ini
- go-github-com-gdamore-tcell-v2
- go-github-com-gatherstars-com-jwz
- go-github-com-fsnotify-fsnotify
- go-github-com-emersion-go-smtp
- go-github-com-emersion-go-sasl
- go-github-com-emersion-go-pgpmail
- go-github-com-emersion-go-message
- go-github-com-emersion-go-maildir
- go-github-com-emersion-go-imap-sortthread
- go-github-com-emersion-go-imap
- go-github-com-emersion-go-msgauth
- go-github-com-emersion-go-mbox
- go-github-com-ddevault-go-libvterm
- go-github-com-danwakefield-fnmatch
- go-github-com-creack-pty
- go-github-com-arran4-golang-ical
- go-github-com-protonmail-go-crypto
- go-github-com-syndtr-goleveldb-leveldb
- go-git-sr-ht-sircmpwn-getopt
- go-git-sr-ht-rockorager-tcell-term
- python
- python-vobject
- zoxide))
- (native-inputs (list scdoc))
+ (inputs (list
+ gnupg
+ notmuch
+ python
+ python-vobject))
+ (native-inputs (list
+ go-github-com-zenhack-go-notmuch
+ go-golang-org-x-oauth2
+ go-github-com-xo-terminfo
+ go-github-com-stretchr-testify
+ go-github-com-riywo-loginshell
+ go-github-com-pkg-errors
+ go-github-com-mitchellh-go-homedir
+ go-github-com-miolini-datacounter
+ go-github-com-mattn-go-runewidth
+ go-github-com-mattn-go-isatty
+ go-github-com-lithammer-fuzzysearch
+ go-github-com-kyoh86-xdg
+ go-github-com-imdario-mergo
+ go-github-com-google-shlex
+ go-github-com-go-ini-ini
+ go-github-com-gdamore-tcell-v2
+ go-github-com-gatherstars-com-jwz
+ go-github-com-fsnotify-fsnotify
+ go-github-com-emersion-go-smtp
+ go-github-com-emersion-go-sasl
+ go-github-com-emersion-go-pgpmail
+ go-github-com-emersion-go-message
+ go-github-com-emersion-go-maildir
+ go-github-com-emersion-go-imap-sortthread
+ go-github-com-emersion-go-imap
+ go-github-com-emersion-go-msgauth
+ go-github-com-emersion-go-mbox
+ go-github-com-ddevault-go-libvterm
+ go-github-com-danwakefield-fnmatch
+ go-github-com-creack-pty
+ go-github-com-arran4-golang-ical
+ go-github-com-protonmail-go-crypto
+ go-github-com-syndtr-goleveldb-leveldb
+ go-git-sr-ht-sircmpwn-getopt
+ go-git-sr-ht-rockorager-tcell-term
+ scdoc
+ zoxide))
(home-page "https://git.sr.ht/~rjarry/aerc")
(synopsis "Email client for the terminal")
(description "@code{aerc} is a textual email client for terminals. It
base-commit: fc6bdaad57bf91609849623c5f485403c030cb49
--
2.41.0