[PATCH] services: xvnc: Do not specify display number when using inetd

  • Done
  • quality assurance status badge
Details
2 participants
  • Thompson, David
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Thompson, David
Severity
normal

Debbugs page

Thompson, David wrote 1 years ago
(name . Ryan Prior via Guix-patches)(address . guix-patches@gnu.org)
CAJ=Rwfadsuv18Gb0i_-OrkLq4kT+j_+z4v2L7ftDra_MG0dPXw@mail.gmail.com
Hey everyone,

I've been struggling to get VNC working with multiple users. Upon
digging into it I realized that it's because the X display number is
fixed in the xvnc service, even when in inetd mode, so only the first
user who connects gets a desktop and everyone else gets an error. By
omitting the display number when using inetd, xvnc just picks an
unused display and I'm now able to log in with multiple user accounts.

The patch is a one-liner and hopefully not very controversial. :)

- Dave
From a7aa18cbb8050ae228aeca2b4a1f724a797983ac Mon Sep 17 00:00:00 2001
Message-ID: <a7aa18cbb8050ae228aeca2b4a1f724a797983ac.1700088462.git.dthompson2@worcester.edu>
From: David Thompson <dthompson2@worcester.edu>
Date: Wed, 15 Nov 2023 17:46:34 -0500
Subject: [PATCH] services: xvnc: Do not specify display number when using
inetd.

* gnu/services/vnc.scm (xvnc-configuration->command-line-arguments): Omit X
display number when inetd? is #t.

Change-Id: I0fc8e3068f3ae22421e60e96bd40e3b6e477ca99
---
gnu/services/vnc.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/services/vnc.scm b/gnu/services/vnc.scm
index f90bd7258f..8b9ad0b179 100644
--- a/gnu/services/vnc.scm
+++ b/gnu/services/vnc.scm
@@ -149,7 +149,7 @@ (define (xvnc-configuration->command-line-arguments config)
(xvnc display-number geometry depth port ipv4? ipv6? password-file xdmcp?
inetd? frame-rate security-types localhost? log-level extra-options)
#~(list #$(file-append xvnc "/bin/Xvnc")
- #$(format #f ":~a" display-number)
+ #$@(if inetd? '() (list (format #f ":~a" display-number)))
"-geometry" #$geometry
"-depth" #$(number->string depth)
#$@(if inetd?

base-commit: d987b75618a62c95c030e7ca53e0972e700c4f06
--
2.41.0
Mathieu Othacehe wrote 1 years ago
(name . Thompson, David)(address . dthompson2@worcester.edu)(address . 67214@debbugs.gnu.org)
87cyvxwvn6.fsf@gnu.org
Hello David,

Toggle quote (3 lines)
> * gnu/services/vnc.scm (xvnc-configuration->command-line-arguments): Omit X
> display number when inetd? is #t.

Seems fair, I think you can go ahead.

Thanks,

Mathieu
Thompson, David wrote 1 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 67214-done@debbugs.gnu.org)
CAJ=RwfZDD5o1WTGFgEPRMy7nxeCr1uxxE1g_aSVPJ1wSUXhJ6w@mail.gmail.com
Hey Mathieu,

On Sat, Nov 25, 2023 at 1:11 PM Mathieu Othacehe <othacehe@gnu.org> wrote:
Toggle quote (9 lines)
>
>
> Hello David,
>
> > * gnu/services/vnc.scm (xvnc-configuration->command-line-arguments): Omit X
> > display number when inetd? is #t.
>
> Seems fair, I think you can go ahead.

Thanks for the review! Pushed as commit
dce3672f5a8eb440ae61a334384423d1e2ff5e65.

- Dave
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67214@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67214
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help