[PATCH] gnu: add cl-libjpeg-turbo 1.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
cage
Severity
normal

Debbugs page

cage wrote 1 years ago
(address . guix-patches@gnu.org)
a766898e1d8d09d1a915946c19c617624dcef584.1700070522.git.cage-dev@twistfold.it
Change-Id: Id64bd481c1b44a169c037260fc02023c35f15e9d
---
gnu/packages/lisp-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 760d0e9e45..5787188ff5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12132,6 +12132,47 @@ (define-public cl-jpeg
(define-public ecl-cl-jpeg
(sbcl-package->ecl-package sbcl-cl-jpeg))

+(define-public sbcl-jpeg-turbo
+ (let ((commit "f79c646cc266c107bdace53572a31664754c6e0c")
+ (revision "1"))
+ (package
+ (name "sbcl-jpeg-turbo")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shamazmazum/jpeg-turbo/")
+ (commit commit)))
+ (file-name (git-file-name "cl-jpeg-turbo" version))
+ (sha256
+ (base32 "1andd1ibbk3224idnpsnrn96flr5d1wm9ja3di57fs04wn577sag"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-lib-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/jpeg-turbo.lisp"
+ (("\"libturbojpeg\\.so\\.0\"")
+ (string-append "\""
+ (assoc-ref inputs "libjpeg-turbo")
+ "/lib/libturbojpeg.so\""))))))))
+ (inputs
+ `(("cffi" ,sbcl-cffi)
+ ("libjpeg-turbo" ,libjpeg-turbo)))
+ (synopsis "Common Lisp wrapper for libjpeg-turbo")
+ (description
+ "jpeg-turbo is a Common Lisp wrapper for libjpeg-turbo library which provides TurboJPEG API for compressing and decompressing JPEG images.")
+ (home-page "https://github.com/shamazmazum/jpeg-turbo/")
+ (license license:bsd-2))))
+
+(define-public cl-jpeg-turbo
+ (sbcl-package->cl-source-package sbcl-jpeg-turbo))
+
+(define-public ecl-cl-jpeg-turbo
+ (sbcl-package->ecl-package sbcl-jpeg-turbo))
+
(define-public sbcl-png
(let ((commit "11b965fe378fd0561abe3616b18ff03af5179648")
(revision "1"))

base-commit: 66132d6a20b3a8fa4649df338568765540057bd1
--
2.41.0
Guillaume Le Vaillant wrote 1 years ago
(name . cage)(address . cage-dev@twistfold.it)(address . 67205-done@debbugs.gnu.org)
87fs1311l8.fsf@kitej
Patch applied with some style changes (no input labels, use of
search-input-file function, etc) as
b9ec0d4ef98bf1b9f5488a44a79de2cefa26ab9e.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZVjisw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j84ZwD/c2w0hQesrWOIlmc3eCFR+tKoJXIuCHVxi7Pf
1/3E9L0A/RpNYbJoFDvsmjJdlNolLY3dzoyd6jUY1R+Ye51X7Eda
=TFi2
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67205@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67205
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help