[PATCH] gnu: Add python-smbus2.

  • Open
  • quality assurance status badge
Details
One participant
  • Wicki Gabriel (wicg)
Owner
unassigned
Submitted by
Wicki Gabriel (wicg)
Severity
normal
W
W
Wicki Gabriel (wicg) wrote on 15 Nov 2023 18:02
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
ZR0P278MB0268E466AE6541FEB597B6D0C1B1A@ZR0P278MB0268.CHEP278.PROD.OUTLOOK.COM

Attachment: file
From eb6a95d3915c3f7785c8e411764c60d39a7ac609 Mon Sep 17 00:00:00 2001
Message-ID: <eb6a95d3915c3f7785c8e411764c60d39a7ac609.1700067600.git.wicg@zhaw.ch>
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Wed, 15 Nov 2023 17:58:02 +0100
Subject: [PATCH] gnu: Add python-smbus2.

* gnu/packages/python-xyz.scm (python-smbus2): New variable.

Change-Id: Ia43f4a0720e8137fba0632dc021babb3bfac590b
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e521c1580d..0f838528dc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3016,6 +3016,26 @@ (define-public python-caniusepython3
a library.")
(license license:asl2.0)))
+(define-public python-smbus2
+ (package
+ (name "python-smbus2")
+ (version "0.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "smbus2" version))
+ (sha256
+ (base32
+ "0fl0dazyg78yqz4lljd252kva3l8ip4lw95jlyvkqdhsis52iwin"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/kplindegaard/smbus2")
+ (synopsis "Drop-in replacement for smbus-cffi/smbus-python in pure Python")
+ (description "This package provides a Python library to access
+@acronym{I2C, Inter-Integrated Circuit} and @acronym{SMBus, System +
+Management Bus} devices on Linux. It is functionally equivalent to
+python-smbus and provides the same interface and syntax.")
+ (license license:expat)))
+
(define-public python-diskcache
(package
(name "python-diskcache")

base-commit: 7e6580670bc615d89d0216ebddfb6ba81feb0238
--
2.41.0
?