Change-Id: I9435787b234f90cb3d59ff6b65b7a96a533aea03
---
gnu/packages/vim.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (41 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 469c8b64cb..d0877033b9 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1423,3 +1423,34 @@ (define-public vim-nerdcommenter
operations and styles which are invoked via key mappings and a menu. These
operations are available for most filetypes.")
(license license:cc0)))
+
+(define-public vim-commentary
+ (let ((commit "e87cd90dc09c2a203e13af9704bd0ef79303d755")
+ (revision "1"))
+ (package
+ (name "vim-commentary")
+ (version (string-append "1.3-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tpope/vim-commentary")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "09kzc89iwkgsi4wvjxk56fis462kkz5chcl9sl4hdbmpa1f41wy0"))))
+ (build-system vim-build-system)
+ (arguments
+ (list
+ #:plugin-name "commentary.vim"))
+ (synopsis "Vim plugin for commenting out code")
+ (description
+ "Comment stuff out. Use gcc to comment out a line (takes a count), gc to
+comment out the target of a motion (for example, gcap to comment out a
+paragraph), gc in visual mode to comment out the selection, and gc in operator
+pending mode to target a comment. You can also use it as a command, either with
+a range like :7,17Commentary, or as part of a :global invocation like with
+:g/TODO/Commentary.")
+ (home-page "https://www.vim.org/scripts/script.php?script_id=3695")
+ (license license:vim))))
--
2.41.0