[PATCH 0/6] *** Add vim plugins ***

  • Open
  • quality assurance status badge
Details
One participant
  • Nathan Merkley
Owner
unassigned
Submitted by
Nathan Merkley
Severity
normal
N
N
Nathan Merkley wrote on 15 Nov 2023 01:21
(address . guix-patches@gnu.org)(name . Nathan Merkley)(address . nathanmerkley@gmail.com)
cover.1700006719.git.nathanmerkley@gmail.com
This adds a handful of vim packages that I like to use.

Since this is my first time submitting a patch, apologies in advance if
I have done anything incorrectly, I'll be happy to correct anything I
did wrong

Nathan Merkley (6):
* gnu/packages/vim.scm (vim-commentary): New variable.
* gnu/packages/vim.scm (vim-guile): New variable
* gnu/packages/vim.scm (vim-dhall-vim): New variable
* gnu/packages/vim.scm (vim-mundo): New variable
* gnu/packages/vim.scm (vim-zig): New variable
* gnu/packages/vim.scm (vim-plantuml-syntax): New variable

gnu/packages/vim.scm | 168 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 168 insertions(+)


base-commit: bd0f2173210416e86281c1de8789e7cdab66dd57
--
2.41.0
N
N
Nathan Merkley wrote on 7 Dec 2023 17:54
[PATCH 1/6] * gnu/packages/vim.scm (vim-commentary): New variable.
(address . 67186@debbugs.gnu.org)(name . Nathan Merkley)(address . nathanmerkley@gmail.com)
20a47b3f14097c25a6b3602ab63217bb377ca972.1700006719.git.nathanmerkley@gmail.com
Change-Id: I9435787b234f90cb3d59ff6b65b7a96a533aea03
---
gnu/packages/vim.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 469c8b64cb..d0877033b9 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1423,3 +1423,34 @@ (define-public vim-nerdcommenter
operations and styles which are invoked via key mappings and a menu. These
operations are available for most filetypes.")
(license license:cc0)))
+
+(define-public vim-commentary
+ (let ((commit "e87cd90dc09c2a203e13af9704bd0ef79303d755")
+ (revision "1"))
+ (package
+ (name "vim-commentary")
+ (version (string-append "1.3-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tpope/vim-commentary")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "09kzc89iwkgsi4wvjxk56fis462kkz5chcl9sl4hdbmpa1f41wy0"))))
+ (build-system vim-build-system)
+ (arguments
+ (list
+ #:plugin-name "commentary.vim"))
+ (synopsis "Vim plugin for commenting out code")
+ (description
+ "Comment stuff out. Use gcc to comment out a line (takes a count), gc to
+comment out the target of a motion (for example, gcap to comment out a
+paragraph), gc in visual mode to comment out the selection, and gc in operator
+pending mode to target a comment. You can also use it as a command, either with
+a range like :7,17Commentary, or as part of a :global invocation like with
+:g/TODO/Commentary.")
+ (home-page "https://www.vim.org/scripts/script.php?script_id=3695")
+ (license license:vim))))
--
2.41.0
N
N
Nathan Merkley wrote on 7 Dec 2023 17:54
[PATCH 2/6] * gnu/packages/vim.scm (vim-guile): New variable
(address . 67186@debbugs.gnu.org)(name . Nathan Merkley)(address . nathanmerkley@gmail.com)
2b6a3e5c57dda4ad32dec18810c0a57b42f6bdb9.1700006719.git.nathanmerkley@gmail.com
Change-Id: I2f69a563681693de9af563caa545f6421f61a093
---
gnu/packages/vim.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index d0877033b9..38e651388f 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1454,3 +1454,32 @@ (define-public vim-commentary
:g/TODO/Commentary.")
(home-page "https://www.vim.org/scripts/script.php?script_id=3695")
(license license:vim))))
+
+(define-public vim-guile
+ (let ((commit "f76959a9dbdc69cde018901de82ac5a3d443843c")
+ (revision "1"))
+ (package
+ (name "vim-guile")
+ (version (string-append "0.0.0-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/HiPhish/guile.vim")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "1pqlhssdnpd8ngjc5bssma7ddjhffvh8hj67gchmyyxr5jfxwdq9"))))
+ (build-system vim-build-system)
+ (arguments
+ (list
+ #:plugin-name "guile.vim"))
+ (synopsis "Syntax highlighting for GNU Guile")
+ (description
+ "This plugin extends Vim's Scheme support to include the additions to
+the language provided by the GNU Guile implementation. The plugin automatically
+detects whether a Scheme file is a Guile file and adds syntax highlighting for
+Guile's special forms.")
+ (home-page "https://github.com/HiPhish/guile.vim")
+ (license license:expat))))
--
2.41.0
N
N
Nathan Merkley wrote on 7 Dec 2023 17:54
[PATCH 3/6] * gnu/packages/vim.scm (vim-dhall-vim): New variable
(address . 67186@debbugs.gnu.org)(name . Nathan Merkley)(address . nathanmerkley@gmail.com)
f585920592bb58d01c8884ecd967e7cf7998a24a.1700006719.git.nathanmerkley@gmail.com
Change-Id: I7bb32594546eb61f781d69a308aa866e4ce78de9
---
gnu/packages/vim.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 38e651388f..44ffc7bef4 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1483,3 +1483,30 @@ (define-public vim-guile
Guile's special forms.")
(home-page "https://github.com/HiPhish/guile.vim")
(license license:expat))))
+
+(define-public vim-dhall-vim
+ (let ((commit "68500ef46ff3706f46c99db3be7a0c8abcf6a3ae")
+ (revision "1"))
+ (package
+ (name "vim-dhall-vim")
+ (version (string-append "0.0.0-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vmchale/dhall-vim")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "0lwna4kcq7davfvh3535n8wl9jxkjm7cg6jgpisd17kvagihh8qw"))))
+ (build-system vim-build-system)
+ (arguments
+ (list
+ #:plugin-name "dhall-vim"))
+ (synopsis "Vim configuration for Dhall")
+ (description
+ "A vim plugin to provide support and syntax hightlighting for the Dhall
+programming language")
+ (home-page "https://github.com/vmchale/dhall-vim")
+ (license license:bsd-3))))
--
2.41.0
N
N
Nathan Merkley wrote on 7 Dec 2023 17:54
[PATCH 4/6] * gnu/packages/vim.scm (vim-mundo): New variable
(address . 67186@debbugs.gnu.org)(name . Nathan Merkley)(address . nathanmerkley@gmail.com)
34322d68337925db74fc846bf01cd1cc44f5a10a.1700006719.git.nathanmerkley@gmail.com
Change-Id: Ic0a96540117c55731ef8f615e916a2ef41a9d0c0
---
gnu/packages/vim.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 44ffc7bef4..3f8e673b69 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1510,3 +1510,28 @@ (define-public vim-dhall-vim
programming language")
(home-page "https://github.com/vmchale/dhall-vim")
(license license:bsd-3))))
+
+(define-public vim-mundo
+ (let ((commit "b53d35fb5ca9923302b9ef29e618ab2db4cc675e")
+ (revision "1"))
+ (package
+ (name "vim-mundo")
+ (version (string-append "3.1.0-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/simnalamburt/vim-mundo")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "1dwrarcxrh8in78igm036lpvyww60c93vmmlk8h054i3v2p8vv59"))))
+ (build-system vim-build-system)
+ (arguments
+ (list
+ #:plugin-name "Mundo"))
+ (synopsis "Vim undo tree visualizer")
+ (description "A Vim plugin to visualize the Vim undo tree")
+ (home-page "https://simnalamburt.github.io/vim-mundo/")
+ (license license:gpl2))))
--
2.41.0
N
N
Nathan Merkley wrote on 7 Dec 2023 17:54
[PATCH 5/6] * gnu/packages/vim.scm (vim-zig): New variable
(address . 67186@debbugs.gnu.org)(name . Nathan Merkley)(address . nathanmerkley@gmail.com)
3fccefdb0b8b017e6bb286e65068245289f91ca6.1700006719.git.nathanmerkley@gmail.com
Change-Id: I90fa7377fa15a95553960aabef041ce31ce97650
---
gnu/packages/vim.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 3f8e673b69..054c23bc92 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1535,3 +1535,30 @@ (define-public vim-mundo
(description "A Vim plugin to visualize the Vim undo tree")
(home-page "https://simnalamburt.github.io/vim-mundo/")
(license license:gpl2))))
+
+(define-public vim-zig
+ (let ((commit "54c216e5306a5c3878a60596aacb94dca8652ab9")
+ (revision "1"))
+ (package
+ (name "vim-zig")
+ (version (string-append "0.0.0-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ziglang/zig.vim")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "1nxwjyn3ps3c2abffai5cql3czl4kah4cin0g30damy1k99ypncb"))))
+ (build-system vim-build-system)
+ (arguments
+ (list
+ #:plugin-name "zig.vim"))
+ (synopsis "Vim configuration for Zig")
+ (description
+ "File detection and syntax highlighting for the zig programming
+language.")
+ (home-page "https://github.com/ziglang/zig.vim")
+ (license license:expat))))
--
2.41.0
N
N
Nathan Merkley wrote on 7 Dec 2023 17:54
[PATCH 6/6] * gnu/packages/vim.scm (vim-plantuml-syntax): New variable
(address . 67186@debbugs.gnu.org)(name . Nathan Merkley)(address . nathanmerkley@gmail.com)
3eff0346b009e2da5e2b9a39280913fb90df6a26.1700006719.git.nathanmerkley@gmail.com
Change-Id: I3e116520239bb66b1140e5bbd40659b3681f77e6
---
gnu/packages/vim.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 054c23bc92..7886f63e97 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1562,3 +1562,32 @@ (define-public vim-zig
language.")
(home-page "https://github.com/ziglang/zig.vim")
(license license:expat))))
+
+(define-public vim-plantuml-syntax
+ (let ((commit "845abb56dcd3f12afa6eb47684ef5ba3055802b8")
+ (revision "1"))
+ (package
+ (name "vim-plantuml-syntax")
+ (version (string-append "0.0.0-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aklt/plantuml-syntax")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32 "0d2frv6knkj4bjavq2c2kx8qdnmcq0d8l04a5z7bpqwkmrrhd31f"))))
+ (build-system vim-build-system)
+ (arguments
+ (list
+ #:plugin-name "plantuml-syntax"))
+ (synopsis "Syntax highlighting for PlantUML")
+ (description
+ "This is a vim syntax file for PlantUML. The filetype will be set to
+plantuml for *.pu, *.uml, *.puml, *.iuml or *.plantuml files or if the first
+line of a file contains @@startuml. Additionally the makeprg is set to plantuml
+assuming you have this executable in your path.")
+ (home-page "https://github.com/aklt/plantuml-syntax")
+ (license license:vim))))
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67186@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67186
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch