[PATCH] gnu: Add python-canmatrix.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal

Debbugs page

Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
87fs189gez.fsf@troyfigiel.com
* gnu/packages/python-xyz.scm (python-canmatrix): New variable.

Change-Id: I96192f7304388aefe1b5cc358d462d42120ca3a0
---
gnu/packages/python-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e521c1580d..10182893cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -145,6 +145,7 @@
;;; Copyright © c4droid <c4droid@foxmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name>
+;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2955,6 +2956,39 @@ (define-public python-can
sending and receiving messages on a CAN bus.")
(license license:lgpl3+)))

+(define-public python-canmatrix
+ (package
+ (name "python-canmatrix")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "canmatrix" version))
+ (sha256
+ (base32 "046dzmggfm6h0fvfvwrblvih0blhc70ma0pqxzry3cphc08jvsrg"))
+ ;; The test suite uder ./test is a legacy test suite. The new test
+ ;; suite is defined under src/canmatrix/tests.
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "test"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs (list python-attrs python-click python-future
+ python-six))
+ (native-inputs (list python-lxml python-pytest python-xlrd python-xlwt))
+ (home-page "https://github.com/ebroecker/canmatrix")
+ (synopsis "Implements a CAN matrix object in Python")
+ (description
+ "This package implements a CAN matrix object in Python which describes the
+CAN-communication and its needed objects such as board units, frames, signals
+and values. It also includes two command line tools (canconvert and
+cancompare) for converting and comparing CAN databases.")
+ (license license:bsd-2)))
+
(define-public python-canopen
(package
(name "python-canopen")
--
2.40.1
Ludovic Courtès wrote 1 years ago
(name . Troy Figiel)(address . troy@troyfigiel.com)(address . 67183-done@debbugs.gnu.org)
877cm41720.fsf@gnu.org
Hi,

Troy Figiel <troy@troyfigiel.com> skribis:

Toggle quote (4 lines)
> * gnu/packages/python-xyz.scm (python-canmatrix): New variable.
>
> Change-Id: I96192f7304388aefe1b5cc358d462d42120ca3a0

Applied with the cosmetic changes below, following

Thanks,
Ludo’.
Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ea1b56fa82..746ecccc5a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2981,12 +2981,13 @@ (define-public python-canmatrix
python-six))
(native-inputs (list python-lxml python-pytest python-xlrd python-xlwt))
(home-page "https://github.com/ebroecker/canmatrix")
- (synopsis "Implements a CAN matrix object in Python")
+ (synopsis "@acronym{CAN, Controller Area Network} matrices in Python")
(description
- "This package implements a CAN matrix object in Python which describes the
-CAN-communication and its needed objects such as board units, frames, signals
-and values. It also includes two command line tools (canconvert and
-cancompare) for converting and comparing CAN databases.")
+ "This package implements a @acronym{CAN, Controller Area Network} matrix
+object in Python which describes the CAN-communication and its needed objects
+such as board units, frames, signals, and values. It also includes two
+command-line tools (@command{canconvert} and @command{cancompare}) for
+converting and comparing CAN databases.")
(license license:bsd-2)))
(define-public python-canopen
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67183@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67183
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help