Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/python-xyz.scm (python-canmatrix): New variable.
Change-Id: I96192f7304388aefe1b5cc358d462d42120ca3a0
---
gnu/packages/python-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (52 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e521c1580d..10182893cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -145,6 +145,7 @@
;;; Copyright © c4droid <c4droid@foxmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name>
+;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2955,6 +2956,39 @@ (define-public python-can
sending and receiving messages on a CAN bus.")
(license license:lgpl3+)))
+(define-public python-canmatrix
+ (package
+ (name "python-canmatrix")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "canmatrix" version))
+ (sha256
+ (base32 "046dzmggfm6h0fvfvwrblvih0blhc70ma0pqxzry3cphc08jvsrg"))
+ ;; The test suite uder ./test is a legacy test suite. The new test
+ ;; suite is defined under src/canmatrix/tests.
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "test"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs (list python-attrs python-click python-future
+ python-six))
+ (native-inputs (list python-lxml python-pytest python-xlrd python-xlwt))
+ (home-page "https://github.com/ebroecker/canmatrix")
+ (synopsis "Implements a CAN matrix object in Python")
+ (description
+ "This package implements a CAN matrix object in Python which describes the
+CAN-communication and its needed objects such as board units, frames, signals
+and values. It also includes two command line tools (canconvert and
+cancompare) for converting and comparing CAN databases.")
+ (license license:bsd-2)))
+
(define-public python-canopen
(package
(name "python-canopen")
--
2.40.1